]> git.pld-linux.org Git - packages/ruby-ohai.git/blobdiff - ruby-ohai.spec
drop virtualization-vserver.patch
[packages/ruby-ohai.git] / ruby-ohai.spec
index abfd6ec118671df5bc3a8306ef6b26c48d6cdf54..6d86120ee8686d40d6c18049abb8c39a64bd1ada 100644 (file)
@@ -1,23 +1,50 @@
-%define gemname ohai
+#
+# Release Notes: https://github.com/opscode/ohai/blob/master/CHANGELOG.md
+#
+# Conditional build:
+%bcond_with    tests           # build without tests
+
+%define pkgname ohai
 Summary:       Profiles your system and emits JSON
-Name:          ruby-%{gemname}
-Version:       0.6.10
-Release:       1
+Name:          ruby-%{pkgname}
+Version:       7.6.0
+Release:       0.3
 License:       Apache v2.0
 Group:         Development/Languages
-Source0:       http://gems.rubyforge.org/gems/%{gemname}-%{version}.gem
-# Source0-md5: 01dea23cd76c6c7e609923810dce9607
-# Request to include: http://tickets.opscode.com/browse/OHAI-169
-Source1:       ohai.1
-URL:           http://docs.opscode.com/ohai.html
+Source0:       https://github.com/opscode/ohai/archive/%{version}/%{pkgname}-%{version}.tar.gz
+# Source0-md5: b28339ec7f835a2ed4ec0f876178fb14
+Patch1:                platform-pld.patch
+Patch2:                soft-net-dhcp.patch
+URL:           http://docs.getchef.com/ohai.html
 BuildRequires: rpm-rubyprov
-BuildRequires: rpmbuild(macros) >= 1.656
-Requires:      ruby-extlib
-Requires:      ruby-json
+BuildRequires: rpmbuild(macros) >= 1.665
+BuildRequires: ruby-rake
+BuildRequires: sed >= 4.0
+# rake gem uses installed ohai version not version we intend to build!
+BuildConflicts:        ruby-ohai
+%if %{with tests}
+BuildRequires: ruby-ffi >= 1.9
+BuildRequires: ruby-ffi-yajl >= 1.1
+BuildRequires: ruby-ipaddress
+BuildRequires: ruby-mixlib-config
+BuildRequires: ruby-mixlib-log
+BuildRequires: ruby-mixlib-shellout >= 2.0.0
+BuildRequires: ruby-rspec
+BuildRequires: ruby-systemu >= 2.6.4
+%endif
+Requires:      iproute2
+Requires:      lsb-release
+Requires:      mount
+Requires:      ruby-ffi >= 1.9
+Requires:      ruby-ffi-yajl >= 1.1
+Requires:      ruby-ipaddress
+Requires:      ruby-mime-types >= 1.16
 Requires:      ruby-mixlib-cli
-Requires:      ruby-mixlib-config
+Requires:      ruby-mixlib-config >= 2.0
 Requires:      ruby-mixlib-log
-Requires:      ruby-systemu
+Requires:      ruby-mixlib-shellout >= 2.0.0
+Requires:      ruby-systemu >= 2.6.4
+Suggests:      ruby-net-dhcp
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -35,38 +62,47 @@ Requires:   %{name} = %{version}-%{release}
 This package contains documentation for %{name}.
 
 %prep
-%setup -q
+%setup -q -n ohai-%{version}
+%patch1 -p1
+%patch2 -p1
+%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
+
+# no plist and not darwin so don't care
+rm spec/unit/plugins/darwin/system_profiler_spec.rb
+
+# can't figure how to fix -r rubygems does not help
+# ohai-6.16.0/spec/unit/plugins/ruby_spec.rb:52:in `block in <top (required)>': uninitialized cons tant Gem (NameError)
+rm spec/unit/plugins/ruby_spec.rb
 
 %build
+rake -Ilib gem
+%{__tar} -xmf pkg/ohai-%{version}*.gem
+%__gem_helper spec
+
 %if %{with tests}
 # Occasionally fails with "undefined method `rfc2822' for nil:NilClass" during
 # mock. Unsure why - disable for now.
-sed -i 's^Time.should_receive(:now)^^' spec/ohai/plugins/ohai_time_spec.rb
-rake spec
+#sed -i 's^Time.should_receive(:now)^^' spec/ohai/plugins/ohai_time_spec.rb
+LC_ALL=en_US.utf8 \
+rake -r rubygems spec
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
+install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir},%{_mandir}/man1}
 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
-
-# http://tickets.opscode.com/browse/OHAI-169
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-install -Dp %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/ohai.1
+cp -p docs/man/man1/ohai.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -p %{pkgname}-%{version}*.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.rdoc
+%doc README.md CHANGELOG.md RELEASE_NOTES.md OHAI_MVPS.md NOTICE
 %attr(755,root,root) %{_bindir}/ohai
 %{_mandir}/man1/ohai.1*
-%{ruby_vendorlibdir}/ohai.rb
-%{ruby_vendorlibdir}/ohai
-
-%if 0
-%files doc
-%defattr(644,root,root,755)
-%endif
+%{ruby_vendorlibdir}/%{pkgname}.rb
+%{ruby_vendorlibdir}/%{pkgname}
+%{ruby_specdir}/%{pkgname}-%{version}*.gemspec
This page took 0.062886 seconds and 4 git commands to generate.