]> git.pld-linux.org Git - packages/rsync.git/blobdiff - rsync.spec
- divided rsync into rsync and rsyncd packages
[packages/rsync.git] / rsync.spec
index 3f1eb05eca5f3944bd98565528c4cbde9c5b2e44..3fe4c012df9f403c80c58645e783f0c670c22c82 100644 (file)
@@ -1,14 +1,21 @@
 Summary:       Program for efficient remote updates of files.
 Summary(pl):   Program efektywnego modyfikowania plików na zdalnym komputerze.
 Name:          rsync
-Version:       2.3.1
-Release:       3
-Copyright:     GPL
-Group:         Applications/Networking
-Group(pl):     Aplikacje/Sieciowe
-Source:                ftp://samba.anu.edu.au/pub/rsync/%{name}-%{version}.tar.gz
+Version:       2.4.3
+Release:       2
+License:       GPL
+Group:         Daemons
+Group(pl):     Serwery
+Source0:       ftp://samba.anu.edu.au/pub/rsync/%{name}-%{version}.tar.gz
+Source1:       rsync.inet
+Patch0:                rsync-config.patch
+Patch1:                rsync-man.patch
+Patch2:                rsync-configure.patch
+Patch3:                http://www.misiek.eu.org/ipv6/rsync-2.4.3-ipv6-20000523.patch.gz
 URL:           http://samba.anu.edu.au/rsync/
-BuildRoot:     /tmp/%{name}-%{version}-root
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define _sysconfdir /etc/rsyncd
 
 %description
 rsync is a replacement for rcp that has many more features.
@@ -19,46 +26,97 @@ differences in the files across the link, without requiring that both
 sets of files are present at one of the ends of the link beforehand.
 
 A technical report describing the rsync algorithm is included with
-this package. 
+this package.
 
 %description -l pl
-Rsync jest zamiennikiem programu rcp i jest bardziej rozbudowan± sk³adniê
-poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w czasie komunikacji 
-i transportu plików do systemu zdalnego. Dokumentacja techniczna nowego 
-algorytmu zosta³a równie¿ do³±czona do pakietu.
+Rsync jest zamiennikiem programu rcp i jest bardziej rozbudowan±
+sk³adniê poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w
+czasie komunikacji i transportu plików do systemu zdalnego.
+Dokumentacja techniczna nowego algorytmu zosta³a równie¿ do³±czona do
+pakietu.
+
+%package -n rsyncd
+Summary:       Files necessary to run rsync in daemon mode
+Summary(pl):   Pliki niezbêdne do uruchomienia rsynca w trybie serwera
+Group:         Daemons
+Group(pl):     Serwery
+Requires:      %{name}
+Requires:      rc-inetd
+
+%description -n rsyncd
+rsync is a replacement for rcp that has many more features.
+
+rsync uses the "rsync algorithm" which provides a very fast method for
+bringing remote files into sync. It does this by sending just the
+differences in the files across the link, without requiring that both
+sets of files are present at one of the ends of the link beforehand.
+
+A technical report describing the rsync algorithm is included with
+this package.
+
+%description -n rsyncd -l pl
+Rsync jest zamiennikiem programu rcp i jest bardziej rozbudowan±
+sk³adniê poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w
+czasie komunikacji i transportu plików do systemu zdalnego.
+Dokumentacja techniczna nowego algorytmu zosta³a równie¿ do³±czona do
+pakietu.
 
 %prep
-%setup -q
+%setup  -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
-./configure %{_target_platform} \
-       --prefix=%{_prefix}
-make 
+autoconf 
+LDFLAGS="-s"; export LDFLAGS
+
+%configure
+%{__make} 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make install prefix=$RPM_BUILD_ROOT/usr
+%{__make} install \
+       prefix=$RPM_BUILD_ROOT%{_prefix} \
+       mandir=$RPM_BUILD_ROOT%{_mandir} \
+       bindir=$RPM_BUILD_ROOT%{_sbindir}
+
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd}
+
+:> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.conf
+:> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.secrets
 
-strip $RPM_BUILD_ROOT%{_bindir}/rsync
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/rsyncd
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
-       README
+gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* README 
+
+%post -n rsyncd
+if [ -f /var/lock/subsys/rc-inetd ]; then
+        /etc/rc.d/init.d/rc-inetd restart 1>&2
+else
+        echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
+fi
+
+%postun -n rsyncd
+if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
+       /etc/rc.d/init.d/rc-inetd reload 1>&2
+fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README
-%attr(755,root,root) %{_bindir}/rsync
-%{_mandir}/man[15]/*
-
-%changelog
-* Wed Jun  9 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.3.1-3]
-- based on spec from RH contrib (witten by Douglas N. Arnold
-  <dna@math.psu.edu>),
-- pl translation by Wojtek ¦lusarczyk <wojtek@shadow.eu.org>,
-- spec rewrited by PLD team.
+%doc README.gz 
+%attr(755,root,root) %{_sbindir}/*
+%{_mandir}/man1/*
+
+%files -n rsyncd
+%defattr(644,root,root,755)
+%dir %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
+%attr(640,root,root) /etc/sysconfig/rc-inetd/rsyncd
+%{_mandir}/man5/*
This page took 0.070922 seconds and 4 git commands to generate.