]> git.pld-linux.org Git - packages/rsync.git/blobdiff - rsync.spec
- divided rsync into rsync and rsyncd packages
[packages/rsync.git] / rsync.spec
index 312d9e7c0d37d1785f79fd2f85ee11a451aa598f..3fe4c012df9f403c80c58645e783f0c670c22c82 100644 (file)
@@ -1,12 +1,21 @@
-Summary:     Program for efficient remote updates of files.
-Name:        rsync
-Version:     2.1.1
-Release:     1
-Copyright:   GPL
-Group:       Applications/Networking
-Source:             ftp://samba.anu.edu.au/pub/rsync/%{name}-%{version}.tar.gz
-URL:         http://samba.anu.edu.au/rsync
-BuildRoot:   /tmp/%{name}-%{version}-root
+Summary:       Program for efficient remote updates of files.
+Summary(pl):   Program efektywnego modyfikowania plików na zdalnym komputerze.
+Name:          rsync
+Version:       2.4.3
+Release:       2
+License:       GPL
+Group:         Daemons
+Group(pl):     Serwery
+Source0:       ftp://samba.anu.edu.au/pub/rsync/%{name}-%{version}.tar.gz
+Source1:       rsync.inet
+Patch0:                rsync-config.patch
+Patch1:                rsync-man.patch
+Patch2:                rsync-configure.patch
+Patch3:                http://www.misiek.eu.org/ipv6/rsync-2.4.3-ipv6-20000523.patch.gz
+URL:           http://samba.anu.edu.au/rsync/
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define _sysconfdir /etc/rsyncd
 
 %description
 rsync is a replacement for rcp that has many more features.
@@ -17,67 +26,97 @@ differences in the files across the link, without requiring that both
 sets of files are present at one of the ends of the link beforehand.
 
 A technical report describing the rsync algorithm is included with
-this package. 
+this package.
+
+%description -l pl
+Rsync jest zamiennikiem programu rcp i jest bardziej rozbudowan±
+sk³adniê poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w
+czasie komunikacji i transportu plików do systemu zdalnego.
+Dokumentacja techniczna nowego algorytmu zosta³a równie¿ do³±czona do
+pakietu.
+
+%package -n rsyncd
+Summary:       Files necessary to run rsync in daemon mode
+Summary(pl):   Pliki niezbêdne do uruchomienia rsynca w trybie serwera
+Group:         Daemons
+Group(pl):     Serwery
+Requires:      %{name}
+Requires:      rc-inetd
+
+%description -n rsyncd
+rsync is a replacement for rcp that has many more features.
+
+rsync uses the "rsync algorithm" which provides a very fast method for
+bringing remote files into sync. It does this by sending just the
+differences in the files across the link, without requiring that both
+sets of files are present at one of the ends of the link beforehand.
+
+A technical report describing the rsync algorithm is included with
+this package.
+
+%description -n rsyncd -l pl
+Rsync jest zamiennikiem programu rcp i jest bardziej rozbudowan±
+sk³adniê poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w
+czasie komunikacji i transportu plików do systemu zdalnego.
+Dokumentacja techniczna nowego algorytmu zosta³a równie¿ do³±czona do
+pakietu.
 
 %prep
-%setup -q
+%setup  -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
-./configure --prefix=/usr
-make CFLAGS="$RPM_OPT_FLAGS"
-strip rsync
-latex tech_report
-dvips tech_report -o
+autoconf 
+LDFLAGS="-s"; export LDFLAGS
+
+%configure
+%{__make} 
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/usr/{bin,man/man{1,5}}
-install rsync $RPM_BUILD_ROOT/usr/bin
-install rsync.1 $RPM_BUILD_ROOT/usr/man/man1
-install rsyncd.conf.5 $RPM_BUILD_ROOT/usr/man/man5
+
+%{__make} install \
+       prefix=$RPM_BUILD_ROOT%{_prefix} \
+       mandir=$RPM_BUILD_ROOT%{_mandir} \
+       bindir=$RPM_BUILD_ROOT%{_sbindir}
+
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd}
+
+:> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.conf
+:> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.secrets
+
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/rsyncd
+
+gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* README 
+
+%post -n rsyncd
+if [ -f /var/lock/subsys/rc-inetd ]; then
+        /etc/rc.d/init.d/rc-inetd restart 1>&2
+else
+        echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
+fi
+
+%postun -n rsyncd
+if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
+       /etc/rc.d/init.d/rc-inetd reload 1>&2
+fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-
-%attr(644, root, root, 755) %doc tech_report.ps README
-%attr(755, root, root) /usr/bin/rsync
-%attr(644, root, root) /usr/man/man[15]/*
-
-%changelog
-* Fri Sep 18 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.1.1-1]
-- added -q %setup parameter,
-- changed Buildroot to /tmp/%%{name}-%%{version}-root,
-- added using %%{name} and %%{version} in Source,
-- added using $RPM_OPT_FLAGS during compile,
-- added full %attr description in %files.
-
-* Thu Jun 18 1998 Douglas N. Arnold <dna@math.psu.edu>
-Upgrade to rsync version 2.0.18
-
-* Sat May 16 1998 John H Terpstra <jht@aquasoft.com.au>
-  Upgraded to Rsync 2.0.6
-    -new feature anonymous rsync
-
-* Mon Apr  6 1998 Douglas N. Arnold <dna@math.psu.edu>
-Upgrade to rsync version 1.7.2.
-
-* Sun Mar  1 1998 Douglas N. Arnold <dna@math.psu.edu>
-Built 1.6.9-1 based on the 1.6.3-2 spec file of John A. Martin.
-Changes from 1.6.3-2 packaging: added latex and dvips commands
-to create tech_report.ps.
-
-* Mon Aug 25 1997 John A. Martin <jam@jamux.com>
-Built 1.6.3-2 after finding no rsync-1.6.3-1.src.rpm although there
-was an ftp://ftp.redhat.com/pub/contrib/alpha/rsync-1.6.3-1.alpha.rpm
-showing no packager nor signature but giving 
-"Source RPM: rsync-1.6.3-1.src.rpm".
-
-Changes from 1.6.2-1 packaging: added '$RPM_OPT_FLAGS' to make, strip
-to '%build', removed '%prefix'.
-
-* Thu Apr 10 1997 Michael De La Rue <miked@ed.ac.uk>
-rsync-1.6.2-1 packaged.  (This entry by jam to credit Michael for the
-previous package(s).)
+%defattr(644,root,root,755)
+%doc README.gz 
+%attr(755,root,root) %{_sbindir}/*
+%{_mandir}/man1/*
+
+%files -n rsyncd
+%defattr(644,root,root,755)
+%dir %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
+%attr(640,root,root) /etc/sysconfig/rc-inetd/rsyncd
+%{_mandir}/man5/*
This page took 0.127629 seconds and 4 git commands to generate.