]> git.pld-linux.org Git - packages/rsync.git/blobdiff - rsync.spec
- divided rsync into rsync and rsyncd packages
[packages/rsync.git] / rsync.spec
index 1f5a5c23d98c4ca4b131f8db4ebec401d84e5244..3fe4c012df9f403c80c58645e783f0c670c22c82 100644 (file)
@@ -1,17 +1,21 @@
 Summary:       Program for efficient remote updates of files.
 Summary(pl):   Program efektywnego modyfikowania plików na zdalnym komputerze.
 Name:          rsync
-Version:       2.3.1
-Release:       4
-Copyright:     GPL
+Version:       2.4.3
+Release:       2
+License:       GPL
 Group:         Daemons
 Group(pl):     Serwery
-Source:                ftp://samba.anu.edu.au/pub/rsync/%{name}-%{version}.tar.gz
-Patch0:                rsync-pld.patch
+Source0:       ftp://samba.anu.edu.au/pub/rsync/%{name}-%{version}.tar.gz
+Source1:       rsync.inet
+Patch0:                rsync-config.patch
 Patch1:                rsync-man.patch
-Patch2:                rsync-231-v6-19990520-PLD.patch
-URL:           http://samba.anu.edu.au/rsync
-BuildRoot:     /tmp/%{name}-%{version}-root
+Patch2:                rsync-configure.patch
+Patch3:                http://www.misiek.eu.org/ipv6/rsync-2.4.3-ipv6-20000523.patch.gz
+URL:           http://samba.anu.edu.au/rsync/
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define _sysconfdir /etc/rsyncd
 
 %description
 rsync is a replacement for rcp that has many more features.
@@ -22,68 +26,97 @@ differences in the files across the link, without requiring that both
 sets of files are present at one of the ends of the link beforehand.
 
 A technical report describing the rsync algorithm is included with
-this package. 
+this package.
 
 %description -l pl
-Rsync jest zamiennikiem programu rcp i jest bardziej rozbudowan± sk³adniê
-poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w czasie komunikacji 
-i transportu plików do systemu zdalnego. Dokumentacja techniczna nowego 
-algorytmu zosta³a równie¿ do³±czona do pakietu.
+Rsync jest zamiennikiem programu rcp i jest bardziej rozbudowan±
+sk³adniê poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w
+czasie komunikacji i transportu plików do systemu zdalnego.
+Dokumentacja techniczna nowego algorytmu zosta³a równie¿ do³±czona do
+pakietu.
+
+%package -n rsyncd
+Summary:       Files necessary to run rsync in daemon mode
+Summary(pl):   Pliki niezbêdne do uruchomienia rsynca w trybie serwera
+Group:         Daemons
+Group(pl):     Serwery
+Requires:      %{name}
+Requires:      rc-inetd
+
+%description -n rsyncd
+rsync is a replacement for rcp that has many more features.
+
+rsync uses the "rsync algorithm" which provides a very fast method for
+bringing remote files into sync. It does this by sending just the
+differences in the files across the link, without requiring that both
+sets of files are present at one of the ends of the link beforehand.
+
+A technical report describing the rsync algorithm is included with
+this package.
+
+%description -n rsyncd -l pl
+Rsync jest zamiennikiem programu rcp i jest bardziej rozbudowan±
+sk³adniê poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w
+czasie komunikacji i transportu plików do systemu zdalnego.
+Dokumentacja techniczna nowego algorytmu zosta³a równie¿ do³±czona do
+pakietu.
 
 %prep
 %setup  -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
-aclocal && autoconf 
-
-%define _sysconfdir /etc/rsyncd
-
-%configure --enable-ipv6
+autoconf 
+LDFLAGS="-s"; export LDFLAGS
 
-make 
+%configure
+%{__make} 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make \
-    prefix=$RPM_BUILD_ROOT%{_prefix} \
-    mandir=$RPM_BUILD_ROOT%{_mandir} \
-    bindir=$RPM_BUILD_ROOT%{_sbindir} \
-    install 
+%{__make} install \
+       prefix=$RPM_BUILD_ROOT%{_prefix} \
+       mandir=$RPM_BUILD_ROOT%{_mandir} \
+       bindir=$RPM_BUILD_ROOT%{_sbindir}
 
-strip $RPM_BUILD_ROOT%{_sbindir}/rsync
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd}
 
-install -d $RPM_BUILD_ROOT/etc/rsyncd
+:> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.conf
+:> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.secrets
 
-:> $RPM_BUILD_ROOT/etc/rsyncd/rsyncd.conf
-:> $RPM_BUILD_ROOT/etc/rsyncd/rsyncd.secrets
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/rsyncd
 
 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* README 
 
+%post -n rsyncd
+if [ -f /var/lock/subsys/rc-inetd ]; then
+        /etc/rc.d/init.d/rc-inetd restart 1>&2
+else
+        echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
+fi
+
+%postun -n rsyncd
+if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
+       /etc/rc.d/init.d/rc-inetd reload 1>&2
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc README.gz 
+%attr(755,root,root) %{_sbindir}/*
+%{_mandir}/man1/*
 
-%attr(750,root,root) %dir /etc/rsyncd
-%attr(640,root,root) %ghost /etc/rsyncd/rsyncd.conf
-%attr(600,root,root) %ghost /etc/rsyncd/rsyncd.secrets
-
-%attr(755,root,root) %{_sbindir}/rsync
-
-%{_mandir}/man[15]/*
-
-%changelog
-* Thu Jun 17 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-  [2.3.1-4]
-- FHS 2.0 
-
-* Wed Jun  9 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [2.3.1-3]
-- pl translation by Wojtek ¦lusarczyk <wojtek@shadow.eu.org>,
-- spec rewrited by PLD team.
+%files -n rsyncd
+%defattr(644,root,root,755)
+%dir %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
+%attr(640,root,root) /etc/sysconfig/rc-inetd/rsyncd
+%{_mandir}/man5/*
This page took 0.138468 seconds and 4 git commands to generate.