]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- improved comments
[packages/rpm.git] / rpm.spec
index aa5ead8a67eed2c9213d37fb25c2c1f98d26c5e8..fb697566d0d3706d84ac2cff5d959d5485c7b253 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -23,6 +23,7 @@
 # - headerGet() making poldek segfault http://rpm5.org/cvs/tktview?tn=38,1
 # - rpm doesn't exit when no sources/patches available http://rpm5.org/cvs/tktview?tn=40,1
 # - http://rpm5.org/cvs/tktview?tn=41&_submit=Show
+# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
 #
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
@@ -31,9 +32,9 @@
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
 %bcond_without suggest_tags    # build without Suggest tag (bootstrapping)
-%bcond_with    neon            # build with HTTP/WebDAV support (neon library)
+%bcond_without neon            # build with HTTP/WebDAV support (neon library)
 %bcond_without db              # BerkeleyDB
-%bcond_with    sqlite          # build with SQLite support
+%bcond_without sqlite          # build with SQLite support
 %bcond_with    sqlite_dbapi    # default database backend is sqlite
 %bcond_without system_lua              # use system lua
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
@@ -53,7 +54,7 @@ ERROR
 %define                reqdb_ver       4.7.25
 %define                reqpopt_ver     1.15
 %define                beecrypt_ver    2:4.1.2-4
-%define                sover   5.0
+%define                sover   5.3
 
 Summary:       RPM Package Manager
 Summary(de.UTF-8):     RPM Packet-Manager
@@ -63,12 +64,12 @@ Summary(pt_BR.UTF-8):       Gerenciador de pacotes RPM
 Summary(ru.UTF-8):     Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
-Version:       5.1.9
+Version:       5.3.11
 Release:       0.1
 License:       LGPL
 Group:         Base
-Source0:       http://rpm5.org/files/rpm/rpm-5.1/%{name}-%{version}.tar.gz
-# Source0-md5: 2b6ff8f7abb1fe919402f00cc0ca56f7
+Source0:       http://rpm5.org/files/rpm/rpm-5.3/%{name}-%{version}.tar.gz
+# Source0-md5: 7c1f624c22143324ee372dffd1a209c2
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -138,6 +139,8 @@ Patch38:    %{name}-perl_req-use_base.patch
 Patch39:       %{name}-perl_req-skip_multiline.patch
 Patch40:       %{name}-perl_req-heredocs_pod.patch
 
+Patch41:       vendor-pld.patch
+
 Patch42:       %{name}-old-fileconflicts-behaviour.patch
 
 Patch46:       %{name}-mono.patch
@@ -151,6 +154,10 @@ Patch59:   %{name}-libtool-deps.patch
 Patch60:       %{name}-mimetype.patch
 Patch61:       %{name}-sparc64.patch
 Patch62:       %{name}-gendiff.patch
+Patch63:       %{name}-lua-exit-chroot-correctly.patch
+Patch70:       %{name}-configure-autoconf.patch
+Patch72:       openmp.patch
+Patch100:      fix-automake-1.11.2.patch
 URL:           http://rpm5.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1.4
@@ -158,10 +165,9 @@ BuildRequires:     beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
 %{?with_db:BuildRequires:      db-devel >= %{reqdb_ver}}
 BuildRequires: elfutils-devel >= 0.108
-BuildRequires: gettext-autopoint >= 0.11.4-2
+#BuildRequires:        gettext-autopoint >= 0.11.4-2
 BuildRequires: gettext-devel >= 0.11.4-2
 BuildRequires: keyutils-devel
-BuildRequires: lzma-devel >= 4.999.3
 BuildRequires: libmagic-devel
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
@@ -176,10 +182,11 @@ BuildRequires:    popt-devel >= %{reqpopt_ver}
 %{?with_system_lua:BuildRequires:      lua51-devel >= 5.1.2}
 %{?with_python:BuildRequires:  python-devel >= 1:2.3}
 BuildRequires: python-modules >= 1:2.3
-BuildRequires: rpm-perlprov
 %{?with_python:BuildRequires:  rpm-pythonprov}
 %{?with_sqlite:BuildRequires:  sqlite3-devel}
+BuildRequires: tcl
 BuildRequires: zlib-devel
+BuildRequires: xz-devel
 %if %{with apidocs}
 BuildRequires: doxygen
 BuildRequires: ghostscript
@@ -676,7 +683,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 # compress doc in upstream
 %patch10 -p1
 %{?with_system_lua:%patch11 -p1}
-%patch12 -p1
+#patch12 -p1
 # CHECK ME - macrofiles: ~/etc could be used
 #%%patch14 -p1
 %patch16 -p1
@@ -695,7 +702,7 @@ install %{SOURCE12} scripts/perl.prov
 
 %ifarch i386 i486
 # disable TSC
-%patch26 -p1
+patch26 -p1
 %endif
 %patch27 -p1
 # to port 
@@ -704,9 +711,10 @@ install %{SOURCE12} scripts/perl.prov
 %patch35 -p0
 %patch36 -p1
 %patch37 -p1
-%patch38 -p1
-%patch39 -p1
-%patch40 -p1
+#patch38 -p1 applied
+#patch39 -p1 applied
+#patch40 -p1 applied
+%patch41 -p1
 %patch42 -p1
 %patch46 -p1
 # port to new implementation
@@ -725,6 +733,12 @@ install %{SOURCE12} scripts/perl.prov
 %patch61 -p1
 %endif
 %patch62 -p1
+#patch63 -p1 applied upstream
+%patch70 -p1
+%patch72 -p1 -b .wiget
+
+%patch100 -p1
+
 
 cd scripts
 mv -f perl.req perl.req.in
@@ -771,14 +785,15 @@ awk -f %{SOURCE6} %{SOURCE1}
        --with-bzip2=external \
        --with-beecrypt=external \
        --with-lzma=external \
+       --with-xz=external \
        --with-neon=%{?with_neon:external}%{!?with_neon:no} \
        --with-file=external \
        --with-popt=external \
-       --with-db=%{?with_db:external}%{!?with_db:no} \
-       --with-sqlite=%{?with_sqlite:external}%{!?with_sqlite:no} \
+       --with-db=%{?with_db:internal}%{!?with_db:no} \
+       --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
        --with-dbapi=%{!?with_sqlite_dbapi:db}%{?with_sqlite_dbapi:sqlite} \
        --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
-       --with-pcre=no \
+       --with-pcre=external \
        --with-keyutils=none \
        --without-path-versioned \
        --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.pld:%{_rpmlibdir}/macros.build:%{_rpmlibdir}/%%{_target}/macros:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:~/etc/rpmmacros:~/etc/.rpmmacros:~/.rpmmacros' \
@@ -1054,7 +1069,7 @@ touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
 # move rpm to /bin
 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
 # move essential libs to /lib (libs that /bin/rpm links to)
-for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so; do
+for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
        mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
        ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
 done
@@ -1081,7 +1096,7 @@ rm $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
 # wrong location, not used anyway
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
 # utils dropped in 4.4.8 -- their manuals
-rm $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/rpmgraph.8
+rm $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
 
 %find_lang %{name}
 
@@ -1158,6 +1173,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/rpmpopt*
 %{_rpmlibdir}/macros
 %{_rpmlibdir}/macros.pld
+%{_rpmlibdir}/cpuinfo.yaml
 
 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
 
@@ -1177,6 +1193,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
 %attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
+%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
 
 %files devel
 %defattr(644,root,root,755)
@@ -1203,18 +1220,20 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %files utils
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/rpm2cpio
-%attr(755,root,root) %{_bindir}/rpmcache
 %attr(755,root,root) %{_bindir}/rpmconstant
-%attr(755,root,root) %{_bindir}/rpmdigest
-%attr(755,root,root) %{_bindir}/rpmgrep
-%attr(755,root,root) %{_bindir}/rpmrepo
-%attr(755,root,root) %{_bindir}/rpmmtree
-%attr(755,root,root) %{_rpmlibdir}/debugedit
 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
-%attr(755,root,root) %{_rpmlibdir}/rpmcmp
 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
-%attr(755,root,root) %{_rpmlibdir}/rpmdeps
 %attr(755,root,root) %{_rpmlibdir}/tgpg
+%dir %{_rpmlibdir}/bin
+%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
+%attr(755,root,root) %{_rpmlibdir}/bin/grep
+%attr(755,root,root) %{_rpmlibdir}/bin/mtree
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
 %{_mandir}/man1/rpmgrep.1*
 %{_mandir}/man8/rpm2cpio.8*
 %{_mandir}/man8/rpmcache.8*
@@ -1251,15 +1270,16 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/cross-build
 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
-%attr(755,root,root) %{_rpmlibdir}/install-sh
 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
-%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
 # needs hacked pkg-config to return anything
 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
+%dir %{_rpmlibdir}/bin
+%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
+%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
 #%attr(755,root,root) %{_rpmlibdir}/rpmb
 #%attr(755,root,root) %{_rpmlibdir}/rpmt
 %attr(755,root,root) %{_rpmlibdir}/vcheck
@@ -1302,11 +1322,23 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%{_rpmlibdir}/sql.req
 #%{_rpmlibdir}/tcl.req
 %attr(755,root,root) %{_rpmlibdir}/mono*
+%dir %{_rpmlibdir}/macros.d
+%{_rpmlibdir}/macros.d/perl
+%{_rpmlibdir}/macros.d/java
+%{_rpmlibdir}/macros.d/libtool
+%{_rpmlibdir}/macros.d/mono
+%{_rpmlibdir}/macros.d/perl
+%{_rpmlibdir}/macros.d/php
+%{_rpmlibdir}/macros.d/pkgconfig
+%{_rpmlibdir}/macros.d/python
+%{_rpmlibdir}/macros.d/selinux
+%{_rpmlibdir}/macros.rpmbuild
+
 
 %attr(755,root,root) %{_bindir}/gendiff
 %attr(755,root,root) %{_bindir}/rpmbuild
-%attr(755,root,root) %{_bindir}/rpmspecdump
-%attr(755,root,root) %{_bindir}/rpmwget
+%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
+%attr(755,root,root) %{_rpmlibdir}/bin/wget
 
 %dir %{_rpmlibdir}/helpers
 %attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
This page took 0.462585 seconds and 4 git commands to generate.