]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- updated
[packages/rpm.git] / rpm.spec
index 5c5479d1a19f36dafb78a063326ca12cc331b535..99c03f2e1000aaa6396a557c86671e469920a1db 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -2,6 +2,7 @@
 # TODO:
 # - python(abi) cap is not provided automatically (because /usr/bin/python matches
 #   ELF first; it should be provided by python-libs not binary anyway)
+# - repackaging when lzma is not installed (todo: fix digest signature of header)
 #
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
@@ -28,12 +29,12 @@ Summary(pt_BR):     Gerenciador de pacotes RPM
 Summary(ru):   íÅÎÅÄÖÅÒ ÐÁËÅÔÏ× ÏÔ RPM
 Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRPM
 Name:          rpm
-Version:       4.4.6
-Release:       1
+Version:       4.4.7
+Release:       0.1
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
-# Source0-md5: baa6f371446c65b4080d1cd1f194a7ae
+# Source0-md5: d012c81b5169f7377ea4a36607e1445e
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -53,7 +54,6 @@ Source31:     adapter.awk
 Source32:      pldnotify.awk
 # http://svn.pld-linux.org/banner.sh/
 Source33:      banner.sh
-Source34:      php-pear-build-macros
 Patch0:                %{name}-pl.po.patch
 Patch1:                %{name}-rpmrc.patch
 Patch2:                %{name}-arch.patch
@@ -87,7 +87,7 @@ Patch29:      %{name}-libdir64.patch
 Patch30:       %{name}-libdir-links.patch
 Patch31:       %{name}-missing-prototypes.patch
 Patch32:       %{name}-pld-autodep.patch
-Patch33:       %{name}-rpmsq.patch
+
 Patch34:       %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
@@ -109,13 +109,16 @@ Patch51:  %{name}-cleanlibdirs.patch
 Patch52:       %{name}-morearchs.patch
 Patch53:       %{name}-lzma.patch
 Patch54:       %{name}-lzma2.patch
+Patch55:       %{name}-truncate-cvslog.patch
+Patch56:       %{name}-skip-backups.patch
+Patch57:       %{name}-as_needed-fix.patch
+Patch58:       %{name}-repackage-wo-lzma.patch
 URL:           http://wraptastic.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
 BuildRequires: db-devel >= %{reqdb_ver}
-%{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: gettext-devel >= 0.11.4-2
 %{?with_system_libmagic:BuildRequires: libmagic-devel}
@@ -129,11 +132,17 @@ BuildRequires:    neon-devel >= 0.25.5
 %endif
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
-%{?with_python:BuildRequires:  python-devel >= 1:2.3}
-BuildRequires: python-modules >= 1:2.3
+%{?with_python:BuildRequires:  python-devel >= 1:2.5}
+BuildRequires: python-modules >= 1:2.5
 BuildRequires: rpm-perlprov
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: zlib-devel
+%if %{with apidocs}
+BuildRequires: doxygen
+BuildRequires: ghostscript
+BuildRequires: graphviz
+BuildRequires: tetex-pdftex
+%endif
 %if %{with static}
 # Require static library only for static build
 BuildRequires: beecrypt-static >= %{beecrypt_ver}
@@ -227,6 +236,7 @@ RPM - 
 Summary:       RPM base package - scripts used by rpm packages themselves
 Summary(pl):   Podstawowy pakiet RPM - skrypty u¿ywane przez same pakiety rpm
 Group:         Base
+Requires:      filesystem
 Obsoletes:     vserver-rpm
 
 %description base
@@ -254,6 +264,7 @@ Requires:   popt >= %{reqpopt_ver}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
+Suggests:      lzma
 
 %description lib
 RPMs library.
@@ -426,11 +437,12 @@ Summary(ru):      
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name}-build-macros >= 1.284
+Requires:      %{name}-build-macros >= 1.314
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
-Requires:      binutils
+# we need fixed binutils for -feliminate-dwarf2-dups
+Requires:      binutils >= 3:2.17.50.0.3-2
 Requires:      bzip2
 Requires:      chrpath >= 0.10-4
 Requires:      cpio
@@ -559,16 +571,10 @@ Requires: sed >= 4.0
 Additional utilities for checking php pear provides/requires in rpm
 packages.
 
-This package provides rpm macros and dependencies to help building
-PEAR packages.
-
 %description php-pearprov -l pl
 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów php pear w
 pakietach rpm.
 
-Ten pakiet dostarcza makra rpm-a i zale¿no¶ci pomagaj±ce przy
-budowaniu pakietów PEAR-a.
-
 %package -n python-rpm
 Summary:       Python interface to RPM library
 Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
@@ -640,7 +646,8 @@ sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 echo '%%define __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
 echo '%%define __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
 echo '# obsoleted file' > macros.python
-install %{SOURCE34} macros.php
+echo '%%define __php_provides  /usr/lib/rpm/php.prov' > macros.php
+echo '%%define __php_requires  /usr/lib/rpm/php.req' >> macros.php
 echo '%%define __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
 echo '%%define __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
 install %{SOURCE5} scripts/find-lang.sh
@@ -660,8 +667,9 @@ install %{SOURCE12} scripts/perl.prov
 %patch29 -p1
 %patch30 -p1
 %patch31 -p1
-%patch32 -p1
-%patch33 -p1
+# FIXME
+#%patch32 -p1
+
 %patch34 -p1
 %patch35 -p0
 %patch36 -p1
@@ -672,7 +680,8 @@ install %{SOURCE12} scripts/perl.prov
 %patch41 -p1
 %patch42 -p1
 %patch43 -p1
-%{!?with_neon:%patch44 -p1}
+# FIXME
+#%{!?with_neon:%patch44 -p1}
 %patch45 -p1
 %patch46 -p1
 
@@ -683,6 +692,10 @@ install %{SOURCE12} scripts/perl.prov
 #%patch52 -p1
 %patch53 -p1
 %patch54 -p1
+%patch55 -p1
+%patch56 -p1
+%patch57 -p1
+%patch58 -p1
 
 cd scripts
 mv -f perl.req perl.req.in
@@ -741,8 +754,8 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
        %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
        --enable-shared \
        --enable-static \
-       %{?with_apidocs:--with-apidocs} \
-       %{?with_python:--with-python=auto} \
+       %{!?with_apidocs:--without-apidocs} \
+       %{?with_python:--with-python=2.5} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
        --without-db
This page took 0.272862 seconds and 4 git commands to generate.