]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- new macro pyrequires_eq so modules can have requirement only for main
[packages/rpm.git] / rpm.spec
index 6c655b3e07e77f9e4b1bc213b03053c2ac7f80c0..8a4dd94c24cd58854f49da5d6d9d4b66714bd81c 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -7,7 +7,7 @@ Summary(pl):    Aplikacja do zarz
 Summary(pt_BR):        Gerenciador de pacotes RPM
 Name:          rpm
 Version:       4.0.2
-Release:       60
+Release:       63
 License:       GPL
 Group:         Base
 Source0:       ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
@@ -24,6 +24,7 @@ Source10:     %{name}-find-provides
 Source11:      %{name}-find-requires
 Source12:      %{name}-non-english-man-pages.tar.bz2
 Source13:      %{name}-macros.python
+Source14:      %{name}-groups-po.awk
 Patch0:                %{name}-rpmrc.patch
 Patch1:                %{name}-macros.patch
 Patch2:                %{name}-arch.patch
@@ -58,7 +59,8 @@ Patch30:      %{name}-athlon.patch
 Patch31:       %{name}-athlon-identify.patch
 Patch32:       %{name}-gettext-in-header.patch
 Patch33:       %{name}-perlprov-perl5.6.patch
-Patch34:       %{name}-groups-po.patch
+Patch34:       %{name}-ac25x.patch
+Patch35:        %{name}-signverify-fix.patch
 Patch37:        %{name}-short_circuit.patch
 Patch38:        %{name}-section_test.patch
 URL:           http://www.rpm.org/
@@ -92,6 +94,7 @@ Conflicts:    glibc < 2.2
 %define                py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
 %define                py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
 %define                py_libdir       %{py_prefix}/lib/python%{py_ver}
+%define                py_sitedir      %{py_libdir}/site-packages
 %define                py_dyndir       %{py_libdir}/lib-dynload
 %define                pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
 
@@ -245,7 +248,7 @@ Pythonie.
 Summary:       Python interface to RPM library
 Summary(pl):   Pythonowy interfejs do biblioteki RPM-a
 Summary(pt_BR):        Módulo Python para aplicativos que manipulam pacotes RPM
-%requires_eq   python
+Group:         Libraries/Python
 Requires:      %{name} = %{version}
 %pyrequires_eq python
 Obsoletes:     rpm-python
@@ -291,6 +294,7 @@ Requires:   findutils
 Requires:      gcc >= 3.0.3
 %else
 Requires:      gcc
+%endif
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -354,6 +358,7 @@ construir pacotes usando o RPM.
 %endif
 
 %patch32 -p1
+%patch33 -p1
 %patch35 -p1
 %patch36 -p1
 %patch37 -p1
@@ -370,13 +375,16 @@ install %{SOURCE9} scripts/find-lang.sh
 (cd scripts;
 mv -f perl.req perl.req.in
 mv -f perl.prov perl.prov.in)
+
+chmod +x %{SOURCE4}
+
 %build
 # generate Group translations to *.po
 awk -f %{SOURCE14} %{SOURCE1}
 
 cd popt
 autoconf
-automake -a -c
+automake -a -c -f
 aclocal
 autoheader
 automake -a -c -f
@@ -390,7 +398,7 @@ aclocal
 autoupdate
 autoheader || :
 %{__autoconf}
-automake -a -c
+automake -a -c -f
 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
        lib/Makefile.am > lib/Makefile.am.new
 mv -f lib/Makefile.am.new lib/Makefile.am
This page took 0.042333 seconds and 4 git commands to generate.