]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- moved man pages to the proper subpackage
[packages/rpm.git] / rpm.spec
index d8d48d25a80f6390d85dc040a4fef725c1236b4f..7d903d19ef87dffa6f4af5c647b2c97e12e02943 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -3,12 +3,11 @@
 # - consider using system libmagic not internal libfmagic
 #   (but internal has different method of passing output)
 # - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
-# - ? make putting packages names in autogenerating dependacies as runtime option
 # 
 # Conditional build:
 %bcond_with    static  # build static rpmi (not supported at the moment)
-%bcond_without pkgnameinautoreq        # don't put package name in autogenerated dependancy
 %bcond_without apidocs # don't generate documentation with doxygen
+%bcond_without pkgnameinautoreq        # don't put package name in autogenerated dependancy
 %bcond_without python  # don't build python bindings
 %bcond_without selinux # dont enable selinux support
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
@@ -106,7 +105,7 @@ BuildRequires:      automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.1
 BuildRequires: db-devel >= %{reqdb_ver}
-%{?with_doc:BuildRequires:     doxygen}
+%{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: elfutils-devel
 BuildRequires: findutils
 BuildRequires: gettext-devel >= 0.11.4-2
@@ -556,12 +555,18 @@ construir pacotes usando o RPM.
 ÐÏÂÕÄÏ×É RPM'¦×.
 
 %if %{with apidocs}
-%package apidocs
-Summary: apidocs
-Group:  Documentation  
+%package       apidocs
+Summary:       rpm API documentation and guides
+Summary(pl):   Documentacja API rpm i przewodniki.
+Group:         Documentation   
 
 %description apidocs
-rpm apidocs generated by doxygen.
+Documentation for rpm API and guides in html format generated
+from rpm sources by doxygen.
+
+%description apidocs -l pl
+Dokumentacja API rpm oraz przewodniki w formacie html generowana
+ze ¼rode³ rpm przez doxygen.
 %endif
 
 %prep
@@ -678,7 +683,7 @@ mv -f macros.tmp macros.in
        CPP="%{__newcpp}" \
        --enable-shared \
        --enable-static \
-       %{?with_doc:--with-apidocs} \
+       %{?with_apidoc:--with-apidocs} \
        %{?with_pkgnameinautoreq:--enable-adding-packages-names-in-autogenerated-dependancies} \
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
@@ -700,7 +705,7 @@ mv -f macros.tmp macros.in
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/{%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm}
+install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -986,15 +991,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
 %attr(755,root,root) %{_rpmlibdir}/tgpg
 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
-
-%files utils-perl
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
-# not here
-#%%{_rpmlibdir}/rpm.daily
-#%%{_rpmlibdir}/rpm.log
-#%%{_rpmlibdir}/rpm.xinetd
-
 %{_mandir}/man8/rpm2cpio.8*
 %{_mandir}/man8/rpmdeps.8*
 %{_mandir}/man8/rpmcache.8*
@@ -1009,6 +1005,15 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
 
+%files utils-perl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
+# not here
+#%%{_rpmlibdir}/rpm.daily
+#%%{_rpmlibdir}/rpm.log
+#%%{_rpmlibdir}/rpm.xinetd
+
+
 %if %{with static}
 %files utils-static
 %defattr(644,root,root,755)
This page took 0.032647 seconds and 4 git commands to generate.