]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- fix symlinks processing during install.
[packages/rpm.git] / rpm.spec
index e534d027d7134d8aa5b0657044dc9feb01af7ed0..5098a4a8b6b9a5eefc6e9a51460d318d4ba76943 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -29,7 +29,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.4
-Release:       0.3
+Release:       0.6
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
@@ -106,6 +106,7 @@ Patch48:    %{name}-requireseq.patch
 Patch49:       %{name}-p4.patch
 Patch50:       %{name}-macros.patch
 Patch51:       %{name}-cleanlibdirs.patch
+Patch52:       %{name}-morearchs.patch
 URL:           http://wraptastic.org/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
@@ -161,6 +162,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # don't require very fresh rpm.macros to build
 %define                __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
 %define                ix86    i386 i486 i586 i686 athlon pentium3 pentium4
+%define                ppc     ppc ppc7400 ppc7450
 %define                x8664   amd64 ia32e x86_64
 
 # stabilize new build environment
@@ -225,7 +227,6 @@ RPM - 
 Summary:       RPM base package - scripts used by rpm packages themselves
 Summary(pl):   Podstawowy pakiet RPM - skrypty u¿ywane przez same pakiety rpm
 Group:         Base
-Requires:      sed
 Obsoletes:     vserver-rpm
 
 %description base
@@ -425,7 +426,7 @@ Summary(ru):        
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name}-build-macros
+Requires:      %{name}-build-macros >= 1.284
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -680,6 +681,7 @@ install %{SOURCE12} scripts/perl.prov
 %patch49 -p1
 %patch50 -p1
 %patch51 -p1
+%patch52 -p1
 
 cd scripts
 mv -f perl.req perl.req.in
@@ -767,6 +769,11 @@ install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/b
        pylibdir=%{py_libdir} \
        pkgbindir="%{_bindir}"
 
+%ifarch %{ppc}
+sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
+       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
+%endif
+
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
@@ -1070,7 +1077,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch mips mipsel mips64 mips64el
 %{_rpmlibdir}/mips*
 %endif
-%ifarch ppc
+%ifarch %{ppc}
 %{_rpmlibdir}/ppc*
 %endif
 %ifarch sparc sparc64
This page took 0.038305 seconds and 4 git commands to generate.