]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- fix symlinks processing during install.
[packages/rpm.git] / rpm.spec
index a827529d8c286997b5876f11be258890c4825425..5098a4a8b6b9a5eefc6e9a51460d318d4ba76943 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -29,7 +29,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.4
-Release:       0.3
+Release:       0.6
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
@@ -426,7 +426,7 @@ Summary(ru):        
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
 Requires(pre): findutils
-Requires:      %{name}-build-macros
+Requires:      %{name}-build-macros >= 1.284
 Requires:      %{name}-utils = %{version}-%{release}
 Requires:      /bin/id
 Requires:      awk
@@ -724,14 +724,8 @@ cd ..
 
 # config.guess doesn't handle athlon, so we have to change it by hand.
 # rpm checks for CPU type at runtime, but it looks better
-%ifarch %{ppc}
-TARG=$( echo %{_target_cpu} | sed 's/ppc//' )
-sed -e "s|@host@|ppc-%{_target_vendor}-linux-gnu|" \
-       -e "s|@host_cpu@|%{_target_cpu}|" macros.in > macros.tmp
-%else
 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' \
        -e 's|@host_cpu@|%{_target_cpu}|' macros.in > macros.tmp
-%endif
 mv -f macros.tmp macros.in
 
 CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
@@ -775,6 +769,11 @@ install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/b
        pylibdir=%{py_libdir} \
        pkgbindir="%{_bindir}"
 
+%ifarch %{ppc}
+sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
+       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
+%endif
+
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
This page took 0.061953 seconds and 4 git commands to generate.