]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- comment fixes
[packages/rpm.git] / rpm.spec
index f2577b9e66b95e23254b6a85b675e4f69e1ecc5a..32b169ef9ca83d0d1938f21062dbc10859ec86cd 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -7,6 +7,7 @@
 #
 # Conditional build:
 # _without_static      - build shared /bin/rpm (doesn't work at the moment)
+# _without_docs                - don't generate documentation with doxygen
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
@@ -17,6 +18,7 @@
 %define        reqdb_ver       4.1.25-1
 %define        reqpopt_ver     1.9
 %define        beecrypt_ver    3.0.0-0.20030610.1
+%define rpm_macros_rev 1.120
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -27,7 +29,7 @@ Summary(uk):  
 Name:          rpm
 %define        ver     4.3
 Version:       %{ver}
-%define        rel     0.%{snap}.15
+%define        rel     0.%{snap}.20.4
 Release:       %{rel}
 License:       GPL
 Group:         Base
@@ -74,7 +76,7 @@ Patch16:      %{name}-etc_dir.patch
 Patch17:       %{name}-system_libs-more.patch
 Patch18:       %{name}-php-deps.patch
 Patch19:       %{name}-python-fix.patch
-Patch20:       %{name}-spec-prep-pre.patch
+#Patch20:      %{name}-spec-prep-pre.patch
 Patch21:       %{name}-perl_req.patch
 Patch22:       %{name}-system_libs_more.patch
 Patch23:       %{name}-python_2_3.patch
@@ -88,6 +90,7 @@ Patch30:      %{name}-man-pl.patch
 Patch31:       %{name}-fdClose-typo.patch
 Patch32:       %{name}-userpmdepswrappers.patch
 Patch33:       %{name}-provides-dont-obsolete.patch
+Patch34:       %{name}-examplesaredoc.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -95,7 +98,7 @@ BuildRequires:        automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.1
 BuildRequires: db-devel >= %{reqdb_ver}
-BuildRequires: doxygen
+%{!?_without_docs:BuildRequires:       doxygen}
 BuildRequires: gettext-devel >= 0.11.4-2
 BuildRequires: elfutils-devel
 #BuildRequires:        libmagic-devel
@@ -184,10 +187,10 @@ RPM - 
 ¦ÎÆÏÒÍÁæÀ ÐÒÏ ÐÁËÅÔ.
 
 %package devel
-Summary:       Header files and libraries
-Summary(de):   Header-Dateien uns Libraries
+Summary:       Header files for rpm libraries
+Summary(de):   Header-Dateien für rpm Libraries
 Summary(es):   Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
-Summary(pl):   Pliki nag³ówkowe i biblioteki
+Summary(pl):   Pliki nag³ówkowe bibliotek rpm
 Summary(pt_BR):        Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
 Summary(ru):   èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÐÒÏÇÒÁÍÍ, ÒÁÂÏÔÁÀÝÉÈ Ó rpm-ÐÁËÅÔÁÍÉ
 Summary(uk):   èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÐÒÏÇÒÁÍ, ÝÏ ÐÒÁÃÀÀÔØ Ú ÐÁËÅÔÁÍÉ rpm
@@ -201,10 +204,11 @@ Requires: popt-devel >= %{reqpopt_ver}
 Requires:      zlib-devel
 
 %description devel
-The RPM packaging system includes a C library that makes it easy to
-manipulate RPM packages and databases. It is intended to ease the
+The RPM packaging system includes C libraries that make it easy to
+manipulate RPM packages and databases. They are intended to ease the
 creation of graphical package managers and other tools that need
-intimate knowledge of RPM packages.
+intimate knowledge of RPM packages. This package contains header files
+for these libraries.
 
 %description devel -l de
 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
@@ -219,10 +223,11 @@ facilitar la creaci
 herramientas que necesiten un conocimiento profundo de paquetes RPM.
 
 %description devel -l pl
-System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
-RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
+System RPM zawiera biblioteki C, które u³atwiaj± manipulowanie
+pakietami RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
 graficznych programów zarz±dzaj±cych pakietami oraz innych narzêdzi,
-które wymagaj± szczegó³owej wiedzy na temat pakietów RPM.
+które wymagaj± szczegó³owej wiedzy na temat pakietów RPM. Ten pakiet
+zawiera pliki nag³ówkowe wspomnianych bibliotek.
 
 %description devel -l pt_BR
 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
@@ -298,6 +303,25 @@ Zusatzwerkzeuge f
 %description utils -l pl
 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
 
+%package utils-perl
+Summary:       Additional utilities for managing rpm packages and database
+Summary(de):   Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
+Summary(pl):   Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
+Group:         Applications/File
+Requires:      %{name} = %{version}
+Requires:      %{name}-utils = %{version}
+Requires:      popt >= %{reqpopt_ver}
+
+%description utils-perl
+Additional utilities for managing rpm packages and database.
+
+%description utils-perl -l de
+Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
+
+%description utils-perl -l pl
+Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
+
+
 %package utils-static
 Summary:       Static rpm utilities
 Summary(pl):   Statyczne narzêdzia rpm
@@ -419,6 +443,7 @@ Summary(pt_BR):     Scripts e programas execut
 Summary(ru):   óËÒÉÐÔÙ É ÕÔÉÌÉÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÓÂÏÒËÉ ÐÁËÅÔÏ×
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
+Provides:      rpmbuild(macros) = %{rpm_macros_rev}
 Requires(pre): findutils
 Requires:      %{name} = %{version}
 Requires:      %{name}-utils = %{version}
@@ -530,15 +555,15 @@ construir pacotes usando o RPM.
 
 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
 cp -f platform.in macros.pld.in
-echo '# obsoleted file' > macros.perl
+echo '%%define _perl_deps      1' > macros.perl
 echo '# obsoleted file' > macros.python
-echo '# obsoleted file' > macros.php
+echo '%%define _php_deps       1' > macros.php
 install %{SOURCE6} scripts/find-lang.sh
 install %{SOURCE12} scripts/php.prov.in
 install %{SOURCE13} scripts/php.req.in
 install %{SOURCE33} scripts/perl.prov
 cat %{SOURCE14} >> macros.in
-%patch20 -p1
+# %patch20 -p1 -- merged into macros
 %patch25 -p1
 %patch26 -p1
 %patch27 -p1
@@ -548,6 +573,7 @@ cat %{SOURCE14} >> macros.in
 %patch31 -p1
 %patch32 -p1
 %patch33 -p1
+%patch34 -p1
 
 cd scripts;
 mv -f perl.req perl.req.in
@@ -595,7 +621,7 @@ mv -f macros.tmp macros.in
        CC="%{__cc}" CXX="%{__cxx}" CPP="%{__cpp}" \
        --enable-shared \
        --enable-static \
-       --with-apidocs \
+       %{!?_without_docs:--with-apidocs} \
        --with-python=auto \
        --without-db
 
@@ -756,7 +782,6 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_libdir}/rpm/cpanflute2
 #%attr(755,root,root) %{_libdir}/rpm/Specfile.pm
 %attr(755,root,root) %{_libdir}/rpm/http.req
-#%attr(755,root,root) %{_libdir}/rpm/magic*
 %attr(755,root,root) %{_libdir}/rpm/magic.prov
 %attr(755,root,root) %{_libdir}/rpm/magic.req
 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
@@ -778,6 +803,9 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %ifarch ppc
 %{_libdir}/rpm/ppc*
 %endif
+# must be here for "Requires: rpm-*prov" to work
+%{_libdir}/rpm/macros.perl
+%{_libdir}/rpm/macros.php
 # not used yet ...
 %{_libdir}/rpm/sql.prov
 %{_libdir}/rpm/sql.req
@@ -817,10 +845,12 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_bindir}/rpmfile
 %attr(755,root,root) %{_libdir}/rpm/find-debuginfo.sh
 %attr(755,root,root) %{_libdir}/rpm/rpm2cpio.sh
-%attr(755,root,root) %{_libdir}/rpm/rpmdiff*
 %attr(755,root,root) %{_libdir}/rpm/tgpg
 %attr(755,root,root) %{_libdir}/rpm/rpmdb_loadcvt
 
+%files utils-perl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/rpm/rpmdiff*
 # not here
 #%%{_libdir}/rpm/rpm.daily
 #%%{_libdir}/rpm/rpm.log
@@ -855,8 +885,6 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
 
-%{_libdir}/rpm/macros.perl
-
 %files pythonprov
 %defattr(644,root,root,755)
 %{_libdir}/rpm/macros.python
@@ -865,7 +893,6 @@ find /usr/lib/rpm -name '*-linux' -type l | xargs rm -f
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/rpm/php*
 %attr(755,root,root) %{_libdir}/rpm/find-php*
-%{_libdir}/rpm/macros.php
 
 %files -n python-rpm
 %defattr(644,root,root,755)
This page took 0.05367 seconds and 4 git commands to generate.