]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- rpm_macros_rev 1.238, rel 4
[packages/rpm.git] / rpm.spec
index 81e9032cbd39e5fe01078ad90ef9ebc408c2e073..1fbb741a03425ec9ab4acc3d1ac7268742dfa956 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -2,14 +2,11 @@
 # TODO:
 # - python(abi) cap is not provided automatically (because /usr/bin/python matches
 #   ELF first; it should be provided by python-libs not binary anyway)
-# - consider using system libmagic not internal libfmagic
-#   (but internal has different method of passing output)
 # 
 # Conditional build:
 %bcond_with    static          # build static rpmi (not supported at the moment)
 %bcond_without apidocs         # don't generate documentation with doxygen
 %bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
-%bcond_without home_etc        # build without HOME_ETC support
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
 %bcond_without system_libmagic # don't use system libmagic
@@ -22,7 +19,7 @@
 %define        reqdb_ver       4.3.27-1
 %define        reqpopt_ver     1.10.2
 %define        beecrypt_ver    2:4.1.2-4
-%define        rpm_macros_rev  1.236
+%define        rpm_macros_rev  1.238
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -33,7 +30,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.2
-Release:       2
+Release:       4
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
@@ -116,7 +113,6 @@ BuildRequires:      db-devel >= %{reqdb_ver}
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: findutils
 BuildRequires: gettext-devel >= 0.11.4-2
-%{?with_home_etc:BuildRequires:        home-etc-devel >= 1:1.0.9-2}
 %{?with_system_libmagic:BuildRequires: libmagic-devel}
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
@@ -230,10 +226,6 @@ Requires:  popt >= %{reqpopt_ver}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
-%if %{with home_etc}
-# avoid linking to /usr/lib
-Conflicts:     home-etc < 1.0.9-2
-%endif
 
 %description lib
 RPMs library.
@@ -255,7 +247,6 @@ Requires:   beecrypt-devel >= %{beecrypt_ver}
 Requires:      bzip2-devel
 Requires:      db-devel >= %{reqdb_ver}
 Requires:      elfutils-devel
-%{?with_home_etc:Requires:     home-etc-devel >= 1:1.0.9-2}
 %{?with_selinux:Requires:      libselinux-devel}
 %{?with_system_libmagic:Requires:       libmagic-devel}
 Requires:      popt-devel >= %{reqpopt_ver}
@@ -709,7 +700,6 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
        --enable-shared \
        --enable-static \
        %{?with_apidocs:--with-apidocs} \
-       %{?with_home_etc:--with-home_etc} \
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
@@ -852,6 +842,8 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
 ^libpsres.so
 ^libxkbfile.so
 ^libxkbui.so
+# -- fam / gamin
+^libfam.so.0
 EOF
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
 # global list of file masks not to be compressed in DOCDIR
This page took 0.028114 seconds and 4 git commands to generate.