]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- be more strict in matching module names (fixes perl-Exception-Class)
[packages/rpm.git] / rpm.spec
index 73a7eda7004cd959aba1687088406ee5658df791..0613b98792d5dfb768086f45dcf3bdfeb7c169f8 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -8,10 +8,6 @@
 #          i386 i386
 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
 #   matches ELF first
-# - rpmbuild computes digest when writing package to temporary file, then adds a few
-#   tags (incl. digest) and writes whole package to destination file;
-#   repackaging uses unchanged "immutable header" image from original rpm, also
-#   preserving payload format and compressor from original rpm, _not_ current settings
 # - TODO: add macros for some ppc, mipsel, alpha and sparc
 # - uppackaged list:
 #   /usr/lib/rpm/http.req
 #   /usr/lib/rpm/vcheck
 #   /usr/share/man/man8/rpmconstant.8
 #
+# - headerGet() making poldek segfault http://rpm5.org/cvs/tktview?tn=38,1
+# - LUA segfault - http://rpm5.org/cvs/tktview?tn=39,1
+# - rpm doesn't exit when no sources/patches available http://rpm5.org/cvs/tktview?tn=40,1
+# - http://rpm5.org/cvs/tktview?tn=38&_submit=Show
+# - http://rpm5.org/cvs/tktview?tn=39&_submit=Show
+# - http://rpm5.org/cvs/tktview?tn=40&_submit=Show
+# - http://rpm5.org/cvs/tktview?tn=41&_submit=Show
+#
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
-%bcond_without apidocs         # don't generate documentation with doxygen
+%bcond_with    apidocs         # don't generate documentation with doxygen
 %bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
@@ -63,7 +67,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.1.4
-Release:       0.5
+Release:       0.9
 License:       LGPL
 Group:         Base
 Source0:       http://rpm5.org/files/rpm/rpm-5.1/%{name}-%{version}.tar.gz
@@ -120,6 +124,7 @@ Patch14:    %{name}-etc_dir.patch
 Patch16:       %{name}-php-deps.patch
 Patch17:       %{name}-macros.patch
 Patch18:       %{name}-macros-th.patch
+Patch19:       %{name}-glob.patch
 
 Patch23:       %{name}-pkgconfigdeps.patch
 
@@ -131,6 +136,8 @@ Patch34:    %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
 Patch37:       %{name}-doxygen_hack.patch
+Patch38:       %{name}-perl_req-use_base.patch
+Patch39:       %{name}-perl_req-skip_multiline.patch
 
 Patch42:       %{name}-old-fileconflicts-behaviour.patch
 
@@ -690,6 +697,8 @@ install %{SOURCE12} scripts/perl.prov
 %patch35 -p0
 %patch36 -p1
 %patch37 -p1
+%patch38 -p1
+%patch39 -p1
 %patch42 -p1
 %patch46 -p1
 %patch47 -p1
@@ -699,6 +708,7 @@ install %{SOURCE12} scripts/perl.prov
 %patch59 -p1
 %patch17 -p1
 %patch18 -p1
+%patch19 -p1
 %patch60 -p1
 %ifarch sparc64
 %patch61 -p1
@@ -1032,7 +1042,7 @@ touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
 # move rpm to /bin
 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
 # move essential libs to /lib (libs that /bin/rpm links to)
-for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so; do
+for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so; do
        mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
        ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
 done
@@ -1105,7 +1115,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_bindir}/rpmsign
 #%attr(755,root,root) %{_bindir}/rpmverify
 
-%dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
 %dir %{_sysconfdir}/rpm/sysinfo
 # these are ok to be replaced
@@ -1143,6 +1152,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %files base
 %defattr(644,root,root,755)
+%dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
 %dir %{_rpmlibdir}
 %attr(755,root,root) %{_bindir}/banner.sh
@@ -1155,6 +1165,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
+%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.027833 seconds and 4 git commands to generate.