]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- %%{user,group}remove support really merged from AC-ranch
[packages/rpm.git] / rpm.spec
index cfc97d94b82bb0f64e183a45cd2f143ce1ed9a18..037854819b60e4bdcf2ac021e5a7708c3f14e085 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
-%include       /usr/lib/rpm/macros.python
 %define        snap    20040614
 # versions of required libraries
 %define        reqdb_ver       4.2.50-1
 %define        reqpopt_ver     1.9
-%define        beecrypt_ver    3.0.0-0.20030610.1
-%define        rpm_macros_rev  1.158
+%define        beecrypt_ver    4.0.0
+%define        rpm_macros_rev  1.161
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -31,7 +30,7 @@ Name:         rpm
 %define        ver     4.4
 %define        sover   4.3
 Version:       %{ver}
-Release:       0.%{snap}.0.3
+Release:       0.%{snap}.0.4
 License:       GPL
 Group:         Base
 #Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
@@ -49,6 +48,8 @@ Source9:      %{name}-php-provides
 Source10:      %{name}-php-requires
 Source11:      %{name}.macros
 Source12:      perl.prov
+Source13:      %{name}-user_group.sh
+Source14:      %{name}.sysconfig
 Source30:      builder
 Source31:      adapter.awk
 Source32:      pldnotify.awk
@@ -92,6 +93,7 @@ Patch40:      %{name}-epoch0.patch
 Patch41:       %{name}-file-readelf-fix.patch
 Patch43:       %{name}-perl_req-INC_dirs.patch
 Patch44:       %{name}-debuginfo.patch
+Patch45:       %{name}-beecrypt4.patch
 Patch100:      %{name}-pl.po.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
@@ -130,7 +132,6 @@ BuildRequires:      elfutils-static
 BuildRequires: popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
 %endif
-Requires:      kernel-headers
 Requires:      popt >= %{reqpopt_ver}
 Requires:      %{name}-lib = %{version}-%{release}
 %{!?with_static:Obsoletes:     rpm-utils-static}
@@ -466,6 +467,7 @@ Requires:   /bin/id
 Requires:      awk
 Requires:      binutils
 Requires:      chrpath >= 0.10-4
+Requires:      cpio
 Requires:      diffutils
 Requires:      file >= 4.01
 Requires:      fileutils
@@ -548,8 +550,6 @@ construir pacotes usando o RPM.
 
 %prep
 %setup -q -n %{name}
-# UPDATE
-#%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -603,6 +603,7 @@ cat %{SOURCE11} >> macros.in
 %patch41 -p1
 %patch43 -p0
 %patch44 -p1
+%patch45 -p1
 %patch100 -p1
 
 cd scripts;
@@ -677,7 +678,7 @@ mv -f macros.tmp macros.in
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/%{_lib}
+install -d $RPM_BUILD_ROOT/{%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -697,8 +698,10 @@ install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
+install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
 install scripts/find-php*      $RPM_BUILD_ROOT%{_rpmlibdir}
 install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
+install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
 
 install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
 install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
@@ -706,8 +709,6 @@ install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
 
 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
 
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
-
 %ifarch %{ix86}
 ix86re=$(echo "(%{ix86})"|sed 's/ /|/g')
 perl -p -i -e 's/^(buildarchtranslate: '"$ix86re"': ).*/\1%{_target_cpu}/' \
@@ -795,6 +796,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
+%config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rpm
 
 %{_mandir}/man8/rpm.8*
 %lang(fr) %{_mandir}/fr/man8/rpm.8*
@@ -816,6 +818,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
 
 %doc %attr(755,root,root) %{_rpmlibdir}/convertrpmrc.sh
+%attr(755,root,root) %{_rpmlibdir}/user_group.sh
 
 %{_rpmlibdir}/rpmrc
 %{_rpmlibdir}/rpmpopt*
@@ -868,6 +871,9 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch ia64
 %{_rpmlibdir}/ia64*
 %endif
+%ifarch mips mipsel mips64 mips64el
+%{_rpmlibdir}/mips*
+%endif
 %ifarch ppc
 %{_rpmlibdir}/ppc*
 %endif
This page took 0.037742 seconds and 4 git commands to generate.