]> git.pld-linux.org Git - packages/qt4.git/blobdiff - qt4.spec
- rel 6; some fixes from git
[packages/qt4.git] / qt4.spec
index 3c60735f8cdf30928b517191c13a1a1419e495c9..02cee544b1ab741d65de0166c3e35795f002437b 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
@@ -5,17 +5,8 @@
 #      - more cleanups
 #      - check if translations are available
 #      - check Qt ui tool
-# - QtDBus (and maybe others) not multilib compatible (split pkgs or drop symlinks)
-#   file /usr/bin/qdbus from install of QtDBus-4.5.0-7.i686 conflicts with file from package QtDBus-4.5.0-7.x86_64
-#   file /usr/bin/qdbusviewer from install of QtDBus-4.5.0-7.i686 conflicts with file from package QtDBus-4.5.0-7.x86_64
-#   $ rpm -q QtDBus --filecolor|less
-#   /usr/bin/qdbus  0
-#   /usr/bin/qdbusviewer    0
-#   $ file /usr/bin/qdbus /usr/bin/qdbusviewer
-#   /usr/bin/qdbus:       symbolic link to `../lib/qt4/bin/qdbus'
-#   /usr/bin/qdbusviewer: symbolic link to `../lib/qt4/bin/qdbusviewer'
-#   MORAL: it would be ok if the files were marked as multilib (colors 1 or 2), not symlinks (color 0)
-#   I personally would moved binaries to %{_bindir}
+#      - QtWebKit-devel is broken: libQtWebKit.*la contains '-ljscore', it comes
+#        from src/3rdparty/webkit/JavaScriptCore, but jscore lib isn't installed
 #
 # Conditional build:
 %bcond_with    nas             # enable NAS audio support
 %bcond_without pch             # disable pch in qmake
 %bcond_without gtk             # don't build GTK theme integration
 %bcond_without system_phonon   # don't build phonon libraries
+%bcond_with    mmx             # use MMX instructions
+%bcond_with    3dnow           # use 3Dnow instructions
 %bcond_with    sse             # use SSE instructions in gui/painting module
 %bcond_with    sse2            # use SSE2 instructions
+%bcond_with    sse3            # use SSE3 instructions (since: Intel middle Pentium4, AMD Athlon64)
+%bcond_with    ssse3           # use SSSE3 instructions (Intel since Core2, Via Nano)
+%bcond_with    sse41           # use SSE4.1 instructions (Intel since middle Core2)
+%bcond_with    sse42           # use SSE4.2 instructions (the same)
+%bcond_with    avx             # use AVX instructions (future Intel x86 CPUs only)
 #
 %ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
 %undefine      with_ibase
 %endif
+%ifarch        athlon
+%define                with_3dnow      1
+%endif
+%ifarch athlon pentium3 pentium4 %{x8664}
+%define                with_mmx        1
+%endif
 %ifarch pentium3 pentium4 %{x8664}
 %define                with_sse        1
 %endif
@@ -51,62 +55,63 @@ Summary(es.UTF-8):  Biblioteca para ejecutar aplicaciones GUI Qt
 Summary(pl.UTF-8):     Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
-Version:       4.7.0
-Release:       3
+Version:       4.8.0
+Release:       6
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
 Source0:       http://download.qt.nokia.com/qt/source/qt-everywhere-opensource-src-%{version}.tar.gz
-# Source0-md5: 3a2f25b9b115037277f4fb759194a7a5
+# Source0-md5: e8a5fdbeba2927c948d9f477a6abe904
 Source2:       %{name}-qtconfig.desktop
 Source3:       %{name}-designer.desktop
 Source4:       %{name}-assistant.desktop
 Source5:       %{name}-linguist.desktop
 
 # git clone git://gitorious.org/+kde-developers/qt/kde-qt.git
-# git checkout -b 4.7.0-patched origin/4.7.0-patched
-# git diff v4.7.0..4.7.0-patched > ~/rpm/packages/qt4/qt4-kde-git.patch
+# git checkout -b 4.7.1-patched origin/4.7.1-patched
+# git diff v4.7.1..4.7.1-patched > ~/rpm/packages/qt4/qt4-kde-git.patch
 Patch100:      %{name}-kde-git.patch
 
 Patch0:                %{name}-tools.patch
 Patch1:                %{name}-qt_copy.patch
 Patch2:                %{name}-buildsystem.patch
 Patch3:                %{name}-locale.patch
-Patch4:                %{name}-antialias.patch
+Patch4:                %{name}-qvfb.patch
 Patch5:                %{name}-support-cflags-with-commas.patch
 Patch6:                %{name}-build-lib-static.patch
 Patch7:                %{name}-x11_fonts.patch
 Patch8:                %{name}-pl-update.patch
 Patch9:                %{name}-ibase.patch
-Patch10:       %{name}-qtbug-13567.patch
-URL:           http://www.qtsoftware.com/
+Patch10:       %{name}-git.patch
+Patch11:       qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
+URL:           http://qt.nokia.com/
 %{?with_ibase:BuildRequires:   Firebird-devel}
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: alsa-lib-devel
 %{?with_cups:BuildRequires:    cups-devel}
-BuildRequires: dbus-devel >= 0.62
+BuildRequires: dbus-devel >= 0.93
 BuildRequires: fontconfig-devel
 BuildRequires: freetds-devel
 BuildRequires: freetype-devel >= 1:2.0.0
 %{?with_pch:BuildRequires:     gcc >= 5:4.0}
 BuildRequires: glib2-devel >= 2.0.0
 BuildRequires: gstreamer-plugins-base-devel
-%{?with_gtk:BuildRequires:     gtk+2-devel}
+%{?with_gtk:BuildRequires:     gtk+2-devel >= 2:2.10}
+BuildRequires: libicu-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libmng-devel >= 1.0.0
 BuildRequires: libpng-devel >= 2:1.0.8
-BuildRequires: pulseaudio-devel >= 0.9.10
 BuildRequires: libstdc++-devel
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: pkgconfig
 %{?with_pgsql:BuildRequires:   postgresql-backend-devel}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
-%{?with_pgsql:BuildRequires:   postgresql-static}
-BuildRequires: rpmbuild(macros) >= 1.213
+BuildRequires: pulseaudio-devel >= 0.9.10
+BuildRequires: rpmbuild(macros) >= 1.602
 BuildRequires: sed >= 4.0
 %{?with_sqlite:BuildRequires:  sqlite-devel}
 %{?with_sqlite3:BuildRequires: sqlite3-devel}
-%{?with_odbc:BuildRequires:    unixODBC-devel >= 2.2.12-2}
+%{?with_odbc:BuildRequires:    unixODBC-devel >= 2.3.0}
 BuildRequires: xorg-lib-libSM-devel
 BuildRequires: xorg-lib-libXcursor-devel
 BuildRequires: xorg-lib-libXext-devel
@@ -252,6 +257,7 @@ biblioteka statyczna.
 Summary:       Qt core classes used by other modules
 Summary(pl.UTF-8):     Podstawowe klasy Qt używane przez inne moduły
 Group:         X11/Libraries
+%requires_eq   libicu
 Obsoletes:     QtAssistant
 
 %description -n QtCore
@@ -364,6 +370,7 @@ językiem zorientowanym na JavaScript.
 Summary:       Development files for QtDeclarative - QML language engine library
 Summary(pl.UTF-8):     Pliki programistyczne QtDeclarative - biblioteki języka QML
 Group:         X11/Development/Libraries
+Requires:      QtDeclarative = %{version}-%{release}
 Requires:      QtGui-devel = %{version}-%{release}
 Requires:      QtNetwork-devel = %{version}-%{release}
 Requires:      QtScript-devel = %{version}-%{release}
@@ -1192,6 +1199,7 @@ Requires: QtSql = %{version}-%{release}
 Requires:      QtSql-sqlite3 = %{version}-%{release}
 Requires:      QtWebKit = %{version}-%{release}
 Requires:      QtXml = %{version}-%{release}
+Requires:      hicolor-icon-theme
 
 %description assistant
 Qt Assistant is a tool for browsing on-line documentation with
@@ -1237,6 +1245,7 @@ Summary:  Translation helper for Qt
 Summary(pl.UTF-8):     Aplikacja ułatwiająca tłumaczenie aplikacji opartych o Qt
 Group:         X11/Development/Tools
 Requires:      QtUiTools = %{version}-%{release}
+Requires:      hicolor-icon-theme
 
 %description linguist
 This program provides an interface that shortens and helps systematize
@@ -1306,6 +1315,7 @@ Requires: QtGui = %{version}-%{release}
 Requires:      QtNetwork = %{version}-%{release}
 Requires:      QtSql = %{version}-%{release}
 Requires:      QtXml = %{version}-%{release}
+Requires:      desktop-file-utils
 
 %description qtconfig
 A tool for configuring look and behavior of Qt widgets.
@@ -1393,6 +1403,7 @@ Programas exemplo para o Qt versão.
 #%patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/g,' mkspecs/linux-g++-64/qmake.conf \
        mkspecs/common/linux.conf
@@ -1407,7 +1418,7 @@ Programas exemplo para o Qt versão.
        s|QMAKE_CXXFLAGS_RELEASE.*|QMAKE_CXXFLAGS_RELEASE\t+= %{rpmcppflags} %{rpmcxxflags}|;
        s|QMAKE_CFLAGS_DEBUG.*|QMAKE_CFLAGS_DEBUG\t+= %{debugcflags}|;
        s|QMAKE_CXXFLAGS_DEBUG.*|QMAKE_CXXFLAGS_DEBUG\t+= %{debugcflags}|;
-       ' mkspecs/common/g++.conf
+       ' mkspecs/common/g++-base.conf
 
 %{__sed} -i -e '
        s|QMAKE_INCDIR_QT.*|QMAKE_INCDIR_QT       = %{_includedir}/qt4|;
@@ -1423,6 +1434,9 @@ Programas exemplo para o Qt versão.
        s|^QMAKE_STRIP.*=.*|QMAKE_STRIP             =|;
        ' mkspecs/common/linux.conf
 
+# disable webkit tests, broken build
+rm -r src/3rdparty/webkit/Source/WebKit/qt/tests
+
 %build
 # pass OPTFLAGS to build qmake itself with optimization
 export OPTFLAGS="%{rpmcflags}"
@@ -1433,7 +1447,6 @@ export PATH=$PWD/bin:$PATH
 ##################################
 
 COMMONOPT=" \
-       -DQT_CLEAN_NAMESPACE \
        -buildkey pld \
        -verbose \
        -prefix %{_qtdir} \
@@ -1448,21 +1461,33 @@ COMMONOPT=" \
        -sysconfdir %{_sysconfdir}/qt4 \
        -examplesdir %{_examplesdir}/qt4 \
        -demosdir %{_examplesdir}/qt4-demos \
+       -opensource \
+       -optimized-qmake \
        -fast \
        -glib \
        %{!?with_gtk:-no-gtkstyle} \
        -%{!?with_pch:no-}pch \
        -no-rpath \
+       %{!?with_mmx:-no-mmx} \
+       %{!?with_3dnow:-no-3dnow} \
        %{!?with_sse:-no-sse} \
        %{!?with_sse2:-no-sse2} \
+       %{!?with_sse3:-no-sse3} \
+       %{!?with_ssse3:-no-ssse3} \
+       %{!?with_sse41:-no-sse4.1} \
+       %{!?with_sse42:-no-sse4.2} \
+       %{!?with_avx:-no-avx} \
        -qdbus \
-       -qt-gif \
+       -dbus-linked \
        -reduce-relocations \
        -system-libjpeg \
        -system-libmng \
        -system-libpng \
+       -system-libtiff \
        -system-zlib \
+       -openssl-linked \
        -exceptions \
+       -graphicssystem raster \
        -largefile \
        -I/usr/include/postgresql/server \
        -I/usr/include/mysql \
@@ -1472,13 +1497,17 @@ COMMONOPT=" \
        %{!?debug:-release} \
        -qt3support \
        -fontconfig \
+       -largefile \
        -iconv \
+       -icu \
        -no-separate-debug-info \
        -xfixes \
        -nis \
        -sm \
        -xcursor \
        -xinput \
+       -xinerama \
+       -xrandr \
        -xkb \
        -xrender \
        -xshape \
@@ -1572,27 +1601,38 @@ ln -sf ../%{_lib}/qt4/bin/qt3to4 .
 ln -sf ../%{_lib}/qt4/bin/rcc .
 ln -sf ../%{_lib}/qt4/bin/uic3 .
 ln -sf ../%{_lib}/qt4/bin/pixeltool .
-ln -sf ../%{_lib}/qt4/bin/qdbus .
+ln -sf ../%{_lib}/qt4/bin/qcollectiongenerator .
 ln -sf ../%{_lib}/qt4/bin/qdbuscpp2xml .
 ln -sf ../%{_lib}/qt4/bin/qdbusxml2cpp .
-ln -sf ../%{_lib}/qt4/bin/qdbusviewer .
 ln -sf ../%{_lib}/qt4/bin/qhelpconverter .
 ln -sf ../%{_lib}/qt4/bin/qhelpgenerator .
 ln -sf ../%{_lib}/qt4/bin/qmlviewer .
+ln -sf ../%{_lib}/qt4/bin/qmlplugindump .
 ln -sf ../%{_lib}/qt4/bin/qttracereplay .
 ln -sf ../%{_lib}/qt4/bin/qvfb .
 ln -sf ../%{_lib}/qt4/bin/xmlpatternsvalidator .
 cd -
 
+# multilib
+mv $RPM_BUILD_ROOT%{_qtdir}/bin/{qdbus,qdbusviewer} $RPM_BUILD_ROOT%{_bindir}
+ln -sf %{_bindir}/qdbus $RPM_BUILD_ROOT%{_qtdir}/bin/qdbus
+ln -sf %{_bindir}/qdbusviewer $RPM_BUILD_ROOT%{_qtdir}/bin/qdbusviewer
+
 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/qtconfig-qt4.desktop
 install tools/qtconfig/images/appicon.png \
        $RPM_BUILD_ROOT%{_pixmapsdir}/qtconfig-qt4.png
 
 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}/linguist-qt4.desktop
-install tools/linguist/linguist/images/appicon.png \
-       $RPM_BUILD_ROOT%{_pixmapsdir}/linguist-qt4.png
+for f in tools/linguist/linguist/images/icons/linguist-*-32.png; do
+       size=$(echo $(basename ${f}) | cut -d- -f2)
+       install -D $f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${size}x${size}/apps/linguist-qt4.png
+done
 
 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/assistant-qt4.desktop
+install -D tools/assistant/tools/assistant/images/assistant.png \
+       $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/assistant-qt4.png
+install -D tools/assistant/tools/assistant/images/assistant-128.png \
+       $RPM_BUILD_ROOT%{_iconsdir}/hicolor/128x128/apps/assistant-qt4.png
 
 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/designer-qt4.desktop
 install tools/designer/src/designer/images/designer.png \
@@ -1609,7 +1649,7 @@ for f in translations/*.ts ; do
        LD_LIBRARY_PATH=lib bin/lrelease $f -qm translations/$(basename $f .ts).qm
 done
 
-rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*.qm
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/locale/*.qm
 for file in translations/*.qm tools/assistant/*.qm tools/designer/designer/*.qm tools/linguist/linguist/*.qm; do
        [ ! -f $file ] && continue
        case "$file" in
@@ -1735,12 +1775,14 @@ for f in `find $RPM_BUILD_ROOT%{_examplesdir}/qt4-demos -printf "%%P "`; do
 done
 
 %if %{with system_phonon}
-for a in $(sed -e '/%defattr/d;s/\(%dir\|%attr[^ ]\+\) //;' < phonon-devel.files); do
-       rm -rf $RPM_BUILD_ROOT$a
-done
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libphonon.so.*
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libphonon.so* \
+       $RPM_BUILD_ROOT%{_libdir}/libphonon.{la,prl} \
+       $RPM_BUILD_ROOT%{_libdir}/qt4/plugins/phonon_backend/libphonon_gstreamer.so \
+       $RPM_BUILD_ROOT%{_pkgconfigdir}/phonon.pc
+%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/qt4/phonon
+%if %{with static_libs}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libphonon.a
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/qt4/plugins/phonon_backend/libphonon_gstreamer.so
+%endif
 %endif
 
 %clean
@@ -1806,9 +1848,24 @@ rm -rf $RPM_BUILD_ROOT
 %post   -n QtXmlPatterns       -p /sbin/ldconfig
 %postun -n QtXmlPatterns       -p /sbin/ldconfig
 
+%post assistant
+%update_icon_cache hicolor
+
+%postun assistant
+%update_icon_cache hicolor
+
+%post linguist
+%update_icon_cache hicolor
+
+%postun linguist
+%update_icon_cache hicolor
+
 %post  phonon          -p /sbin/ldconfig
 %postun        phonon          -p /sbin/ldconfig
 
+%post qtconfig
+%update_desktop_database
+
 %files -n Qt3Support
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQt3Support.so.*.*
@@ -1838,10 +1895,14 @@ rm -rf $RPM_BUILD_ROOT
 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/qt4.qm
 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/qt4.qm
 %lang(es) %{_datadir}/locale/es/LC_MESSAGES/qt4.qm
+%lang(fa) %{_datadir}/locale/fa/LC_MESSAGES/qt4.qm
 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/qt4.qm
+%lang(gl) %{_datadir}/locale/gl/LC_MESSAGES/qt4.qm
 %lang(he) %{_datadir}/locale/he/LC_MESSAGES/qt4.qm
 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/qt4.qm
 %lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/qt4.qm
+%lang(ko) %{_datadir}/locale/ko/LC_MESSAGES/qt4.qm
+%lang(lt) %{_datadir}/locale/lt/LC_MESSAGES/qt4.qm
 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/qt4.qm
 %lang(pt) %{_datadir}/locale/pt/LC_MESSAGES/qt4.qm
 %lang(ru) %{_datadir}/locale/ru/LC_MESSAGES/qt4.qm
@@ -1866,7 +1927,9 @@ rm -rf $RPM_BUILD_ROOT
 %files -n QtDeclarative
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qmlviewer
+%attr(755,root,root) %{_bindir}/qmlplugindump
 %attr(755,root,root) %{_qtdir}/bin/qmlviewer
+%attr(755,root,root) %{_qtdir}/bin/qmlplugindump
 %attr(755,root,root) %{_libdir}/libQtDeclarative.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtDeclarative.so.4
 %dir %{_qtdir}/imports
@@ -1875,11 +1938,15 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_qtdir}/imports/Qt/labs/folderlistmodel
 %dir %{_qtdir}/imports/Qt/labs/gestures
 %dir %{_qtdir}/imports/Qt/labs/particles
+%dir %{_qtdir}/imports/Qt/labs/shaders
 %attr(755,root,root) %{_qtdir}/imports/Qt/labs/*/*.so
 %{_qtdir}/imports/Qt/labs/*/qmldir
 %dir %{_qtdir}/imports/QtWebKit
 %attr(755,root,root) %{_qtdir}/imports/QtWebKit/*.so
 %{_qtdir}/imports/QtWebKit/qmldir
+%dir %{_qtdir}/plugins/qmltooling
+%attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_tcp.so
+%attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_inspector.so
 
 %files -n QtDesigner
 %defattr(644,root,root,755)
@@ -1904,6 +1971,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_qtdir}/plugins/imageformats/libqico.so
 %attr(755,root,root) %{_qtdir}/plugins/imageformats/libqjpeg.so
 %attr(755,root,root) %{_qtdir}/plugins/imageformats/libqmng.so
+%attr(755,root,root) %{_qtdir}/plugins/imageformats/libqtga.so
 %attr(755,root,root) %{_qtdir}/plugins/imageformats/libqtiff.so
 %dir %{_qtdir}/plugins/inputmethods
 %attr(755,root,root) %{_qtdir}/plugins/inputmethods/*.so
@@ -1920,10 +1988,14 @@ rm -rf $RPM_BUILD_ROOT
 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/qt4-qt_help.qm
 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/qt4-qt_help.qm
 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/qt4-qt_help.qm
+%lang(gl) %{_datadir}/locale/gl/LC_MESSAGES/qt4-qt_help.qm
 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/qt4-qt_help.qm
 %lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/qt4-qt_help.qm
+%lang(ko) %{_datadir}/locale/ko/LC_MESSAGES/qt4-qt_help.qm
 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/qt4-qt_help.qm
 %lang(ru) %{_datadir}/locale/ru/LC_MESSAGES/qt4-qt_help.qm
+%lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/qt4-qt_help.qm
+%lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/qt4-qt_help.qm
 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/qt4-qt_help.qm
 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/qt4-qt_help.qm
 
@@ -2039,23 +2111,27 @@ rm -rf $RPM_BUILD_ROOT
 
 %files assistant
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/pixeltool
 %attr(755,root,root) %{_bindir}/assistant-qt4
+%attr(755,root,root) %{_bindir}/pixeltool
+%attr(755,root,root) %{_bindir}/qcollectiongenerator
+%attr(755,root,root) %{_qtdir}/bin/assistant
 %attr(755,root,root) %{_qtdir}/bin/pixeltool
 %attr(755,root,root) %{_qtdir}/bin/qcollectiongenerator
-%attr(755,root,root) %{_qtdir}/bin/assistant
 %lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/qt4-assistant.qm
 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/qt4-assistant.qm
 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/qt4-assistant.qm
 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/qt4-assistant.qm
 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/qt4-assistant.qm
 %lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/qt4-assistant.qm
+%lang(ko) %{_datadir}/locale/ko/LC_MESSAGES/qt4-assistant.qm
 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/qt4-assistant.qm
 %lang(ru) %{_datadir}/locale/ru/LC_MESSAGES/qt4-assistant.qm
+%lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/qt4-assistant.qm
+%lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/qt4-assistant.qm
 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/qt4-assistant.qm
 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/qt4-assistant.qm
 %{_desktopdir}/assistant-qt4.desktop
-#%{_pixmapsdir}/assistant-qt4.png
+%{_iconsdir}/hicolor/*/apps/assistant-qt4.png
 
 %files build
 %defattr(644,root,root,755)
@@ -2083,9 +2159,11 @@ rm -rf $RPM_BUILD_ROOT
 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/qt4-designer.qm
 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/qt4-designer.qm
 %lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/qt4-designer.qm
+%lang(ko) %{_datadir}/locale/ko/LC_MESSAGES/qt4-designer.qm
 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/qt4-designer.qm
 %lang(ru) %{_datadir}/locale/ru/LC_MESSAGES/qt4-designer.qm
 %lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/qt4-designer.qm
+%lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/qt4-designer.qm
 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/qt4-designer.qm
 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/qt4-designer.qm
 %{_desktopdir}/designer-qt4.desktop
@@ -2107,13 +2185,16 @@ rm -rf $RPM_BUILD_ROOT
 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/qt4-linguist.qm
 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/qt4-linguist.qm
 %lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/qt4-linguist.qm
+%lang(ko) %{_datadir}/locale/ko/LC_MESSAGES/qt4-linguist.qm
 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/qt4-linguist.qm
 %lang(ru) %{_datadir}/locale/ru/LC_MESSAGES/qt4-linguist.qm
+%lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/qt4-linguist.qm
+%lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/qt4-linguist.qm
 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/qt4-linguist.qm
 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/qt4-linguist.qm
 %{_datadir}/qt4/phrasebooks
 %{_desktopdir}/linguist-qt4.desktop
-%{_pixmapsdir}/linguist-qt4.png
+%{_iconsdir}/hicolor/*/apps/linguist-qt4.png
 
 %if %{without system_phonon}
 %files phonon
@@ -2136,8 +2217,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/qtconfig-qt4
 %attr(755,root,root) %{_qtdir}/bin/qtconfig
 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/qt4-qtconfig.qm
+%lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/qt4-qtconfig.qm
+%lang(ko) %{_datadir}/locale/ko/LC_MESSAGES/qt4-qtconfig.qm
 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ru) %{_datadir}/locale/ru/LC_MESSAGES/qt4-qtconfig.qm
+%lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/qt4-qtconfig.qm
+%lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/qt4-qtconfig.qm
 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/qt4-qtconfig.qm
 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/qt4-qtconfig.qm
 %{_desktopdir}/qtconfig-qt4.desktop
@@ -2148,8 +2233,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/qvfb
 %attr(755,root,root) %{_qtdir}/bin/qvfb
 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/qt4-qvfb.qm
+%lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/qt4-qvfb.qm
+%lang(ko) %{_datadir}/locale/ko/LC_MESSAGES/qt4-qvfb.qm
 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/qt4-qvfb.qm
 %lang(ru) %{_datadir}/locale/ru/LC_MESSAGES/qt4-qvfb.qm
+%lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/qt4-qvfb.qm
+%lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/qt4-qvfb.qm
 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/qt4-qvfb.qm
 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/qt4-qvfb.qm
 
@@ -2291,9 +2380,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libQtUiTools.a
 
-#%files -n QtWebKit-static
-#%defattr(644,root,root,755)
-#%{_libdir}/libQtWebKit.a
+%files -n QtWebKit-static
+%defattr(644,root,root,755)
+%{_libdir}/libQtWebKit.a
 
 %files -n QtDeclarative-static
 %defattr(644,root,root,755)
This page took 0.124745 seconds and 4 git commands to generate.