]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3.spec
- md5
[packages/python3.git] / python3.spec
index 757bf47a0737c56acb1346304b187109fe99ce92..a64e5e38f5972b7c2db6f14a656f43115d163adf 100644 (file)
@@ -5,11 +5,12 @@
 %bcond_without tkinter                 # disables tkinter module building
 %bcond_without tests                   # disables Python testing
 %bcond_with    verbose_tests           # runs tests in verbose mode
+%bcond_with    optimizations           # optimitations
 #
 # tests which will not work on 64-bit platforms
 %define                no64bit_tests   test_audioop test_rgbimg test_imageop
 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
-%define                nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty test_asyncio test_os test_readline
+%define                nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty test_asyncio test_os test_readline test_normalization
 
 # tests which fail because of some unknown/unresolved reason (this list should be %{nil})
 #   test_site: fails because our site.py is patched to include both /usr/share/... and /usr/lib...
@@ -18,7 +19,7 @@
 %ifarch x32
 %define                broken_tests_x32        test_time
 %endif
-%define                broken_tests    test_nntplib test_gdb test_site %{?broken_tests_x32}
+%define                broken_tests    test_nntplib test_gdb test_site test_ssl %{?broken_tests_x32}
 
 %define py_ver         3.6
 %define py_abi         %{py_ver}m
@@ -38,13 +39,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.0
-Release:       2
+Version:       %{py_ver}.6
+Release:       1
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: 82b143ebbf4514d7e05876bed7a6b1f5
+# Source0-md5: c3f30a0aff425dda77d19e02f420d6ba
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
@@ -214,6 +215,8 @@ Group:              Libraries/Python
 Provides:      python(abi) = %{py_ver}
 # for compatibility with existing Ac packages
 Provides:      python(bytecode) = %{py_ver}
+Provides:      python3-enum
+Obsoletes:     python3-enum
 %{!?with_info:Obsoletes: python3-doc-info}
 
 %description libs
@@ -229,8 +232,6 @@ Summary(pl.UTF-8):  Moduły języka Python
 Group:         Libraries/Python
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 %{?with_system_mpdecimal:Requires:     mpdecimal >= 2.4.1}
-Provides:      python3-enum
-Obsoletes:     python3-enum
 Obsoletes:     python3-modules-sqlite
 %requires_ge_to        openssl openssl-devel
 
@@ -531,7 +532,11 @@ fi
        --with-system-expat \
        --with-system-ffi \
        %{?with_system_mpdecimal:--with-system-libmpdec} \
-       --with-threads
+       --with-threads \
+%if %{with optimizations}
+       --enable-optimizations \
+       --with-lto
+%endif
 
 %{__make} 2>&1 | awk '
 BEGIN { fail = 0; logmsg = ""; }
@@ -618,7 +623,7 @@ install -p Tools/scripts/reindent.py $RPM_BUILD_ROOT%{_bindir}/pyreindent%{py_ve
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/*.bat
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/*.pyw
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/help.html
-%{__rm} $RPM_BUILD_ROOT%{py_libdir}/site-packages/README
+%{__rm} $RPM_BUILD_ROOT%{py_libdir}/site-packages/README.txt
 
 # currently provided by python-2to3, consider switching to this one
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/2to3
@@ -682,6 +687,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/bisect.py
 %{py_libdir}/codecs.py
 %{py_libdir}/copyreg.py
+%{py_libdir}/enum.py
 %{py_libdir}/functools.py
 %{py_libdir}/genericpath.py
 %{py_libdir}/heapq.py
@@ -712,6 +718,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/codecs.cpython-*.py[co]
 %{py_libdir}/__pycache__/_collections_abc.cpython-*.py[co]
 %{py_libdir}/__pycache__/copyreg.cpython-*.py[co]
+%{py_libdir}/__pycache__/enum.cpython-*.py[co]
 %{py_libdir}/__pycache__/functools.cpython-*.py[co]
 %{py_libdir}/__pycache__/genericpath.cpython-*.py[co]
 %{py_libdir}/__pycache__/heapq.cpython-*.py[co]
@@ -750,7 +757,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files modules
 %defattr(644,root,root,755)
-/etc/shrc.d/python*-modules*
+%config(noreplace) %verify(not md5 mtime size) /etc/shrc.d/python*-modules*
 %attr(755,root,root) %{_bindir}/pyvenv
 %attr(755,root,root) %{_bindir}/pyvenv-%{py_ver}
 %{py_libdir}/__future__.py
@@ -796,7 +803,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/dis.py
 %{py_libdir}/doctest.py
 %{py_libdir}/dummy_threading.py
-%{py_libdir}/enum.py
 %{py_libdir}/filecmp.py
 %{py_libdir}/fileinput.py
 %{py_libdir}/fnmatch.py
@@ -930,7 +936,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/dis.cpython-*.py[co]
 %{py_libdir}/__pycache__/doctest.cpython-*.py[co]
 %{py_libdir}/__pycache__/dummy_threading.cpython-*.py[co]
-%{py_libdir}/__pycache__/enum.cpython-*.py[co]
 %{py_libdir}/__pycache__/filecmp.cpython-*.py[co]
 %{py_libdir}/__pycache__/fileinput.cpython-*.py[co]
 %{py_libdir}/__pycache__/fnmatch.cpython-*.py[co]
@@ -1184,8 +1189,9 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/venv/__pycache__
 %{py_libdir}/venv/*.py
 %dir %{py_libdir}/venv/scripts
+%dir %{py_libdir}/venv/scripts/common
+%{py_libdir}/venv/scripts/common/activate
 %dir %{py_libdir}/venv/scripts/posix
-%{py_libdir}/venv/scripts/posix/activate
 %{py_libdir}/venv/scripts/posix/activate.csh
 %{py_libdir}/venv/scripts/posix/activate.fish
 
@@ -1265,7 +1271,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel-tools
 %defattr(644,root,root,755)
-/etc/shrc.d/python*-devel*
+%config(noreplace) %verify(not md5 mtime size) /etc/shrc.d/python*-devel*
 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
 %attr(755,root,root) %{_bindir}/pyreindent%{py_ver}
 %{py_libdir}/pdb.py
This page took 0.045592 seconds and 4 git commands to generate.