]> git.pld-linux.org Git - packages/python.git/blobdiff - python.spec
- adapterized (avoid macros with /usr/include/{ncurses,freetype}*)
[packages/python.git] / python.spec
index db26428b8bd85df940a4ac2c9b8ff8425f6d96e6..fa45249e2495f6611db656cd56ff787b99505646 100644 (file)
@@ -29,24 +29,23 @@ Summary(ru):        
 Summary(tr):   X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
 Summary(uk):   íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
 Name:          python
-Version:       %{py_ver}
-Release:       6
+Version:       %{py_ver}.2
+Release:       2.1
 Epoch:         1
 License:       PSF
 Group:         Applications
 Source0:       http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
-# Source0-md5: 44c2226eff0f3fc1f2fedaa1ce596533
+# Source0-md5: 98db1465629693fc434d4dc52db93838
 Source1:       http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
-# Source1-md5: 10cca09fcdf1b5ad269bc9edb652d76f
+# Source1-md5: 4e3f177f32e15713130d9d9cf35f991f
 Patch0:                %{name}-readline.patch
 Patch1:                %{name}-%{name}path.patch
-Patch2:                %{name}-default_encoding.patch
-Patch3:                %{name}-no_ndbm.patch
-Patch4:                %{name}-ac_fixes.patch
-Patch5:                %{name}-noarch_to_datadir.patch
-Patch6:                %{name}-lib64.patch
-Patch7:                %{name}-doc_path.patch
-Patch8:                %{name}-CAN-2005-0089.patch
+Patch2:                %{name}-no_ndbm.patch
+Patch3:                %{name}-ac_fixes.patch
+Patch4:                %{name}-noarch_to_datadir.patch
+Patch5:                %{name}-lib64.patch
+Patch6:                %{name}-doc_path.patch
+Patch7:                %{name}-db44.patch
 URL:           http://www.python.org/
 BuildRequires: autoconf
 BuildRequires: bzip2-devel
@@ -54,10 +53,11 @@ BuildRequires:      db-devel >= 4
 BuildRequires: expat-devel >= 1:1.95.7
 BuildRequires: gdbm-devel >= 1.8.3
 BuildRequires: gmp-devel >= 4.0
-BuildRequires: ncurses-ext-devel >= 5.2
 BuildRequires: libstdc++-devel
+BuildRequires: ncurses-ext-devel >= 5.2
 BuildRequires: openssl-devel >= 0.9.7d
-BuildRequires: readline-devel >= 4.2
+BuildRequires: readline-devel >= 5.0
+BuildRequires: sed >= 4.0
 %{?with_tkinter:BuildRequires: tix-devel >= 1:8.1.4-4}
 %{?with_tkinter:BuildRequires: tk-devel >= 8.4.3}
 BuildRequires: zlib-devel
@@ -77,7 +77,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define test_flags -l -x 
 %endif
 
-%ifarch alpha amd64 ia64 ppc64 sparc64 ppc64
+%ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
 %else
 %define test_list %{nobuilder_tests} %{broken_tests}
@@ -180,6 +180,9 @@ Python - 
 Summary:       Python library
 Summary(pl):   Biblioteka jêzyka Python
 Group:         Libraries/Python
+# broken detection in rpm/pythondeps.sh
+Provides:      python(abi) = %{py_ver}
+# for compatibility with existing Ac packages
 Provides:      python(bytecode) = %{py_ver}
 
 %description libs
@@ -315,7 +318,8 @@ Requires:   %{name}-modules = %{epoch}:%{version}-%{release}
 Python development tools such as profilers and debugger.
 
 %description devel-tools -l pl
-Narzêdzia programistyczne jêzyka Python takie jak profiler oraz debugger.
+Narzêdzia programistyczne jêzyka Python takie jak profiler oraz
+debugger.
 
 %package static
 Summary:       Static python library
@@ -362,8 +366,8 @@ son interpr
 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
-napisanych w LaTeXu, tylko gotowe do wykorzystania pliki
-postscriptowe i HTML.
+napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
+i HTML.
 
 %description doc -l pt_BR
 O pacote python-doc contém documentação para a linguagem de
@@ -407,8 +411,8 @@ Eine grafische Schnittstelle f
 vielen Konfigurations-Tools genutzt.
 
 %description tkinter -l es
-Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por
-muchas herramientas de configuración.
+Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
+herramientas de configuración.
 
 %description tkinter -l fr
 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
@@ -469,28 +473,27 @@ Przyk
 %setup -q -n Python-%{version}
 %patch0 -p1
 %patch1 -p1
-# should be already fixed in the source but seems not to be:
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %if "%{_lib}" == "lib64"
-%patch6 -p1
+%patch5 -p1
 %endif
+%patch6 -p1
 %patch7 -p1
-%patch8 -p1
 
 tar -xf %{SOURCE1} --use=bzip2
 
 %build
 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
 %{__autoconf}
-CPPFLAGS="-I%{_includedir}/ncurses"; export CPPFLAGS
+CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
 %configure \
        --with-threads \
-       --with-cxx=%{__cxx} \
+       --with-cxx="%{__cxx}" \
        --enable-unicode=ucs4 \
-       --enable-shared
+       --enable-shared \
+       LINKCC='$(PURIFY) $(CXX)'
 
 %{__make} \
        OPT="%{rpmcflags}"
@@ -550,9 +553,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/python
 %{_mandir}/man1/*
 
-# readline support for python binary
-%attr(755,root,root) %{py_dyndir}/readline.so
-
 %files modules
 %defattr(644,root,root,755)
 %exclude %{py_scriptdir}/UserDict.py[co]
@@ -578,7 +578,7 @@ rm -rf $RPM_BUILD_ROOT
 
 # three modules below does not work on 64-bit architectures
 # see Python README file for explanation
-%ifnarch alpha amd64 ia64 ppc64 sparc64
+%ifnarch alpha ia64 ppc64 sparc64 %{x8664}
 %attr(755,root,root) %{py_dyndir}/audioop.so
 %attr(755,root,root) %{py_dyndir}/rgbimg.so
 %attr(755,root,root) %{py_dyndir}/imageop.so
@@ -632,6 +632,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_dyndir}/parser.so
 %attr(755,root,root) %{py_dyndir}/pwd.so
 %attr(755,root,root) %{py_dyndir}/pyexpat.so
+%attr(755,root,root) %{py_dyndir}/readline.so
 %attr(755,root,root) %{py_dyndir}/regex.so
 %attr(755,root,root) %{py_dyndir}/resource.so
 %attr(755,root,root) %{py_dyndir}/select.so
@@ -791,10 +792,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 # FIXME
 %doc Python-Docs-%{version}
-%dir %{py_scriptdir}/test
-%attr(-,root,root) %{py_scriptdir}/test/*
-%attr(-,root,root) %{py_scriptdir}/email/test/*
-%attr(-,root,root) %{py_scriptdir}/bsddb/test/*
+%attr(-,root,root) %{py_scriptdir}/test
+%attr(-,root,root) %{py_scriptdir}/email/test
+%attr(-,root,root) %{py_scriptdir}/bsddb/test
 
 %if %{with tkinter}
 %files tkinter
This page took 0.037083 seconds and 4 git commands to generate.