]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - python.spec
- macros for py3* macros
[projects/template-specs.git] / python.spec
index 12bcca5278f86a2c162bf11ed1c88ac47c05af3d..6139837bbda368ab1e1c494a9f00f4e41241eb64 100644 (file)
@@ -21,17 +21,19 @@ URL:                -
 BuildRequires: rpm-pythonprov
 # if py_postclean is used
 BuildRequires: rpmbuild(macros) >= 1.219
+# if py3* macros are used
+BuildRequires: rpmbuild(macros) >= 1.612
 # when using /usr/bin/env or other in-place substitutions
 #BuildRequires:        sed >= 4.0
 # when python3 present
 %if %{with python2}
 BuildRequires: python-devel
-BuildRequires: python-setuptools >= 7.0
+BuildRequires: python-setuptools
 %endif
 %if %{with python3}
 BuildRequires: python3-devel
 BuildRequires: python3-modules
-BuildRequires: python3-setuptools >= 7.0
+BuildRequires: python3-setuptools
 %endif
 # Below Rs only work for main package (python2)
 #Requires:             python-libs
@@ -70,6 +72,11 @@ Dokumentacja API %{module}.
 # fix #!/usr/bin/env python -> #!/usr/bin/python:
 #%{__sed} -i -e '1s,^#!.*python,#!%{__python},' %{name}.py
 
+# setup copy of source in py3 dir
+set -- *
+install -d py3
+cp -a "$@" py3
+
 %build
 %if %{with python2}
 # CC/CFLAGS is only for arch packages - remove on noarch packages
This page took 0.04577 seconds and 4 git commands to generate.