]> git.pld-linux.org Git - packages/python-urllib3.git/blobdiff - python-urllib3.spec
- updated to 1.25.11 (last compatible with requests 2.23.x)
[packages/python-urllib3.git] / python-urllib3.spec
index a6ebe473947cc2085fcad50da40dd3c943959709..f35bfd6832ad2e1276bc434795bee31084f8675e 100644 (file)
 Summary:       HTTP library with thread-safe connection pooling, file post, and more
 Summary(pl.UTF-8):     Biblioteka HTTP z bezpieczną wątkowo pulą połączeń, wysyłaniem plików itd.
 Name:          python-%{module}
-Version:       1.25.9
+Version:       1.25.11
 Release:       1
 License:       MIT
 Group:         Development/Languages/Python
 #Source0Download: https://pypi.org/simple/urllib3/
 Source0:       https://files.pythonhosted.org/packages/source/u/urllib3/%{module}-%{version}.tar.gz
-# Source0-md5: dbf9b868b90880b24b1ac278094e912e
+# Source0-md5: d47dd21a6e66a03c3633cac468ffd010
 Patch0:                %{name}-mock.patch
 Patch1:                %{name}-httplib.patch
 URL:           http://urllib3.readthedocs.org/
@@ -26,13 +26,17 @@ BuildRequires:      glibc-localedb-all
 %if %{with python2}
 BuildRequires: python-modules >= 1:2.7
 %if %{with tests}
-BuildRequires: python-PySocks >= 1.5.6
+BuildRequires: python-PySocks >= 1.7.1
 BuildRequires: python-PySocks < 2.0
 BuildRequires: python-cryptography >= 2.8
+BuildRequires: python-dateutil >= 2.8.1
+BuildRequires: python-flaky >= 3.6.1
 # TODO
 #BuildRequires:        python-gcp_devrel-py-tools >= 0.0.15
 BuildRequires: python-mock >= 3.0.5
-BuildRequires: python-pytest
+BuildRequires: python-pytest >= 4.6.9
+BuildRequires: python-pytest-freezegun >= 0.3.0
+BuildRequires: python-pytest-timeout >= 1.3.4
 BuildRequires: python-tornado >= 5.1.1
 BuildRequires: python-trustme >= 0.5.3
 # SO_REUSEPORT option
@@ -42,11 +46,15 @@ BuildRequires:      uname(release) >= 3.9
 %if %{with python3}
 BuildRequires: python3-modules >= 1:3.5
 %if %{with tests}
-BuildRequires: python3-PySocks >= 1.5.6
+BuildRequires: python3-PySocks >= 1.7.1
 BuildRequires: python3-PySocks < 2.0
 BuildRequires: python3-cryptography >= 2.8
+BuildRequires: python3-dateutil >= 2.8.1
+BuildRequires: python3-flaky >= 3.6.1
 #BuildRequires:        python3-gcp_devrel-py-tools >= 0.0.15
-BuildRequires: python3-pytest
+BuildRequires: python3-pytest >= 4.6.9
+BuildRequires: python3-pytest-freezegun >= 0.4.2
+BuildRequires: python3-pytest-timeout >= 1.3.4
 BuildRequires: python3-tornado >= 6.0.3
 BuildRequires: python3-trustme >= 0.5.3
 # SO_REUSEPORT option
@@ -129,10 +137,16 @@ Dokumentacja API modułu Pythona urllib3.
 %if %{with python2}
 %py_build
 
-%if %{with tests_py2}
+%if %{with tests}
+# RECENT_DATE is too old
+# test_retry.py: many failures with py2
+# TestSSL: unknown ca, timeout errors etc.
 LC_ALL=C.UTF-8 \
 PYTHONPATH=$(pwd)/src \
-%{__python} -m pytest test
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="flaky.flaky_pytest_plugin,pytest_freezegun,pytest_timeout" \
+%{__python} -m pytest test -k 'not (test_recent_date or test_retry or test_ssl_read_timeout or test_ssl_failed_fingerprint_verification)'
+# or TestSSL)'
 %endif
 %endif
 
@@ -140,8 +154,12 @@ PYTHONPATH=$(pwd)/src \
 %py3_build
 
 %if %{with tests}
+# RECENT_DATE is too old
+# TestSSL: verification errors
 PYTHONPATH=$(pwd)/src \
-%{__python3} -m pytest test
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="flaky.flaky_pytest_plugin,pytest_freezegun,pytest_timeout" \
+%{__python3} -m pytest test -k 'not (test_recent_date or test_ssl_read_timeout or test_ssl_failed_fingerprint_verification)'
 %endif
 %endif
 
@@ -156,6 +174,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %py_install
+
 %py_postclean
 %endif
 
This page took 0.053185 seconds and 4 git commands to generate.