]> git.pld-linux.org Git - packages/python-urllib3.git/blobdiff - python-urllib3.spec
- updated to 1.25.9
[packages/python-urllib3.git] / python-urllib3.spec
index fae8ee9baf4fb44d6219a70fc24cee64ed75c989..a6ebe473947cc2085fcad50da40dd3c943959709 100644 (file)
@@ -4,40 +4,51 @@
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 %bcond_without doc     # Sphinx documentation
-%bcond_with    tests   # test target (uses network etc.)
+%bcond_with    tests   # test target (uses network etc., few failures)
 
 %define                module          urllib3
 Summary:       HTTP library with thread-safe connection pooling, file post, and more
 Summary(pl.UTF-8):     Biblioteka HTTP z bezpieczną wątkowo pulą połączeń, wysyłaniem plików itd.
 Name:          python-%{module}
-Version:       1.25.7
+Version:       1.25.9
 Release:       1
 License:       MIT
 Group:         Development/Languages/Python
 #Source0Download: https://pypi.org/simple/urllib3/
 Source0:       https://files.pythonhosted.org/packages/source/u/urllib3/%{module}-%{version}.tar.gz
-# Source0-md5: 85e1e3925f8c1095172bff343f3312ed
+# Source0-md5: dbf9b868b90880b24b1ac278094e912e
 Patch0:                %{name}-mock.patch
+Patch1:                %{name}-httplib.patch
 URL:           http://urllib3.readthedocs.org/
+%if %(locale -a | grep -q '^C\.utf8$'; echo $?)
+BuildRequires: glibc-localedb-all
+%endif
 %if %{with python2}
 BuildRequires: python-modules >= 1:2.7
 %if %{with tests}
 BuildRequires: python-PySocks >= 1.5.6
 BuildRequires: python-PySocks < 2.0
-BuildRequires: python-mock
-BuildRequires: python-nose
-BuildRequires: python-tornado
+BuildRequires: python-cryptography >= 2.8
+# TODO
+#BuildRequires:        python-gcp_devrel-py-tools >= 0.0.15
+BuildRequires: python-mock >= 3.0.5
+BuildRequires: python-pytest
+BuildRequires: python-tornado >= 5.1.1
+BuildRequires: python-trustme >= 0.5.3
 # SO_REUSEPORT option
 BuildRequires: uname(release) >= 3.9
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.4
+BuildRequires: python3-modules >= 1:3.5
 %if %{with tests}
 BuildRequires: python3-PySocks >= 1.5.6
 BuildRequires: python3-PySocks < 2.0
-BuildRequires: python3-nose
-BuildRequires: python3-tornado
+BuildRequires: python3-cryptography >= 2.8
+#BuildRequires:        python3-gcp_devrel-py-tools >= 0.0.15
+BuildRequires: python3-pytest
+BuildRequires: python3-tornado >= 6.0.3
+BuildRequires: python3-trustme >= 0.5.3
 # SO_REUSEPORT option
 BuildRequires: uname(release) >= 3.9
 %endif
@@ -76,7 +87,7 @@ plików metodą POST. Możliwości:
 Summary:       HTTP library with thread-safe connection pooling, file post, and more
 Summary(pl.UTF-8):     Biblioteka HTTP z bezpieczną wątkowo pulą połączeń, wysyłaniem plików itd.
 Group:         Development/Languages/Python
-Requires:      python3-modules >= 1:3.4
+Requires:      python3-modules >= 1:3.5
 
 %description -n python3-urllib3
 Python 3 HTTP module with connection pooling and file POST abilities.
@@ -112,14 +123,26 @@ Dokumentacja API modułu Pythona urllib3.
 %prep
 %setup -q -n %{module}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+
+%if %{with tests_py2}
+LC_ALL=C.UTF-8 \
+PYTHONPATH=$(pwd)/src \
+%{__python} -m pytest test
+%endif
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
+%py3_build
+
+%if %{with tests}
+PYTHONPATH=$(pwd)/src \
+%{__python3} -m pytest test
+%endif
 %endif
 
 %if %{with doc}
This page took 0.034569 seconds and 4 git commands to generate.