]> git.pld-linux.org Git - packages/python-setuptools.git/blobdiff - python-setuptools.spec
up to 40.2.0
[packages/python-setuptools.git] / python-setuptools.spec
index f7231b4d4f220e9324b37cbd31a1845dd743e690..12067e8337f48f4397bcea885fdf4b1123004575 100644 (file)
@@ -1,36 +1,65 @@
 #
 # Conditional build:
-%bcond_without apidocs # sphinx based documentation
-%bcond_with    tests   # "test" action (fails?)
-%bcond_without python2 # CPython 2.x module
-%bcond_without python3 # CPython 3.x module
+%bcond_without apidocs         # Sphinx based documentation
+%bcond_with    tests           # py.test tests (few failures)
+%bcond_without python2         # CPython 2.x module
+%bcond_without python3         # CPython 3.x module
+%bcond_without python3_default # Use Python 3.x for easy_install executable
+
+%if %{without python3}
+%undefine      python3_default
+%endif
 
 %define                module  setuptools
 Summary:       A collection of enhancements to the Python distutils
 Summary(pl.UTF-8):     Zestaw rozszerzeń dla pythonowych distutils
 Name:          python-setuptools
-Version:       7.0
-Release:       2
+Version:       40.2.0
+Release:       1
 Epoch:         1
 License:       PSF or ZPL
 Group:         Development/Languages/Python
-Source0:       https://pypi.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
-# Source0-md5: 6245d6752e2ef803c365f560f7f2f940
-URL:           https://bitbucket.org/pypa/setuptools
-%if %(locale -a | grep -q '^en_US.UTF-8$'; echo $?)
+#Source0Download: https://pypi.python.org/simple/setuptools/
+Source0:       https://files.pythonhosted.org/packages/ef/1d/201c13e353956a1c840f5d0fbf0461bd45bbd678ea4843ebf25924e8984c/setuptools-%{version}.zip
+# Source0-md5: 592efabea3a65d8e97a025ed52f69b12
+URL:           https://github.com/pypa/setuptools
+%if %(locale -a | grep -q '^C.UTF-8$'; echo $?)
 BuildRequires: glibc-localedb-all
 %endif
 %if %{with python2}
-BuildRequires: python-distribute
+BuildRequires: python-appdirs >= 1.4.0
 BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-packaging >= 16.8
+BuildConflicts:        python-distribute < 0.7
+BuildRequires: python-six >= 1.6.0
+%if %{with tests}
+BuildRequires: python-backports.unittest_mock >= 1.2
+BuildRequires: python-pytest >= 3.0.2
+BuildRequires: python-pytest-flake8
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3-distribute
-BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-appdirs >= 1.4.0
+BuildRequires: python3-modules >= 1:3.3
+BuildRequires: python3-packaging >= 16.8
+BuildRequires: python3-six >= 1.6.0
+BuildConflicts:        python3-distribute < 0.7
+%if %{with tests}
+BuildRequires: python3-pytest >= 3.0.2
+BuildRequires: python3-pytest-flake8
+%endif
+%endif
+%if %{with apidocs}
+BuildRequires: python3-jaraco
+BuildRequires: python3-jaraco.packaging
+BuildRequires: python3-rst.linker >= 1.6.1
+BuildRequires: sphinx-pdg-3 >= 1.4
 %endif
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.714
+BuildRequires: unzip
 Requires:      python-modules >= 1:2.6
-Obsoletes:     python-distribute
+Obsoletes:     python-distribute < 0.7
 Obsoletes:     python-setuptools-devel
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -53,7 +82,8 @@ Pythona 2.x.
 Summary:       A collection of enhancements to the Python distutils
 Summary(pl.UTF-8):     Zestaw rozszerzeń dla pythonowych distutils
 Group:         Libraries/Python
-Requires:      python3-modules >= 1:3.2
+Requires:      python3-modules >= 1:3.3
+Obsoletes:     python3-distribute < 0.7
 
 %description -n python3-%{module}
 setuptools is a collection of enhancements to the Python distutils
@@ -65,6 +95,23 @@ setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
 łatwiejsze budowanie i rozprowadzanie pakietów Pythona 3.x,
 szczególnie tych mających zależności od innych pakietów.
 
+%package -n easy_install
+Summary:       Python software installer
+Summary(pl.UTF-8):     Instalator oprogramowania napisanego w Pythonie
+Group:         Libraries/Python
+%if %{with python3_default}
+Requires:      python3-%{module} = %{epoch}:%{version}-%{release}
+%else
+Requires:      python-%{module} = %{epoch}:%{version}-%{release}
+%endif
+Conflicts:     python-setuptools < 1:18.6.1-2
+
+%description -n easy_install
+Python software installer.
+
+%description -n easy_install -l pl.UTF-8
+Instalator oprogramowania napisanego w Pythonie.
+
 %package apidocs
 Summary:       %{module} API documentation
 Summary(pl.UTF-8):     Dokumentacja API %{module}
@@ -81,38 +128,41 @@ Dokumentacja API %{module}.
 
 %build
 %if %{with python2}
-LC_ALL=en_US.UTF-8 \
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+LC_ALL=C.UTF-8 \
+%py_build
+
+%{?with_tests:%{__python} -m pytest pkg_resources/tests setuptools/tests tests}
 %endif
 
 %if %{with python3}
-LC_ALL=en_US.UTF-8 \
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+LC_ALL=C.UTF-8 \
+%py3_build
+
+%{?with_tests:%{__python3} -m pytest pkg_resources/tests setuptools/tests tests}
 %endif
 
 %if %{with apidocs}
-%{__make} -C docs html
+%{__make} -C docs html SPHINXBUILD=sphinx-build-3
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python3}
-%{__python3} setup.py \
-       build --build-base build-3 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 %if %{with python2}
-%{__python} setup.py \
-       build --build-base build-2 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
+
+# note: setuptools/command/easy_install.py expects setuptools/site-patch.py to exist
+%py_postclean -x site-patch.py
+%endif
 
-%py_postclean
+%if %{with python3_default}
+ln -sf easy_install-%{py3_ver} $RPM_BUILD_ROOT%{_bindir}/easy_install
+%else
+ln -sf easy_install-%{py_ver} $RPM_BUILD_ROOT%{_bindir}/easy_install
 %endif
 
 %clean
@@ -121,32 +171,32 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc CHANGES.txt README.txt DEVGUIDE.txt
-%attr(755,root,root) %{_bindir}/easy_install
-%attr(755,root,root) %{_bindir}/easy_install-2.*
-%{py_sitescriptdir}/%{module}
-%{py_sitescriptdir}/_markerlib
+%doc CHANGES.rst README.rst
+%attr(755,root,root) %{_bindir}/easy_install-%{py_ver}
+%{py_sitescriptdir}/pkg_resources
+%{py_sitescriptdir}/setuptools
 %{py_sitescriptdir}/easy_install.py[co]
-%{py_sitescriptdir}/pkg_resources.py[co]
 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc CHANGES.txt README.txt DEVGUIDE.txt
-%attr(755,root,root) %{_bindir}/easy_install-3.*
+%doc CHANGES.rst README.rst
+%attr(755,root,root) %{_bindir}/easy_install-%{py3_ver}
 %{py3_sitescriptdir}/__pycache__/easy_install.*.py[co]
-%{py3_sitescriptdir}/__pycache__/pkg_resources.*.py[co]
-%{py3_sitescriptdir}/%{module}
-%{py3_sitescriptdir}/_markerlib
+%{py3_sitescriptdir}/pkg_resources
+%{py3_sitescriptdir}/setuptools
 %{py3_sitescriptdir}/easy_install.py
-%{py3_sitescriptdir}/pkg_resources.py
 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
 
+%files -n easy_install
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/easy_install
+
 %if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
-%doc docs/build/html/*
+%doc docs/build/html/{_static,*.html,*.js}
 %endif
This page took 0.060365 seconds and 4 git commands to generate.