]> git.pld-linux.org Git - packages/python-requests.git/blobdiff - python-requests.spec
Version: 2.18.2
[packages/python-requests.git] / python-requests.spec
index 315ffe69b7f2284ff7c1e80dec83c0803eb48958..ad0da4deed1e90b1a747fb84c5e7e25143b19c87 100644 (file)
@@ -1,36 +1,58 @@
+#
 # Conditional build:
-%bcond_without  python2         # build python 2 module
-%bcond_without  python3         # build python 3 module
+%bcond_with    tests   # test target (tests not included in dist tarball as of 2.13.0)
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
 #
+%define                urllib3ver      1.21.1
 %define        module  requests
-Summary:       HTTP library for Python
-Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona
+Summary:       HTTP library for Python 2
+Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 2
 Name:          python-%{module}
-Version:       2.4.1
+Version:       2.18.2
 Release:       1
-License:       Apache2
+License:       Apache v2.0
 Group:         Development/Languages/Python
-Source0:       https://pypi.python.org/packages/source/r/requests/%{module}-%{version}.tar.gz
-# Source0-md5: 931461f761c70708c46ea65b7889da58
-URL:           http://python-requests.org
-Patch0:                system-charade-and-urllib3.patch
-Patch1:                system-cert.patch
+Source0:       https://pypi.python.org/packages/07/2e/81fdfdfac91cf3cb2518fb149ac67caf0e081b485eab68e9aee63396f7e8/requests-2.18.2.tar.gz
+# Source0-md5: 49bd9924d3be341871bc922cde6f372e
+Patch0:                system-cert.patch
+URL:           http://python-requests.org/
 %if %{with python2}
-BuildRequires: python-charade
 BuildRequires: python-modules >= 1:2.6
-BuildRequires: python-urllib3 >= 1.9.1
+%if %{with tests}
+BuildRequires: python-chardet >= 3.0.2
+BuildRequires: python-idna >= 2.5
+BuildRequires: python-urllib3 >= %{urllib3ver}
+BuildRequires: python-certifi >= 2017.4.17
+BuildRequires: python-pytest >= 2.8.0
+BuildRequires: python-pytest-cov
+BuildRequires: python-pytest-httpbin >= 0.0.7
+BuildRequires: python-pytest-mock
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3-charade
-BuildRequires: python3-modules >= 3.2
-BuildRequires: python3-urllib3 >= 1.9.1
+BuildRequires: python3-modules >= 1:3.2
+%if %{with tests}
+BuildRequires: python3-chardet >= 3.0.2
+BuildRequires: python3-idna >= 2.5
+BuildRequires: python3-urllib3 >= %{urllib3ver}
+BuildRequires: python3-certifi >= 2017.4.17
+BuildRequires: python3-pytest >= 2.8.0
+BuildRequires: python3-pytest-cov
+BuildRequires: python3-pytest-httpbin >= 0.0.7
+BuildRequires: python3-pytest-mock
+%endif
 %endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
-Requires:      ca-certificates
-Requires:      python-charade
-Requires:      python-modules >= 1:2.6
-Requires:      python-urllib3 >= 1.9.1
+BuildRequires: rpmbuild(macros) >= 1.713
+Suggests:      ca-certificates
+Requires:      python-chardet >= 3.0.2
+Requires:      python-idna >= 2.5
+Requires:      python-urllib3 >= %{urllib3ver}
+# for python2 only to get SNI working. python3 doesn't need this
+Requires:      python-ndg-httpsclient
+Requires:      python-pyasn1
+Requires:      python-pyOpenSSL >= 0.14
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -44,6 +66,8 @@ broken. It requires an enormous amount of work (even method overrides)
 to perform the simplest of tasks. Things shouldn't be this way. Not in
 Python.
 
+This package contains Python 2.x module.
+
 %description -l pl.UTF-8
 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
 
@@ -53,14 +77,16 @@ zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
 
+Ten pakiet zawiera moduł dla Pythona 2.x.
+
 %package -n python3-requests
-Summary:       HTTP library, written in Python, for human beings
-Summary(pl.UTF-8):     Biblioteka HTTP library napisana w Pythonie dla ludzi
+Summary:       HTTP library for Python 3
+Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 3
 Group:         Development/Languages/Python
-Requires:      ca-certificates
-Requires:      python3-charade
-Requires:      python3-modules >= 3.2
-Requires:      python3-urllib3 >= 1.9.1
+Suggests:      ca-certificates
+Requires:      python-chardet >= 3.0.2
+Requires:      python-idna >= 2.5
+Requires:      python-urllib3 >= %{urllib3ver}
 
 %description -n python3-requests
 Requests is a HTTP library, written in Python, for human beings.
@@ -72,6 +98,8 @@ broken. It requires an enormous amount of work (even method overrides)
 to perform the simplest of tasks. Things shouldn't be this way. Not in
 Python.
 
+This package contains Python 3.x module.
+
 %description -n python3-requests -l pl.UTF-8
 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
 
@@ -81,46 +109,35 @@ zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
 
+Ten pakiet zawiera moduł dla Pythona 3.x.
+
 %prep
 %setup -q -n %{module}-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 %if %{with python2}
-%{__python} setup.py build -b py2
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
-%{__python3} setup.py build -b py3
+%py3_build %{?with_tests:test}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build -b py2 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py  \
-       build -b py3 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
-%{__rm} -rf $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/{cacert.pem,packages}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -129,10 +146,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc HISTORY.rst README.rst
 %{py_sitescriptdir}/%{module}
-%if "%{py_ver}" > "2.4"
 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
-%endif
 
 %if %{with python3}
 %files -n python3-requests
This page took 0.053317 seconds and 4 git commands to generate.