]> git.pld-linux.org Git - packages/python-path.git/blobdiff - python-path.spec
rebuild with tests and docs
[packages/python-path.git] / python-path.spec
index 59d1e0d72ab7a521ac3fe933b7b746f58abcbcad..bd4b809087f9cc58c62fd9d19805afd4d4ab01a1 100644 (file)
@@ -1,50 +1,61 @@
 #
 # Conditional build:
 %bcond_without python2 # CPython 2.x module
-%bcond_without python3 # CPython 3.x module
+%bcond_with    python3 # CPython 3.x module (built from python3-path.spec)
 %bcond_without doc     # Sphinx documentation
 %bcond_without tests   # py.test unit tests
 
 Summary:       Python 2 module wrapper for os.path
 Summary(pl.UTF-8):     Moduł Pythona 2 obudowujący os.path
 Name:          python-path
-Version:       10.1
-Release:       2
+# keep 11.x here for python2 support
+Version:       11.5.2
+Release:       4
 License:       MIT
 Group:         Libraries/Python
-#Source0Download: https://pypi.python.org/simple/path.py
-Source0:       https://pypi.python.org/packages/5d/54/4b2301e48a5889de9d121f6232e1833f19513fb24a93c0cbdb919eeec1dd/path.py-%{version}.tar.gz
-# Source0-md5: f9d31317ceeb798f6b5eac8d3b8e5988
-Patch0:                %{name}-sphinx.patch
+#Source0Download: https://pypi.python.org/simple/path-py/
+Source0:       https://files.pythonhosted.org/packages/source/p/path.py/path.py-%{version}.tar.gz
+# Source0-md5: f7330990e70574d917630c157eeb639a
 URL:           https://github.com/jaraco/path.py
-%if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
+%if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
 BuildRequires: glibc-localedb-all
 %endif
 %if %{with python2}
 BuildRequires: python >= 1:2.7
 BuildRequires: python-modules >= 1:2.7
-BuildRequires: python-setuptools
+BuildRequires: python-setuptools >= 1:31.0.1
 BuildRequires: python-setuptools_scm >= 1.15.0
 %if %{with tests}
 BuildRequires: python-appdirs
-BuildRequires: python-pytest >= 2.8
+BuildRequires: python-backports.os
+BuildRequires: python-importlib_metadata >= 0.5
+BuildRequires: python-packaging
+BuildRequires: python-pygments
+BuildRequires: python-pytest >= 3.5
+BuildRequires: python-pytest-flake8
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3 >= 1:3.3
-BuildRequires: python3-modules >= 1:3.3
-BuildRequires: python3-setuptools
+BuildRequires: python3 >= 1:3.4
+BuildRequires: python3-modules >= 1:3.4
+BuildRequires: python3-setuptools >= 1:31.0.1
 BuildRequires: python3-setuptools_scm >= 1.15.0
 %if %{with tests}
 BuildRequires: python3-appdirs
-BuildRequires: python3-pytest >= 2.8
+BuildRequires: python3-importlib_metadata >= 0.5
+BuildRequires: python3-packaging
+BuildRequires: python3-pygments
+BuildRequires: python3-pytest >= 3.5
+BuildRequires: python3-pytest-flake8
 %endif
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with doc}
-BuildRequires: sphinx-pdg
-BuildRequires: python3-rst.linker
+BuildRequires: sphinx-pdg-2
+BuildRequires: python-alabaster
+BuildRequires: python-jaraco.packaging >= 3.2
+BuildRequires: python-rst.linker >= 1.9
 %endif
 Requires:      python-modules >= 1:2.7
 BuildArch:     noarch
@@ -64,7 +75,7 @@ na tych ścieżkach.
 Summary:       Python 3 module wrapper for os.path
 Summary(pl.UTF-8):     Moduł Pythona 3 obudowujący os.path
 Group:         Libraries/Python
-Requires:      python3-modules >= 1:3.3
+Requires:      python3-modules >= 1:3.4
 
 %description -n python3-path
 path.py implements a path objects as first-class entities, allowing
@@ -89,14 +100,16 @@ Dokumentacja modułu Pythona path.py.
 
 %prep
 %setup -q -n path.py-%{version}
-%patch0 -p1
 
 %build
 %if %{with python2}
 %py_build
 
 %if %{with tests}
-LC_ALL=C.UTF-8 %{__python} -m pytest test_path.py
+LC_ALL=C.UTF-8 \
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="pytest_flake8" \
+%{__python} -m pytest test_path.py
 %endif
 %endif
 
@@ -104,14 +117,17 @@ LC_ALL=C.UTF-8 %{__python} -m pytest test_path.py
 %py3_build
 
 %if %{with tests}
-LC_ALL=C.UTF-8 %{__python3} -m pytest test_path.py
+LC_ALL=C.UTF-8 \
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="pytest_flake8" \
+%{__python3} -m pytest test_path.py
 %endif
 %endif
 
 %if %{with doc}
-install -d docs/_static
 # disable warnings (-W in SPHINXOPTS) to ignore objects.inv fetching error on builders
 %{__make} -C docs html \
+       SPHINXBUILD=sphinx-build-2 \
        SPHINXOPTS=
 %endif
 
@@ -122,14 +138,10 @@ rm -rf $RPM_BUILD_ROOT
 %py_install
 
 %py_postclean
-%{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/test_path.py*
 %endif
 
 %if %{with python3}
 %py3_install
-
-%{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/test_path.py
-%{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/__pycache__/test_path.*
 %endif
 
 %clean
@@ -138,7 +150,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc CHANGES.rst README.rst
+%doc CHANGES.rst LICENSE README.rst
 %{py_sitescriptdir}/path.py[co]
 %{py_sitescriptdir}/path.py-%{version}-py*.egg-info
 %endif
@@ -146,7 +158,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-path
 %defattr(644,root,root,755)
-%doc CHANGES.rst README.rst
+%doc CHANGES.rst LICENSE README.rst
 %{py3_sitescriptdir}/path.py
 %{py3_sitescriptdir}/__pycache__/path.cpython-*.py[co]
 %{py3_sitescriptdir}/path.py-%{version}-py*.egg-info
This page took 0.104729 seconds and 4 git commands to generate.