]> git.pld-linux.org Git - packages/python-bs4.git/blobdiff - python-bs4.spec
rebuild with python 3.10
[packages/python-bs4.git] / python-bs4.spec
index 990fe48a35c8bb40f6f38d3e0aa73e08cb096781..8d17d20346461a8b028abce43cdd556e7a5d06a5 100644 (file)
@@ -1,29 +1,39 @@
 #
 # Conditional build:
-%bcond_without tests   # do not perform "make test"
+%bcond_without doc     # Sphinx documentation
+%bcond_without tests   # unit tests
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
 %define        module  bs4
 Summary:       beautifulsoup4 - Screen-scraping library
+Summary(pl.UTF-8):     beautifulsoup4 - biblioteka przechwytująca wyjście
 Name:          python-%{module}
-Version:       4.4.1
-Release:       4
+Version:       4.6.3
+Release:       2
 License:       MIT
 Group:         Libraries/Python
-Source0:       https://pypi.python.org/packages/source/b/beautifulsoup4/beautifulsoup4-%{version}.tar.gz
-# Source0-md5: 8fbd9a7cac0704645fa20d1419036815
+#Source0Download: https://pypi.org/simple/beautifulsoup4/
+Source0:       https://files.pythonhosted.org/packages/source/b/beautifulsoup4/beautifulsoup4-%{version}.tar.gz
+# Source0-md5: a08ea866a5c508d9b4c28c4d21e05df8
 Patch0:                test_suite.patch
-URL:           http://www.crummy.com/software/BeautifulSoup/bs4/
-BuildRequires: rpmbuild(macros) >= 1.710
+Patch1:                %{name}-lxml.patch
+Patch2:                %{name}-smart_quotes.patch
+URL:           https://www.crummy.com/software/BeautifulSoup/
+BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: rpm-pythonprov
 %if %{with python2}
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
 %endif
 %if %{with python3}
+BuildRequires: python3-modules >= 1:3.2
 BuildRequires: python3-setuptools
 %endif
-Requires:      python-modules
+%if %{with doc}
+BuildRequires: sphinx-pdg
+%endif
+Requires:      python-modules >= 1:2.7
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -31,18 +41,42 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Beautiful Soup sits atop an HTML or XML parser, providing Pythonic
 idioms for iterating, searching, and modifying the parse tree.
 
+%description -l pl.UTF-8
+Beautiful Soup rezyduje powyżej parsera HTML lub XML, zapewniając
+pythonowe idiomy do iterowania, wyszukiwania i modyfikowania drzewa
+analizy.
+
 %package -n python3-%{module}
 Summary:       beautifulsoup4 - Screen-scraping library
+Summary(pl.UTF-8):     beautifulsoup4 - biblioteka przechwytująca wyjście
 Group:         Libraries/Python
-Requires:      python3-modules
+Requires:      python3-modules >= 1:3.2
 
 %description -n python3-%{module}
 Beautiful Soup sits atop an HTML or XML parser, providing Pythonic
 idioms for iterating, searching, and modifying the parse tree.
 
+%description -n python3-%{module} -l pl.UTF-8
+Beautiful Soup rezyduje powyżej parsera HTML lub XML, zapewniając
+pythonowe idiomy do iterowania, wyszukiwania i modyfikowania drzewa
+analizy.
+
+%package apidocs
+Summary:       API documentation for Python beautifulsoup4 module
+Summary(pl.UTF-8):     Dokumentacja API modułu Pythona beautifulsoup4
+Group:         Documentation
+
+%description apidocs
+API documentation for Python beautifulsoup4 module.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API modułu Pythona beautifulsoup4.
+
 %prep
 %setup -q -n beautifulsoup4-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %if %{with python2}
@@ -54,9 +88,7 @@ idioms for iterating, searching, and modifying the parse tree.
 %endif
 
 %if %{with doc}
-cd docs
-%{__make} -j1 html
-rm -rf _build/html/_sources
+%{__make} -C doc html
 %endif
 
 %install
@@ -76,7 +108,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc {AUTHORS,NEWS,README,TODO}.txt
+%doc AUTHORS.txt COPYING.txt NEWS.txt README.md TODO.txt
 %{py_sitescriptdir}/bs4
 %{py_sitescriptdir}/beautifulsoup4-%{version}-py*.egg-info
 %endif
@@ -84,7 +116,13 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc {AUTHORS,NEWS,README,TODO}.txt
+%doc AUTHORS.txt COPYING.txt NEWS.txt README.md TODO.txt
 %{py3_sitescriptdir}/bs4
 %{py3_sitescriptdir}/beautifulsoup4-%{version}-py*.egg-info
 %endif
+
+%if %{with doc}
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/build/html/{_images,_static,*.html,*.js}
+%endif
This page took 0.358087 seconds and 4 git commands to generate.