]> git.pld-linux.org Git - packages/python-SOAP.git/blobdiff - python-SOAP.spec
- updated to 0.11.4
[packages/python-SOAP.git] / python-SOAP.spec
index 1e1748c78a92797a7212bd3820180c14d94066c5..3a8d2df5ad2c5aa8fe8d1816c86a664ebff2bda6 100644 (file)
@@ -1,46 +1,51 @@
+%include       /usr/lib/rpm/macros.python
 Summary:       A SOAP library for Python
+Summary(pl):   Biblioteka SOAP dla Pythona
 Name:          python-SOAP
-Version:       0.9.7
+Version:       0.11.4
 Release:       1
-License:       Python License
-Source0:       http://prdownloads.sourceforge.net/pywebsvcs/SOAPpy097.tgz
+License:       Python
+Group:         Libraries/Python
+Source0:       http://dl.sourceforge.net/pywebsvcs/SOAPpy-%{version}.tar.gz
+# Source0-md5: 69a384d9a61b36325a97d81165668b39
 URL:           http://sourceforge.net/projects/pywebsvcs/
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(pl):     Programowanie/Jêzyki/Python
-Requires:      python >= 2.1
-BuildRequires: python-devel >= 2.1
+%pyrequires_eq python
+BuildRequires: python-devel >= 2.3
+BuildRequires: rpm-pythonprov
+BuildRequires: python-fpconst
+BuildRequires: python-PyXML
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
-%define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
-%define python_libdir      %{python_prefix}/lib/python%{python_version}
-%define python_sitedir     %{python_libdir}/site-packages
-
 %description
-Web services for Python programmers, both client and servers. 
-This includes SOAP, WSDL, UDDI, etc.
+Web services for Python programmers, both client and servers. This
+includes SOAP, WSDL, UDDI, etc.
+
+%description -l pl
+Serwisy WWW dla programistów Pythona, zarówno klient i serwery. W tym
+SOAP, WSDL, UDDI itp.
 
 %prep
-%setup -q -n SOAPpy097
+%setup -q -n SOAPpy-%{version}
 
 %build
-python -c 'import py_compile; py_compile.compile("SOAP.py");'
-python -O -c 'import py_compile; py_compile.compile("SOAP.py");'
+python setup.py build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{python_sitedir}
-
-install SOAP.py? $RPM_BUILD_ROOT%{python_sitedir}
+install -d $RPM_BUILD_ROOT%{py_sitedir}
 
-gzip -9nf README CHANGELOG docs/*.txt 
+python setup.py install \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz docs/*.gz validate tests tools contrib bid *.py
-%{python_sitedir}/*.py?
+%doc README docs/*.txt validate tests tools contrib bid
+%dir %{py_sitescriptdir}/SOAPpy
+%{py_sitescriptdir}/SOAPpy/*.py?
+%dir %{py_sitescriptdir}/SOAPpy/wstools
+%{py_sitescriptdir}/SOAPpy/wstools/*.py?
This page took 0.053391 seconds and 4 git commands to generate.