]> git.pld-linux.org Git - packages/pure-ftpd.git/blobdiff - pure-ftpd.spec
- when SSLCertFile is absent in pureftpd.conf use path to certificate
[packages/pure-ftpd.git] / pure-ftpd.spec
index af57502a0bca1568319d5086d2ba3ef087d22fbe..9df0b2be4f9de7dcefaf1764a9f4d541cae190e4 100644 (file)
@@ -1,40 +1,46 @@
 #
 # Conditional build:
-# _without_mysql - disable MySQL auth but disables PAM auth
-# _without_ldap  - disable LDAP auth
-# _without_pgsql - disable PostgreSQL support
-# _without_tls   - support SSL/TLS
+%bcond_without  ldap   # disable LDAP auth
+%bcond_without  mysql  # disable MySQL auth but disables PAM auth
+%bcond_without  pgsql  # disable PostgreSQL support
+%bcond_without puredb  # disable pure-db support
+%bcond_without  tls    # support SSL/TLS
 #
 Summary:       Small, fast and secure FTP server
 Summary(pl):   Ma³y, szybki i bezpieczny serwer FTP
 Name:          pure-ftpd
-Version:       1.0.17a
+Version:       1.0.20
 Release:       1
 Epoch:         0
 License:       BSD-like
 Group:         Daemons
 Source0:       ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: cb994e16d163252c0fcbbc63491456f8
+# Source0-md5: e928e9e15adf6b52bfe6183fdad20144
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       ftpusers.tar.bz2
 # Source3-md5: 76c80b6ec9f4d079a1e27316edddbe16
+Patch0:                %{name}-config.patch
+# This patch is broken and changes default pureftpd behaviour
+Patch1:                %{name}-path_to_ssl_cert_in_config.patch
+Patch2:                %{name}-pure-pw_passwd.patch
 URL:           http://www.pureftpd.org/
 BuildRequires: libcap-devel
-%{!?_without_mysql:BuildRequires:      mysql-devel}
-%{!?_without_ldap:BuildRequires:       openldap-devel}
-%{!?_without_tls:BuildRequires:                openssl-devel}
-%{!?_without_pgsql:BuildRequires:      postgresql-devel}
+%{?with_ldap:BuildRequires:    openldap-devel}
+%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+%{?with_tls:BuildRequires:     openssl-devel}
 BuildRequires: pam-devel
 Prereq:                rc-scripts
 Requires(post,preun):/sbin/chkconfig
 Requires:      pam >= 0.77.3
+Requires:      perl-base
 Provides:      ftpserver
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     ftpserver
 Obsoletes:     anonftp
 Obsoletes:     bftpd
 Obsoletes:     ftpd-BSD
+Obsoletes:     glftpd
 Obsoletes:     heimdal-ftpd
 Obsoletes:     linux-ftpd
 Obsoletes:     muddleftpd
@@ -46,8 +52,10 @@ Obsoletes:   troll-ftpd
 Obsoletes:     vsftpd
 Obsoletes:     wu-ftpd
 Conflicts:     man-pages < 1.51
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/ftpd
+%define                _ftpdir         /home/services/ftp
 
 %description
 Pure-FTPd is a fast, production-quality, standard-comformant FTP
@@ -70,37 +78,40 @@ po
 
 %prep
 %setup -q
+%patch0 -p0
+# broken
+#%patch1 -p1
+%patch2 -p1
 
 %build
 %configure \
+       --with-boring \
        --with-altlog \
-       --with-puredb \
-       --with-extauth \
-       --with-pam \
        --with-cookie \
-       --with-throttling \
-       --with-ratios \
-       --with-quotas \
+       --with-diraliases \
+       --with-extauth \
        --with-ftpwho \
+       --with-language=english \
        --with-largefile \
+       %{?with_ldap:--with-ldap} \
+       %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
+       --with-pam \
+       --with-peruserlimits \
+       %{?with_pgsql:--with-pgsql} \
+       --with-privsep \
+       %{?with_puredb:--with-puredb} \
+       --with-quotas \
+       --with-ratios \
+       --with-throttling \
+       %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
        --with-uploadscript \
-       --with-virtualhosts \
        --with-virtualchroot \
-       --with-diraliases \
-       --with-peruserlimits \
-       %{!?_without_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
-       %{!?_without_pgsql:--with-pgsql} \
-       %{!?_without_ldap:--with-ldap} \
-       %{!?_without_tls: --with-tls} \
-       --with-language=english \
-       --with-privsep
-
-echo '#define  TLS_CERTIFICATE_PATH    "%{_sysconfdir}/ssl/pure-ftpd.pem"' >> config.h
-
+       --with-virtualhosts 
+        
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
-       $RPM_BUILD_ROOT{%{_sysconfdir}/{vhosts,ssl},/home/services/ftp/Incoming}
+       $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir}/Incoming}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -108,9 +119,9 @@ install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
-%{!?_without_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
-%{!?_without_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
-%{!?_without_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
+%{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
+%{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
+%{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
 install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}
 touch $RPM_BUILD_ROOT/etc/security/blacklist.ftp
@@ -140,22 +151,21 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README* AUTHORS ChangeLog HISTORY NEWS THANKS pure*.conf
+%doc AUTHORS ChangeLog CONTACT FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/*
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.ftp
-%{!?_without_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
-%{!?_without_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
-%{!?_without_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
+%{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
+%{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
+%{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
 %attr(710,root,ftp) %dir %{_sysconfdir}
 %dir %{_sysconfdir}/vhosts
 %dir %{_sysconfdir}/pure-ftpd
-%{!?_without_tls:%attr(750,root,root) %dir %{_sysconfdir}/ssl}
-%dir /home/services/ftp
-%attr(775,root,ftp) %dir /home/services/ftp/Incoming
+%dir %{_ftpdir}
+%attr(775,root,ftp) %dir %{_ftpdir}/Incoming
 %{_mandir}/man?/*
 %lang(ja) %{_mandir}/ja/man5/ftpusers*
 %lang(pl) %{_mandir}/pl/man5/ftpusers*
This page took 0.075897 seconds and 4 git commands to generate.