]> git.pld-linux.org Git - packages/postgresql.git/blobdiff - postgresql.spec
- new patches for postgresql
[packages/postgresql.git] / postgresql.spec
index fac3747215f5bb90f59b9dd1f62246182b5a7fc5..2abf8b9c0a4c3bd04873e1265e694968d2056a16 100644 (file)
@@ -276,7 +276,7 @@ Pakiet ten zawiera biblioteki i pliki nag
 cd src
 
 CFLAGS="$RPM_OPT_FLAGS" \
-./configure %{_target} \
+./configure %{_target_platform} \
        --prefix=/usr \
        --enable-hba \
        --enable-locale \
@@ -332,8 +332,8 @@ find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -print | \
 find $RPM_BUILD_ROOT%{_libdir}/perl5 -type d -name Pg -print | \
        sed -e "s|$RPM_BUILD_ROOT/|%dir /|g" >> perlfiles.list
 
-# Move all includes beneath /usr/include/pgsql.
-( cd $RPM_BUILD_ROOT/usr/include
+# Move all includes beneath %{_includedir}/pgsql.
+( cd $RPM_BUILD_ROOT%{_includedir}
   rm -rf include
   for f in *.h access commands executor lib libpq libpq++ port utils
   do
@@ -358,7 +358,7 @@ install -d howto
 )
 
 # Strip 'em all
-strip -s $RPM_BUILD_ROOT/usr/bin/* || :
+strip -s $RPM_BUILD_ROOT%{_bindir}/* || :
 
 # gzip all man pages
 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/*
@@ -386,7 +386,7 @@ fi
 %post data
 # Create sample database
 su postgres -c "LD_LIBRARY_PATH=%{_libdir} \
-    /usr/bin/initdb --pgdata=/var/lib/pgsql \
+    %{_bindir}/initdb --pgdata=/var/lib/pgsql \
     --pglib=%{_libdir}/pgsql"
 
 %post   -p /sbin/ldconfig clients
@@ -419,26 +419,26 @@ rm -f /tmp/tmp_perl_info
 %doc howto
 
 %files
-%defattr(644, root, root, 755)
+%defattr(644,root,root,755)
 %doc contrib 
 %doc doc/FAQ doc/FAQ_Linux doc/README* 
 %doc COPYRIGHT README HISTORY doc/bug.template
 %doc doc/*.ps.gz
 
-%attr(754, root, root) /etc/rc.d/init.d/*
-
-%attr(644, postgres, postgres, 755) %{_libdir}/pgsql
-%attr(755,root,root) /usr/bin/cleardbdir
-%attr(755,root,root) /usr/bin/createdb
-%attr(755,root,root) /usr/bin/createuser
-%attr(755,root,root) /usr/bin/destroydb
-%attr(755,root,root) /usr/bin/destroyuser
-%attr(755,root,root) /usr/bin/initdb
-%attr(755,root,root) /usr/bin/initlocation
-%attr(755,root,root) /usr/bin/pg_passwd
-%attr(755,root,root) /usr/bin/pg_version
-%attr(755,root,root) /usr/bin/postgres
-%attr(755,root,root) /usr/bin/postmaster
+%attr(754,root,root) /etc/rc.d/init.d/*
+
+%attr(644, postgres, postgres,755) %{_libdir}/pgsql
+%attr(755,root,root) %{_bindir}/cleardbdir
+%attr(755,root,root) %{_bindir}/createdb
+%attr(755,root,root) %{_bindir}/createuser
+%attr(755,root,root) %{_bindir}/destroydb
+%attr(755,root,root) %{_bindir}/destroyuser
+%attr(755,root,root) %{_bindir}/initdb
+%attr(755,root,root) %{_bindir}/initlocation
+%attr(755,root,root) %{_bindir}/pg_passwd
+%attr(755,root,root) %{_bindir}/pg_version
+%attr(755,root,root) %{_bindir}/postgres
+%attr(755,root,root) %{_bindir}/postmaster
 %{_mandir}/man1/cleardbdir.1.gz
 %{_mandir}/man1/createdb.1.gz
 %{_mandir}/man1/createuser.1.gz
@@ -457,9 +457,9 @@ rm -f /tmp/tmp_perl_info
 %{_libdir}/libpq*.a
 %attr(755,root,root) %{_libdir}/libec*.so
 %attr(755,root,root) %{_libdir}/libpq*.so
-/usr/include/pgsql
+%{_includedir}/pgsql
 %{_mandir}/man3/*.gz
-%attr(755,root,root) /usr/bin/ecpg
+%attr(755,root,root) %{_bindir}/ecpg
 %{_mandir}/man1/ecpg.1.gz
 
 %files data
@@ -467,14 +467,14 @@ rm -f /tmp/tmp_perl_info
 %attr(-,postgres,postgres) /var/lib/pgsql
 
 %files clients
-%defattr(644, root, root, 755)
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libec*.so.*
 %attr(755,root,root) %{_libdir}/libpq*.so.*
-%attr(755,root,root) /usr/bin/pg_dump
-%attr(755,root,root) /usr/bin/pg_dumpall
-%attr(755,root,root) /usr/bin/pg_id
-%attr(755,root,root) /usr/bin/pg_upgrade
-%attr(755,root,root) /usr/bin/psql
+%attr(755,root,root) %{_bindir}/pg_dump
+%attr(755,root,root) %{_bindir}/pg_dumpall
+%attr(755,root,root) %{_bindir}/pg_id
+%attr(755,root,root) %{_bindir}/pg_upgrade
+%attr(755,root,root) %{_bindir}/psql
 %{_mandir}/man1/pg_dump.1.gz
 %{_mandir}/man1/pg_dumpall.1.gz
 %{_mandir}/man1/pg_upgrade.1.gz
@@ -482,14 +482,14 @@ rm -f /tmp/tmp_perl_info
 %{_mandir}/manl/*.gz
 
 %files -f perlfiles.list perl
-%defattr(-, root, root)
+%defattr(-,root,root)
 
 %files odbc
-%defattr(644, root, root, 755)
+%defattr(644,root,root,755)
 %doc src/interfaces/odbc/readme.txt src/interfaces/odbc/notice.txt
 %config(noreplace) %verify(not size mtime md5) /etc/odbc*
 %{_libdir}/libpsqlodbc*
-/usr/include/iodbc
+%{_includedir}/iodbc
 
 %changelog
 * Wed Mar 24 1999 Jacek Smyda <smyda@posexperts.com.pl>
@@ -528,13 +528,13 @@ rm -f /tmp/tmp_perl_info
 - /var/lib/pgsql/pg_pwd should not be 666
 
 * Sun Jun 21 1998 Jeff Johnson <jbj@redhat.com>
-- create %{_libdir}/pgsql (like /usr/include/pgsql)
+- create %{_libdir}/pgsql (like %{_includedir}/pgsql)
 - resurrect libpq++.so*
 - fix name problem in startup-script (problem #533)
 
 * Fri Jun 19 1998 Jeff Johnson <jbj@redhat.com>
 - configure had "--prefix=$RPM_BUILD_ROOT/usr"
-- move all include files below /usr/include/pgsql.
+- move all include files below %{_includedir}/pgsql.
 - resurrect perl client file lists.
 
 * Tue May 05 1998 Prospector System <bugs@redhat.com>
This page took 0.037593 seconds and 4 git commands to generate.