]> git.pld-linux.org Git - packages/postfix.git/blobdiff - postfix.spec
- up to 3.6.8
[packages/postfix.git] / postfix.spec
index 2129e780719388e34a014cf4a77877658bafec0b..f7466627b37bea6855020864891514564a979d08 100644 (file)
@@ -1,24 +1,24 @@
 #
 # Conditional build:
-%bcond_without ldap    # without LDAP map module
-%bcond_without mysql   # without MySQL map module
-%bcond_without pgsql   # without PostgreSQL map module
-%bcond_without sqlite  # without SQLite map module
-%bcond_without sasl    # without SMTP AUTH support
-%bcond_without ssl     # without SSL/TLS support
-%bcond_without cdb     # without cdb map support
-%bcond_without lmdb    # without lmdb map support
-%bcond_with    vda     # with VDA patch
-%bcond_with    hir     # with Beeth's header_if_reject patch
-%bcond_with    tcp     # with unofficial tcp: lookup table
+%bcond_without ldap    # LDAP map module
+%bcond_without mysql   # MySQL map module
+%bcond_without pgsql   # PostgreSQL map module
+%bcond_without sqlite  # SQLite map module
+%bcond_without sasl    # SMTP AUTH support
+%bcond_without ssl     # SSL/TLS support
+%bcond_without cdb     # cdb map support
+%bcond_without lmdb    # lmdb map support
+%bcond_with    vda     # VDA patch
+%bcond_with    hir     # Beeth's header_if_reject patch
+%bcond_with    tcp     # unofficial tcp: lookup table
 %if "%{pld_release}" == "ac"
-%bcond_with            epoll   # enable epoll for 2.6 kernels
+%bcond_with    epoll   # epoll support for 2.6 kernels
 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
 %ifarch %{x8664}
 %define                with_epoll      1
 %endif
 %else
-%bcond_without epoll   # disable epoll for 2.4 kernels
+%bcond_without epoll   # epoll support (Linux >= 2.6)
 %endif
 
 %define                vda_ver v13-2.10.0
@@ -30,13 +30,13 @@ Summary(pl.UTF-8):  Serwer SMTP Postfix
 Summary(pt_BR.UTF-8):  Postfix - Um MTA (Mail Transport Agent) de alto desempenho
 Summary(sk.UTF-8):     Agent prenosu pošty Postfix
 Name:          postfix
-Version:       3.3.1
+Version:       3.6.8
 Release:       1
 Epoch:         2
-License:       distributable
+License:       IBM Public License or Eclipse Public License v2.0
 Group:         Networking/Daemons/SMTP
 Source0:       ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
-# Source0-md5: 4381c6492f415e4a69cf5099d4acea76
+# Source0-md5: d39b4666910ea4e4aeadd09bb1e1d2c4
 Source1:       %{name}.aliases
 Source2:       %{name}.cron
 Source3:       %{name}.init
@@ -65,13 +65,16 @@ Patch8:             %{name}-dictname.patch
 
 Patch11:       %{name}-scache_clnt.patch
 Patch12:       format-security.patch
-Patch13:       %{name}-no_cdb.patch
+Patch13:       glibc-2.34.patch
 URL:           http://www.postfix.org/
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel}
 BuildRequires: db-devel
 # getifaddrs() with IPv6 support
 BuildRequires: glibc-devel >= 6:2.3.4
-%{?with_lmbd:BuildRequires:    lmdb-devel}
+BuildRequires: libicu-devel
+BuildRequires: libnsl-devel
+BuildRequires: m4
+%{?with_lmdb:BuildRequires:    lmdb-devel}
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.0.12}
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7l}
@@ -245,6 +248,18 @@ This package provides support for LMDB maps in Postfix.
 %description dict-lmdb -l pl.UTF-8
 Ten pakiet dodaje obsługę map LMDB do Postfiksa.
 
+%package dict-cdb
+Summary:       CDB map support for Postfix
+Summary(pl.UTF-8):     Obsługa map CDB dla Postfiksa
+Group:         Networking/Daemons/SMTP
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description dict-cdb
+This package provides support for CDB maps in Postfix.
+
+%description dict-cdb -l pl.UTF-8
+Ten pakiet dodaje obsługę map CDB do Postfiksa.
+
 %package qshape
 Summary:       qshape - Print Postfix queue domain and age distribution
 Summary(pl.UTF-8):     qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
@@ -286,14 +301,14 @@ cat %{SOURCE7} | %{__patch} -p1 -s
 cat %{SOURCE11} | %{__patch} -p1 -s
 %endif
 
-find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
+find -type f | xargs %{__sed} -i -e 's|/etc/postfix|/etc/mail|g'
 
 %patch0 -p1
 
 %patch3 -p1
 %{?with_hir:%patch4 -p0}
 
-sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
+%{__sed} -i -e '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
 %patch7 -p1
 %patch8 -p1
 
@@ -301,18 +316,30 @@ sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt
 %if %{with vda}
 %patch12 -p1
 %endif
-%{!?with_cdb:%patch13 -p1}
+%patch13 -p1
 
 %if %{with tcp}
 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
 %endif
 
+%{__sed} -i -e 's,/lib64\>,/%{_lib},' makedefs
+
 %build
+# export, as the same variables must be passed both to 'make makefiles' and 'make'
 export CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB} %{?with_sqlite:-DHAS_SQLITE} %{?with_lmdb:-DHAS_LMDB} -LHAS_SDBM"
-export AUXLIBS="-ldb -lresolv %{?with_mysql:-lmysqlclient} %{?with_pgsql:-lpq} %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre %{?with_ldap:-lldap -llber}"
+export AUXLIBS="%{rpmldflags} -lsasl -lssl -lcrypto"
+export AUXLIBS_CDB="%{?with_cdb:-lcdb}"
+export AUXLIBS_LDAP="%{?with_ldap:-lldap -llber}"
+export AUXLIBS_LMDB="%{?with_lmdb:-llmdb}"
+export AUXLIBS_MYSQL="%{?with_mysql:-lmysqlclient}"
+export AUXLIBS_PCRE="-lpcre"
+export AUXLIBS_PGSQL="%{?with_pgsql:-lpq}"
+export AUXLIBS_SQLITE="%{?with_sqlite:-lsqlite3}"
+
 export CC="%{__cc}"
 %{__make} makefiles \
-       shared=yes dynamicmaps=yes \
+       shared=yes \
+       dynamicmaps=yes \
        daemon_directory="%{_libdir}/postfix" \
        shlib_directory="%{_libdir}/postfix" \
        manpage_directory="%{_mandir}"
@@ -484,9 +511,9 @@ fi
 %attr(755,root,root) %{_libdir}/postfix/oqmgr
 %attr(755,root,root) %{_libdir}/postfix/pickup
 %attr(755,root,root) %{_libdir}/postfix/pipe
-%attr(755,root,root) %{_libdir}/postfix/postfix-cdb.so
 %attr(755,root,root) %{_libdir}/postfix/postfix-script
 %attr(755,root,root) %{_libdir}/postfix/postfix-tls-script
+%attr(755,root,root) %{_libdir}/postfix/postlogd
 %attr(755,root,root) %{_libdir}/postfix/postfix-wrapper
 %attr(755,root,root) %{_libdir}/postfix/post-install
 %attr(755,root,root) %{_libdir}/postfix/postmulti-script
@@ -512,7 +539,7 @@ fi
 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
-%attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
+%attr(755,root,root) %dir %{_var}/spool/postfix/pid
 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
@@ -589,6 +616,11 @@ fi
 %{_mandir}/man5/lmdb_table.5*
 %endif
 
+%if %{with cdb}
+%files dict-cdb
+%attr(755,root,root) %{_libdir}/postfix/postfix-cdb.so
+%endif
+
 %files qshape
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qshape
This page took 0.062031 seconds and 4 git commands to generate.