]> git.pld-linux.org Git - packages/postfix.git/blobdiff - postfix.spec
- removes some compiler warnings during postfix compilation which may cause fatal...
[packages/postfix.git] / postfix.spec
index cef5863873af7b926fa4e379d0021938310cf847..6ac4ebccc54af01f6da1a341476fbcefad79f2db 100644 (file)
@@ -1,54 +1,84 @@
 #
-# Conditional build:   
-# --without sasl - build wihtout SMTP AUTH support
-# --without ldap - build without LDAP support
-# --without pcre - build without Perl Compatible Regular Expresion support
-# --without ssl  - build without SSL/TLS support
-# --with mysql - build with MySQL support
-# --without ipv6  - build without IPv6 support
+# TODO:
+#      - kill all "implicit declaration of function" and "assignment
+#        makes pointer from integer without a cast" warnings
+#        (code causing such warnings may be fatal on some
+#        architectures)
+#      - fix ipv6 patch against IPv4 RBLs
+#      - 0.0.0.0/0 is still being added to mynetworks if any ipv6/ip
+#        tunnels are present
+#       - fix patches
 #
-%define        tls_ver 0.7.13c-snap20011127-0.9.6b
+# Conditional build:
+%bcond_without ipv6    # without IPv6 support
+%bcond_without ldap    # without LDAP map module
+%bcond_without mysql   # without MySQL map module
+%bcond_without pgsql   # without PostgreSQL map module
+%bcond_without sasl    # without SMTP AUTH support
+%bcond_without ssl     # without SSL/TLS support
+%bcond_with    polish  # with double English+Polish messages
+%bcond_with    cdb     # with cdb map support
+#
+%define        tls_ver 0.8.16-2.0.16-0.9.7b
 Summary:       Postfix Mail Transport Agent
+Summary(cs):   Postfix - program pro pøepravu po¹ty (MTA)
+Summary(es):   Postfix - Un MTA (Mail Transport Agent) de alto desempeño
+Summary(fr):   Agent de transport de courrier Postfix
 Summary(pl):   Serwer SMTP Postfix
+Summary(pt_BR):        Postfix - Um MTA (Mail Transport Agent) de alto desempenho
+Summary(sk):   Agent prenosu po¹ty Postfix
 Name:          postfix
-Version:       20011127
-Release:       1
+Version:       2.0.16
+Release:       3
+Epoch:         2
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
 License:       distributable
-Source0:       ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/snapshot-%{version}.tar.gz
+Source0:       ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
+# Source0-md5: ac13776442ba7708e683bc1bfbadab2f
 Source1:       %{name}.aliases
 Source2:       %{name}.cron
 Source3:       %{name}.init
 Source5:       %{name}.sysconfig
 Source6:       ftp://ftp.aet.tu-cottbus.de/pub/pfixtls/pfixtls-%{tls_ver}.tar.gz
+# Source6-md5: b39c08eabe807db4af5bcb1cafc9761e
 Source7:       %{name}.sasl
+Source8:       ftp://ftp.corpit.ru/pub/postfix/%{name}-dict_cdb-1.1.11-20021104.tar.gz
+# Source8-md5: 5731b5081725f4688dc6fae119d617e4
 Patch0:                %{name}-config.patch
-Patch1:                %{name}-pl.patch
-Patch2:                %{name}-conf_msg.patch
-Patch3:                %{name}-ipv6.patch
+Patch1:                %{name}-conf_msg.patch
+Patch2:                %{name}-dynamicmaps.patch
+Patch3:                %{name}-pgsql.patch
+Patch4:                %{name}-master.cf_cyrus.patch
+Patch5:                %{name}-ipv6.patch
+Patch6:                %{name}-pl.patch
+Patch7:                %{name}-cdb_man.patch
+Patch8:         %{name}-ns-mx-acl.patch
+Patch9:         %{name}-kill_warnings.patch
 URL:           http://www.postfix.org/
-Provides:      smtpdaemon
-Prereq:                rc-scripts
-%{!?_without_ldap:BuildRequires:       openldap-devel >= 2.0.0}
-%{!?_without_ssl:BuildRequires:        openssl-devel >= 0.9.6a}
-%{!?_without_pcre:BuildRequires:       pcre-devel}
-%{!?_without_sasl:BuildRequires:       cyrus-sasl-devel}
-%{!?_without_ipv6:BuildRequires:       libinet6 >= 0.20010420-3}
-BuildRequires: db3-devel
-BuildRequires: grep
 BuildRequires: awk
-Prereq:                /sbin/chkconfig
-Prereq:                /usr/sbin/useradd
-Prereq:                /usr/sbin/groupadd
-Prereq:                /usr/sbin/userdel
-Prereq:                /usr/sbin/groupdel
-Prereq:                /usr/bin/getgid
-Prereq:                /bin/id
-Prereq:                /bin/hostname
-%{!?_without_ldap:Prereq:      openldap >= 2.0.0}
+%{?with_sasl:BuildRequires:    cyrus-sasl-devel}
+BuildRequires: db-devel
+BuildRequires: grep
+%{?with_ipv6:BuildRequires:    libinet6 >= 0.20030228-1}
+%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_ldap:BuildRequires:    openldap-devel >= 2.0.0}
+%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7c}
+BuildRequires: pcre-devel
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+%{?with_cdb:BuildRequires:     tinycdb-devel}
+PreReq:                rc-scripts
+PreReq:                sed
+Requires(pre): /usr/sbin/useradd
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/bin/getgid
+Requires(pre): /bin/id
+Requires(post):        /bin/hostname
+Requires(post,postun): /sbin/ldconfig
+Requires(post,preun):  /sbin/chkconfig
+Requires(postun):      /usr/sbin/userdel
+Requires(postun):      /usr/sbin/groupdel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Provides:      smtpdaemon
 Obsoletes:     smtpdaemon
 Obsoletes:     exim
 Obsoletes:     masqmail
@@ -59,51 +89,179 @@ Obsoletes: sendmail-cf
 Obsoletes:     sendmail-doc
 Obsoletes:     smail
 Obsoletes:     zmailer
-Requires:      procmail
+Requires:      diffutils
+Requires:      findutils
+%{?with_cdb:Requires:tinycdb}
 
 %description
 Postfix is attempt to provide an alternative to the widely-used
 Sendmail program. Postfix attempts to be fast, easy to administer, and
 hopefully secure, while at the same time being sendmail compatible
-enough to not upset your users. This version have IPv6 support and
-%{!?_without_ldap:no }LDAP support.
+enough to not upset your users. %{?with_ipv6:This version has IPv6 support.}
+
+%description -l pt_BR
+O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
+você deseja um servidor SMTP *rápido*, instale este pacote.
+
+%description -l es
+Postfix es una alternativa para el mundialmente utilizado sendmail. Si
+desea tener un servidor SMTP *rápido*, debe instalar este paquete.
+
+%description -l fr
+Postfix (voir http://www.postfix.org/) se veut une alternative à
+sendmail, responsable de l'acheminement de 70% des courriers
+électroniques sur Internet. IBM en a suppotré le développement, mais
+ne contrôle pas son évolution. Le but est d'installer Postfix sur le
+plus grand nombre de systèmes possible. Dans cette optique, il a été
+écrit pour être totalement sous le contrôle de l'utilisateur.
+
+%description -l it
+Postfix (http://www.postfix.org/) e' un'alternativa al programma
+sendmail utilizzato per la gestione del 70 per cento della posta
+Internet.
+
+Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
+evoluzione.
+
+Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
+quale troverete le indicazioni per una corretta installazione e
+configurazione di questo programma.
 
 %description -l pl
 Postfix jest prób± dostarczenia alternatywnego MTA w stosunku do
 szeroko u¿ywanego sendmaila. Postfix w zamierzeniu ma byæ szybki,
 ³atwy w administrowaniu, bezpieczny oraz ma byæ na tyle kompatybilny z
-sendmailem by nie denerwowaæ Twoich u¿ytkowników. Ta wersja wspiera
-IPv6%{!?_without_ldap: oraz LDAP}.
+sendmailem by nie denerwowaæ Twoich u¿ytkowników. %{?with_ipv6:Ta wersja wspiera IPv6.}
+
+%description -l pt_BR
+O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
+você deseja um servidor SMTP *rápido*, instale este pacote.
+
+%description -l sk
+Postfix (pozri http://www.postfix.org/) má za cieµ by» alternatívou k
+¹iroko roz¹írenému programu sendmail, zodpovednému za 70% v¹etkej
+elektronickej po¹ty doruèenej na Internete.
+
+Aj keï IBM podporovala vývoj Postfixu, zdr¾iava sa vplyvu na jeho
+vývoj. Cieµom je in¹talácia Postfixu na èo najväè¹om poète systémov.
+Do tohoto momentu je softvér poskytovaný bez ovplyvòovania, tak¾e sa
+mô¾e vyvíja» podµa jeho pou¾ívateµov.
+
+Urèite si preèítajte http://www.moongroup.com/how-to.phtml, kde sú
+popísané kroky potrebné pred a po in¹talácii Postfixu.
+
+%package devel
+Summary:       Postfix loadable modules development package
+Summary(pl):   Pakiet dla programistów ³adowanych modu³ów do postfiksa
+Group:         Development/Libraries
+Requires:      %{name} = %{epoch}:%{version}
+
+%description devel
+Header files to build additional map types for Postfix.
+
+%description devel -l pl
+Pliki nag³ówkowe do tworzenia dodatkowych typów map dla Postfiksa.
+
+%package dict-ldap
+Summary:       LDAP map support for Postfix
+Summary(pl):   Obs³uga map LDAP dla Postfiksa
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}
+Requires:      openldap >= 2.0.0
+
+%description dict-ldap
+This package provides support for LDAP maps in Postfix.
+
+%description dict-ldap -l pl
+Ten pakiet dodaje obs³ugê map LDAP do Postfiksa.
+
+%package dict-mysql
+Summary:       MySQL map support for Postfix
+Summary(pl):   Obs³uga map MySQL dla Postfiksa
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}
+
+%description dict-mysql
+This package provides support for MySQL maps in Postfix.
+
+%description dict-mysql -l pl
+Ten pakiet dodaje obs³ugê map MySQL do Postfiksa.
+
+%package dict-pcre
+Summary:       PCRE map support for Postfix
+Summary(pl):   Obs³uga map PCRE dla Postfiksa
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}
+
+%description dict-pcre
+This package provides support for PCRE maps in Postfix.
+
+%description dict-pcre -l pl
+Ten pakiet dodaje obs³ugê map PCRE do Postfiksa.
+
+%package dict-pgsql
+Summary:       PostgreSQL map support for Postfix
+Summary(pl):   Obs³uga map PostgreSQL dla Postfiksa
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}
+
+%description dict-pgsql
+This package provides support for PostgreSQL maps in Postfix.
+
+%description dict-pgsql -l pl
+Ten pakiet dodaje obs³ugê map PostgreSQL do Postfiksa.
 
 %prep
-%setup -q -n snapshot-%{version} -a 6 
+%setup -q -a6 %{?with_cdb:-a8}
+echo Postfix TLS patch:
+patch -p1 -s <pfixtls-%{tls_ver}/pfixtls.diff
 %patch0 -p1
 %patch1 -p1
-patch -p1 -s <pfixtls-%{tls_ver}/pfixtls.diff 
 %patch2 -p1
-%{!?_without_ipv6:%patch3 -p1 }
+%patch3 -p1
+%patch4 -p1
+%{?with_ipv6:%patch5 -p1}
+%{?with_polish:%patch6 -p1}
+%{?with_cdb:%patch7 -p1}
+%patch8 -p1
+%patch9 -p1
+%{?with_cdb:sh dict_cdb.sh}
 
 %build
 %{__make} -f Makefile.init makefiles
 %{__make} tidy
 %{__make} DEBUG="" OPT="%{rpmcflags}" \
-       CCARGS="%{!?_without_ldap:-DHAS_LDAP} %{!?_without_pcre:-DHAS_PCRE} %{!?_without_sasl:-DUSE_SASL_AUTH} %{?_with_mysql:-DHAS_MYSQL -I%{_includedir}/mysql} %{!?_without_ssl:-DHAS_SSL -I%{_includedir}/openssl}" \
-       AUXLIBS="%{!?_without_ldap:-llber -lldap} -lnsl -ldb -lresolv %{!?_without_pcre:-lpcre} %{!?_without_sasl:-lsasl} %{?_with_mysql:-lmysqlclient} %{!?_without_ssl:-lssl -lcrypto}"
+       %{!?with_ldap:LDAPSO=""} \
+       %{!?with_mysql:MYSQLSO=""} \
+       %{!?with_pgsql:PGSQLSO=""} \
+       CCARGS="%{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL -I/usr/include/postgresql} %{?with_ssl:-DHAS_SSL -I/usr/include/openssl} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
+       AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/{mail,cron.daily,rc.d/init.d,sasl,sysconfig} \
-          $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,%{_mandir}/man{1,5,8}} \
-          $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
-          pfixtls
+install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
+       $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
+       $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}/man{1,5,8}} \
+       $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
+       pfixtls
 
 rm -f {html,man}/Makefile.in conf/{LICENSE,main.cf.default}
 
-install -d sample-conf; mv -f conf/sample* sample-conf/ || :
+install -d sample-conf; mv -f conf/sample* sample-conf || :
 
 install bin/* $RPM_BUILD_ROOT%{_sbindir}
 install libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
+sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
+       conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
+
+for f in dns global master util ; do
+       install lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
+       ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
+done
+install lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
+install include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
 
 (cd man; tar cf - .) | (cd $RPM_BUILD_ROOT%{_mandir}; tar xf -)
 
@@ -111,25 +269,17 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/postfix
-install %{SOURCE7} $RPM_BUILD_ROOT/etc/sasl/smtpd.conf
+install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
 install auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
 
-ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
-ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
-ln -sf ../sbin/sendmail $RPM_BUILD_ROOT%{_libdir}/sendmail
-
-mv -f  $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script-sgid \
-       $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script
-
-rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mail/postfix-script-{diff,nosgid}
+ln -sf /usr/sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
+ln -sf /usr/sbin/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
+ln -sf /usr/sbin/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
 
 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
        {aliases,access,canonical,relocated,transport,virtual}{,.db}
 
-gzip -9nf *README HISTORY COMPATIBILITY LICENSE RELEASE_NOTES \
-          RESTRICTION_CLASS TODO
-
-touch $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
+> $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -137,7 +287,7 @@ rm -rf $RPM_BUILD_ROOT
 %pre
 if [ -n "`/usr/bin/getgid postfix`" ]; then
        if [ "`getgid postfix`" != "62" ]; then
-               echo "Warning: group postfix haven't gid=62. Correct this before installing postfix" 1>&2
+               echo "Error: group postfix doesn't have gid=62. Correct this before installing postfix." 1>&2
                exit 1
        fi
 else
@@ -145,7 +295,7 @@ else
 fi
 if [ -n "`/usr/bin/getgid maildrop`" ]; then
        if [ "`/usr/bin/getgid maildrop`" != "63" ]; then
-               echo "Warning: group maildrop haven't gid=63. Correct this before installing postfix" 1>&2
+               echo "Error: group maildrop doesn't have gid=63. Correct this before installing postfix." 1>&2
                exit 1
        fi
 else
@@ -153,7 +303,7 @@ else
 fi
 if [ -n "`/bin/id -u postfix 2>/dev/null`" ]; then
        if [ "`/bin/id -u postfix`" != "62" ]; then
-               echo "Warning: user postfix haven't uid=62. Correct this before installing postfix" 1>&2
+               echo "Error: user postfix doesn't have uid=62. Correct this before installing postfix." 1>&2
                exit 1
        fi
 else
@@ -161,9 +311,10 @@ else
 fi
 
 %post
+/sbin/ldconfig
 if ! grep -q "^postmaster:" /etc/mail/aliases; then
-        echo "Adding Entry for postmaster in /etc/mail/aliases" >&2
-        echo "postmaster:      root" >>/etc/mail/aliases
+       echo "Adding Entry for postmaster in /etc/mail/aliases" >&2
+       echo "postmaster:       root" >>/etc/mail/aliases
 fi
 if ! grep -q "^myhostname" /etc/mail/main.cf; then
        postconf -e myhostname=`/bin/hostname -f`
@@ -186,42 +337,61 @@ if [ "$1" = "0" ]; then
 fi
 
 %postun
-if [ $1 = 0 ]; then
+/sbin/ldconfig
+if [ "$1" = "0" ]; then
        /usr/sbin/groupdel maildrop 2> /dev/null
        /usr/sbin/userdel postfix 2> /dev/null
        /usr/sbin/groupdel postfix 2> /dev/null
 fi
 
+%triggerpostun -- postfix < 1:1.1.2
+umask 022
+sed -e 's/^\(pickup[   ]\+fifo[        ]\+[^   ]\+[    ]\+\)[^         ]\+\([  ]\)/\1-\2/;
+s/^\(cleanup[  ]\+unix[        ]\+\)[^         ]\+\([  ]\)/\1n\2/' /etc/mail/master.cf \
+       > /etc/mail/master.cf.rpmtmp
+mv -f /etc/mail/master.cf.rpmtmp /etc/mail/master.cf
+
 %files
 %defattr(644,root,root,755)
-%doc html *README.gz
-%doc {HISTORY,COMPATIBILITY,LICENSE,RELEASE_NOTES,RESTRICTION_CLASS,TODO}.gz
+%doc html *README COMPATIBILITY HISTORY LICENSE RELEASE_NOTES
+%doc README_FILES/*README
 %doc sample-conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/access
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/aliases
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/canonical
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/pcre_table
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/regexp_table
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/relocated
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/transport
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/virtual
 #%ghost %{_sysconfdir}/mail/*.db
 %dir %{_sysconfdir}/mail
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/dynamicmaps.cf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/main.cf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/master.cf
 %attr(755,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/postfix-script
+%attr(755,root,root) %{_sysconfdir}/mail/post-install
+%{_sysconfdir}/mail/postfix-files
 %attr(740,root,root) /etc/cron.daily/postfix
 %attr(754,root,root) /etc/rc.d/init.d/postfix
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/postfix
-%{!?_without_sasl:%config(noreplace) %verify(not size mtime md5) /etc/sasl/smtpd.conf}
+%{?with_sasl:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sasl/smtpd.conf}
+%attr(755,root,root) %{_libdir}/libpostfix-*.so.*
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/s*
-%attr(755,root,root) %{_sbindir}/post*i*
+%attr(755,root,root) %{_sbindir}/postfix
+%attr(755,root,root) %{_sbindir}/postalias
+%attr(755,root,root) %{_sbindir}/postkick
 %attr(755,root,root) %{_sbindir}/postl*
 %attr(755,root,root) %{_sbindir}/postc*
 %attr(755,root,root) %{_sbindir}/postmap
+%attr(2755,root,maildrop) %{_sbindir}/postqueue
 %attr(755,root,root) %{_sbindir}/postsuper
 %attr(2755,root,maildrop) %{_sbindir}/postdrop
-%attr(755,root,root) %{_libdir}/sendmail
-%attr(755,root,root) %{_libdir}/postfix
+%attr(755,root,root) %{_sbindir}/qmqp-source
+%attr(755,root,root) /usr/lib/sendmail
+%dir %{_libdir}/postfix
+%attr(755,root,root) %{_libdir}/postfix/[!d]*
 %attr(755,root,root) %dir %{_var}/spool/postfix
 %attr(700, postfix,root) %dir %{_var}/spool/postfix/active
 %attr(700, postfix,root) %dir %{_var}/spool/postfix/bounce
@@ -232,7 +402,34 @@ fi
 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
 %attr(755, postfix,root) %dir %{_var}/spool/postfix/pid
 %attr(700, postfix,root) %dir %{_var}/spool/postfix/private
-%attr(755, postfix,root) %dir %{_var}/spool/postfix/public
+%attr(710, postfix,maildrop) %dir %{_var}/spool/postfix/public
 %attr(700, postfix,root) %dir %{_var}/spool/postfix/saved
 %attr(644, postfix,root) %{_var}/spool/postfix/.nofinger
 %{_mandir}/man*/*
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libpostfix-*.so
+%{_includedir}/postfix
+
+%if %{with ldap}
+%files dict-ldap
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
+%endif
+
+%if %{with mysql}
+%files dict-mysql
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
+%endif
+
+%files dict-pcre
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
+
+%if %{with pgsql}
+%files dict-pgsql
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
+%endif
This page took 0.137377 seconds and 4 git commands to generate.