]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
This commit was manufactured by cvs2git to create tag 'auto-ac-poldek-
[packages/poldek.git] / poldek.spec
index 49dab4cd49b287ed1a0572cc9456714ddae9dff4..3661fb8c572a6cbb03063e6457033eb31c082dc3 100644 (file)
@@ -1,51 +1,60 @@
 #
 # Conditional build:
-# _with_static         - don't use shared libraries
-# _without_imode       - don't build interactive mode
-# _with_curl           - link with curl
+%bcond_with    static  # don't use shared libraries
+%bcond_without imode   # don't build interactive mode
+%bcond_with    curl    # link with curl
 #
+# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
+%define        ver_db  4.2.50-1
+%define        ver_rpm 4.3-0.20040107.34
 Summary:       RPM packages management helper tool
 Summary(pl):   Pomocnicze narzêdzie do zarz±dzania pakietami RPM
 Name:          poldek
-Version:       0.18.1
-Release:       12
+Version:       0.18.8
+Release:       7
 License:       GPL v2
 Group:         Applications/System
 Source0:       http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 8af8090d401254939911e456e2f09e60
+# Source0-md5: f7e2978c7f8b35b0b07d0278dd299881
 Source1:       %{name}.conf
-Patch0:                %{name}-static.patch
-Patch1:                %{name}-etc_dir.patch
-Patch2:                %{name}-rpm4.2.patch
-Patch3:                %{name}-rpm4.1-fix.patch
-Patch4:                %{name}-retr_term.patch
-Patch5:                %{name}-deps-fix.patch
-Patch6:                %{name}-broken-rpmdb.patch
+Patch0:                %{name}-etc_dir.patch
+Patch1:                %{name}-retr_term.patch
+Patch2:                %{name}-simplestatic.patch
+Patch3:                %{name}-cookie.patch
+Patch4:                %{name}-rpmcmd.patch
 URL:           http://team.pld.org.pl/~mis/poldek/
-BuildRequires: bzip2-devel
-%{?_with_curl:BuildRequires:   curl-devel >= 7.8}
 BuildRequires: automake
 BuildRequires: autoconf
+BuildRequires: bzip2-devel
+%{?with_curl:BuildRequires:    curl-devel >= 7.8}
+BuildRequires: db-devel >= %{ver_db}
 BuildRequires: gettext-autopoint
-BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pcre-devel
 BuildRequires: popt-devel
 BuildRequires: readline-devel
-BuildRequires: rpm-devel >= 4.0.2-62
+BuildRequires: rpm-devel >= %{ver_rpm}
 BuildRequires: zlib-devel
-BuildRequires: /usr/bin/pod2man
-%{?_with_static:BuildRequires: bzip2-static}
-%{?_with_curl:%{?_with_static:BuildRequires:   curl-static}}
-%{?_with_static:BuildRequires: ncurses-static}
-%{?_with_static:BuildRequires: openssl-static}
-%{?_with_static:BuildRequires: pcre-static}
-%{?_with_static:BuildRequires: popt-static}
-%{?_with_static:BuildRequires: readline-static}
-%{?_with_static:BuildRequires: rpm-static}
-%{?_with_static:BuildRequires: zlib-static}
-%{?_with_static:BuildRequires: glibc-static}
-Requires:      rpm >= 4.0.2-62
+BuildRequires: perl-tools-pod
+%if %{with static}
+BuildRequires: bzip2-static
+%{?with_curl:BuildRequires:    curl-static}
+BuildRequires: db-static >= %{ver_db}
+BuildRequires: glibc-static
+BuildRequires: libselinux-static
+BuildRequires: ncurses-static
+BuildRequires: openssl-static
+BuildRequires: pcre-static
+BuildRequires: popt-static
+BuildRequires: readline-static
+BuildRequires: rpm-static
+BuildRequires: zlib-static
+%endif
+Requires:      db >= %{ver_db}
+Requires:      ed
+Requires:      rpm >= %{ver_rpm}
 Requires:      sed
+Requires:      openssl >= 0.9.7c
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -58,9 +67,9 @@ interactive mode. The interactive mode puts you into a readline
 interface with command line autocompletion and history, similar to the
 shell mode of Perl's CPAN.
 
-%{?_with_static:This version is statically linked.}
+%{?with_static:This version is statically linked.}
 
-%{?_without_imode:This version hasn't got interactive mode.}
+%{!?with_imode:This version hasn't got interactive mode.}
 
 %description -l pl
 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
@@ -72,29 +81,29 @@ interaktywnym. Tryb interaktywny posiada interfejs readline z
 dope³nianiem komend i histori±, podobny do trybu shell perlowego
 modu³u CPAN.
 
-%{?_with_static:Ta wersja jest konsolidowana statycznie.}
+%{?with_static:Ta wersja jest konsolidowana statycznie.}
 
-%{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
+%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
 
 %prep
 %setup -q
-%patch0        -p1
+%patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p0
+%patch2 -p0
+%patch3 -p1
 %patch4 -p1
-%patch5 -p0
-%patch6 -p1
 
 %build
-autopoint --force
+%{__autopoint}
 %{__aclocal} -I m4
 %{__autoconf}
+%{__autoheader}
 %{__automake}
+cp -f config.sub trurlib
 %configure \
-       %{?_with_static:--enable-static} \
-       %{?_without_imode:--disable-imode} \
-       %{?_with_curl:--with-curl}
+       %{?with_static:--enable-static} \
+       %{!?with_imode:--disable-imode} \
+       %{?with_curl:--with-curl}
 %{__make}
 
 %install
@@ -104,14 +113,46 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{?_with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
-sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
+%{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
+
+#
+# CHANGE IT WHEN SWITCHING poldek.conf FROM AC TO TH !!!
+#
+%ifarch i386 i586 i686 ppc sparc alpha amd64 athlon
+%define                _ftp_arch       %{_target_cpu}
+%else
+%ifarch i486
+%define                _ftp_arch       i386
+%else
+%ifarch pentium2 pentium3 pentium4
+%define                _ftp_arch       i686
+%else
+%ifarch sparcv9 sparc64
+%define                _ftp_arch       sparc
+%endif
+%endif
+%endif
+%endif
+
+sed "s|%%ARCH%%|%{_ftp_arch}|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%triggerpostun -- poldek <= 0.18.3-5
+if grep -q '^promoteepoch.*yes' %{_sysconfdir}/poldek.conf ; then
+       echo -e ',s:^promoteepoch:# promoteepoch:g\n,w' | ed -s %{_sysconfdir}/poldek.conf
+fi
+
+# otherwise don't touch
+%ifarch i386 i586 i686 ppc sparc alpha amd64 athlon
+%triggerpostun -- poldek <= 0.18.7-1
+echo -e ',s://ftp.pld-linux.org://ftp.%{_target_cpu}.ac.pld-linux.org:g\n,w' |\
+       ed -s /etc/poldek.conf ||:
+%endif
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README* NEWS TODO *sample* conf/poldekrc*
This page took 0.035205 seconds and 4 git commands to generate.