]> git.pld-linux.org Git - packages/pida.git/blobdiff - pida.spec
- add R: python-argparse (thanks to Witold Firlej)
[packages/pida.git] / pida.spec
index 5b302aba7c0b2c48cb43f48e7a7f08e1a26300a4..590318c44e57cb66d43bd670c9c6c24189df5110 100644 (file)
--- a/pida.spec
+++ b/pida.spec
@@ -2,28 +2,35 @@
 # - investigate the documentation format in doc
 # - verify if such a big version jump actually works
 # - move .po files to glibc dir and test if it works
+#   are these used afterall, as they are .po sources not .mo compiled
 # - moo_stub is just sample? kill it and can make package noarch.
-#
-%define                realname PIDA
+# - pida probably needs some .py files to run properly
 #
 Summary:       A framework for integrated development
 Summary(pl.UTF-8):     Szkielet do programowania zintegrowanego
 Name:          pida
-Version:       0.5.1
-Release:       1
-License:       GPL
+Version:       0.6.2
+Release:       0.1
+License:       GPL v2+
 Group:         Development/Tools
-Source0:       http://pida.googlecode.com/files/%{realname}-%{version}.tar.gz
-# Source0-md5: d24bbdc2c07172062cf55dffe58c85f6
+Source0:       http://pypi.python.org/packages/source/p/pida/%{name}-%{version}.tar.gz
+# Source0-md5: 6ee61497996abd54f8a9dacd39b90c8c
 Source1:       %{name}.desktop
-URL:           http://pida.berlios.de/
+URL:           http://pida.co.uk/
+BuildRequires: pkgconfig
 BuildRequires: python-devel
 BuildRequires: python-pygtk-devel
+BuildRequires: python-pygtk-glade
 BuildRequires: python-setuptools
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.219
+Requires:      fontconfig
+Requires:      python-argparse
 Requires:      python-gnome-desktop-gtksourceview
 Requires:      python-gnome-gconf
 Requires:      python-kiwi
+Requires:      python-pygtkhelpers
+Requires:      python-simplejson
 Requires:      python-vte
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -51,23 +58,23 @@ Unikalne cechy:
 - wiele innych unikalnych i pożądanych drobiazgów
 
 %prep
-%setup -q -n %{realname}-%{version}
+%setup -q
 
 %build
-python setup.py build
+%{__python} setup.py build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 
-python setup.py install \
+%{__python} setup.py install \
        --install-data=%{_datadir}/%{name} \
        --root=$RPM_BUILD_ROOT \
        --optimize=2
 
 cp $RPM_BUILD_ROOT%{py_sitedir}/%{name}/resources/pixmaps/pida-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-%py_postclean
+#%%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -76,138 +83,151 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS README
 %attr(755,root,root) %{_bindir}/pida
+%attr(755,root,root) %{_bindir}/pida-build
 %attr(755,root,root) %{_bindir}/pida-remote
 
 # see todo at top of the spec
-%lang(fr) %{py_sitedir}/pida/resources/locale/fr_FR/LC_MESSAGES/pida.po
-%lang(fr) %{py_sitedir}/pida/services/appcontroller/locale/fr_FR/LC_MESSAGES/appcontroller.po
-%lang(fr) %{py_sitedir}/pida/services/buffer/locale/fr_FR/LC_MESSAGES/buffer.po
-%lang(fr) %{py_sitedir}/pida/services/bugreport/locale/fr_FR/LC_MESSAGES/bugreport.po
-%lang(fr) %{py_sitedir}/pida/services/commander/locale/fr_FR/LC_MESSAGES/commander.po
-%lang(fr) %{py_sitedir}/pida/services/editor/locale/fr_FR/LC_MESSAGES/editor.po
-%lang(fr) %{py_sitedir}/pida/services/filemanager/locale/fr_FR/LC_MESSAGES/filemanager.po
-%lang(fr) %{py_sitedir}/pida/services/grepper/locale/fr_FR/LC_MESSAGES/grepper.po
-%lang(fr) %{py_sitedir}/pida/services/help/locale/fr_FR/LC_MESSAGES/help.po
-%lang(fr) %{py_sitedir}/pida/services/manhole/locale/fr_FR/LC_MESSAGES/manhole.po
-%lang(fr) %{py_sitedir}/pida/services/notify/locale/fr_FR/LC_MESSAGES/notify.po
-%lang(fr) %{py_sitedir}/pida/services/openwith/locale/fr_FR/LC_MESSAGES/openwith.po
-%lang(fr) %{py_sitedir}/pida/services/optionsmanager/locale/fr_FR/LC_MESSAGES/optionsmanager.po
-%lang(fr) %{py_sitedir}/pida/services/plugins/locale/fr_FR/LC_MESSAGES/plugins.po
-%lang(fr) %{py_sitedir}/pida/services/project/locale/fr_FR/LC_MESSAGES/project.po
-%lang(fr) %{py_sitedir}/pida/services/sessions/locale/fr_FR/LC_MESSAGES/sessions.po
-%lang(fr) %{py_sitedir}/pida/services/shortcuts/locale/fr_FR/LC_MESSAGES/shortcuts.po
-%lang(fr) %{py_sitedir}/pida/services/versioncontrol/locale/fr_FR/LC_MESSAGES/versioncontrol.po
-%lang(fr) %{py_sitedir}/pida/services/webbrowser/locale/fr_FR/LC_MESSAGES/webbrowser.po
-%lang(fr) %{py_sitedir}/pida/services/window/locale/fr_FR/LC_MESSAGES/window.po
+#%%dir %{py_sitedir}/pida/resources/locale
+#%%dir %{py_sitedir}/pida/services/appcontroller/locale
+#%%dir %{py_sitedir}/pida/services/browseweb/locale
+#%%dir %{py_sitedir}/pida/services/buffer/locale
+#%%dir %{py_sitedir}/pida/services/bugreport/locale
+#%%dir %{py_sitedir}/pida/services/commander/locale
+#%%dir %{py_sitedir}/pida/services/editor/locale
+#%%dir %{py_sitedir}/pida/services/filemanager/locale
+#%%dir %{py_sitedir}/pida/services/grepper/locale
+#%%dir %{py_sitedir}/pida/services/help/locale
+#%%dir %{py_sitedir}/pida/services/manhole/locale
+#%%dir %{py_sitedir}/pida/services/notify/locale
+#%%dir %{py_sitedir}/pida/services/openwith/locale
+#%%dir %{py_sitedir}/pida/services/optionsmanager/locale
+#%%dir %{py_sitedir}/pida/services/plugins/locale
+#%%dir %{py_sitedir}/pida/services/project/locale
+#%%dir %{py_sitedir}/pida/services/sessions/locale
+#%%dir %{py_sitedir}/pida/services/shortcuts/locale
+#%%dir %{py_sitedir}/pida/services/versioncontrol/locale
+#%%dir %{py_sitedir}/pida/services/window/locale
+#%%lang(fr) %{py_sitedir}/pida/resources/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/appcontroller/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/browseweb/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/buffer/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/bugreport/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/commander/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/editor/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/filemanager/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/grepper/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/help/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/manhole/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/notify/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/openwith/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/optionsmanager/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/plugins/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/project/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/sessions/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/shortcuts/locale/fr_FR
+#%%lang(fr) %{py_sitedir}/pida/services/versioncontrol/locale/fr_FR
+#$%lang(fr) %{py_sitedir}/pida/services/window/locale/fr_FR
 
-%{py_sitedir}/*-py2.5.egg-info
-%attr(755,root,root) %{py_sitedir}/moo_stub.so
-%{py_sitedir}/pida/*.py[co]
+%if "%{py_ver}" > "2.4"
+%{py_sitedir}/pida-*-py2.*.egg-info
+%endif
 
+%dir %{py_sitedir}/pida
+#%%attr(755,root,root) %{py_sitedir}/moo_stub.so
+%{py_sitedir}/pida/*.py[co]
 %{py_sitedir}/pida/core
 %{py_sitedir}/pida/editors
+%dir %{py_sitedir}/pida/plugins
+%dir %{py_sitedir}/pida/plugins/*.py[co]
 %dir %{py_sitedir}/pida/resources
-%{py_sitedir}/pida/resources/glade
+#%%{py_sitedir}/pida/resources/glade
 %{py_sitedir}/pida/resources/pixmaps
 %{py_sitedir}/pida/resources/uidef
+%dir %{py_sitedir}/pida/resources/data
+%dir %{py_sitedir}/pida/resources/data/gtkrc-2.0
+#%%{py_sitedir}/pida/resources/data/*.py[co]
+%{py_sitedir}/pida/resources/data/*.vim
+%{py_sitedir}/pida/resources/data/*.el
 %dir %{py_sitedir}/pida/services
 %dir %{py_sitedir}/pida/services/appcontroller
 %{py_sitedir}/pida/services/appcontroller/*.py[co]
-%{py_sitedir}/pida/services/appcontroller/service.pida
 %{py_sitedir}/pida/services/appcontroller/uidef
+%dir %{py_sitedir}/pida/services/browseweb
+#%%{py_sitedir}/pida/services/browseweb/glade
+%{py_sitedir}/pida/services/browseweb/*.py[co]
+%{py_sitedir}/pida/services/browseweb/uidef
 %dir %{py_sitedir}/pida/services/buffer
 %{py_sitedir}/pida/services/buffer/glade
 %{py_sitedir}/pida/services/buffer/*.py[co]
-%{py_sitedir}/pida/services/buffer/service.pida
-%{py_sitedir}/pida/services/buffer/uidef/buffer-file-menu.xml
-%{py_sitedir}/pida/services/buffer/uidef/buffer.xml
-%dir %{py_sitedir}/pida/services/bugreport
-%{py_sitedir}/pida/services/bugreport/glade
-%{py_sitedir}/pida/services/bugreport/*.py[co]
-%{py_sitedir}/pida/services/bugreport/service.pida
-%{py_sitedir}/pida/services/bugreport/uidef
+%{py_sitedir}/pida/services/buffer/uidef
+#%%dir %{py_sitedir}/pida/services/bugreport
+#%%{py_sitedir}/pida/services/bugreport/glade
+#%%{py_sitedir}/pida/services/bugreport/*.py[co]
+#%%{py_sitedir}/pida/services/bugreport/uidef
 %dir %{py_sitedir}/pida/services/commander
 %{py_sitedir}/pida/services/commander/*.py[co]
-%{py_sitedir}/pida/services/commander/service.pida
+%{py_sitedir}/pida/services/commander/pixmaps
 %{py_sitedir}/pida/services/commander/uidef
 %dir %{py_sitedir}/pida/services/contexts
 %{py_sitedir}/pida/services/contexts/*.py[co]
-%{py_sitedir}/pida/services/contexts/service.pida
 %{py_sitedir}/pida/services/contexts/uidef
 %dir %{py_sitedir}/pida/services/editor
 %{py_sitedir}/pida/services/editor/*.py[co]
-%{py_sitedir}/pida/services/editor/service.pida
 %dir %{py_sitedir}/pida/services/filemanager
 %{py_sitedir}/pida/services/filemanager/*.py[co]
-%{py_sitedir}/pida/services/filemanager/service.pida
 %{py_sitedir}/pida/services/filemanager/uidef
 %dir %{py_sitedir}/pida/services/filewatcher
 %{py_sitedir}/pida/services/filewatcher/*.py[co]
-%{py_sitedir}/pida/services/filewatcher/service.pida
 %dir %{py_sitedir}/pida/services/grepper
 %{py_sitedir}/pida/services/grepper/glade
 %{py_sitedir}/pida/services/grepper/*.py[co]
-%{py_sitedir}/pida/services/grepper/service.pida
 %{py_sitedir}/pida/services/grepper/uidef
 %dir %{py_sitedir}/pida/services/help
 %{py_sitedir}/pida/services/help/*.py[co]
-%{py_sitedir}/pida/services/help/service.pida
 %{py_sitedir}/pida/services/help/uidef
+%dir %{py_sitedir}/pida/services/language
+%{py_sitedir}/pida/services/language/glade
+%{py_sitedir}/pida/services/language/*.py[co]
+%{py_sitedir}/pida/services/language/pixmaps
+%{py_sitedir}/pida/services/language/uidef
 %dir %{py_sitedir}/pida/services/manhole
 %{py_sitedir}/pida/services/manhole/*.py[co]
-%{py_sitedir}/pida/services/manhole/service.pida
 %{py_sitedir}/pida/services/manhole/uidef
 %dir %{py_sitedir}/pida/services/notify
 %{py_sitedir}/pida/services/notify/*.py[co]
-%{py_sitedir}/pida/services/notify/service.pida
 %{py_sitedir}/pida/services/notify/uidef
 %dir %{py_sitedir}/pida/services/openwith
 %{py_sitedir}/pida/services/openwith/glade
 %{py_sitedir}/pida/services/openwith/*.py[co]
-%{py_sitedir}/pida/services/openwith/service.pida
 %{py_sitedir}/pida/services/openwith/uidef
 %dir %{py_sitedir}/pida/services/optionsmanager
-%{py_sitedir}/pida/services/optionsmanager/glade
+#%%{py_sitedir}/pida/services/optionsmanager/glade
 %{py_sitedir}/pida/services/optionsmanager/*.py[co]
-%{py_sitedir}/pida/services/optionsmanager/service.pida
 %{py_sitedir}/pida/services/optionsmanager/uidef
 %dir %{py_sitedir}/pida/services/plugins
 %{py_sitedir}/pida/services/plugins/glade
 %{py_sitedir}/pida/services/plugins/*.py[co]
-%{py_sitedir}/pida/services/plugins/service.pida
 %{py_sitedir}/pida/services/plugins/uidef
 %dir %{py_sitedir}/pida/services/project
 %{py_sitedir}/pida/services/project/glade
 %{py_sitedir}/pida/services/project/*.py[co]
-%{py_sitedir}/pida/services/project/service.pida
 %{py_sitedir}/pida/services/project/uidef
 %{py_sitedir}/pida/services/*.py[co]
-%dir %{py_sitedir}/pida/services/rpc
-%{py_sitedir}/pida/services/rpc/*.py[co]
-%{py_sitedir}/pida/services/rpc/service.pida
-%dir %{py_sitedir}/pida/services/sessions
-%{py_sitedir}/pida/services/sessions/*.py[co]
-%{py_sitedir}/pida/services/sessions/service.pida
-%{py_sitedir}/pida/services/sessions/uidef
+#%%dir %{py_sitedir}/pida/services/sessions
+#%%{py_sitedir}/pida/services/sessions/glade
+#%%{py_sitedir}/pida/services/sessions/*.py[co]
+#%%{py_sitedir}/pida/services/sessions/uidef
 %dir %{py_sitedir}/pida/services/shortcuts
 %{py_sitedir}/pida/services/shortcuts/*.py[co]
-%{py_sitedir}/pida/services/shortcuts/service.pida
 %{py_sitedir}/pida/services/shortcuts/uidef
 %dir %{py_sitedir}/pida/services/statusbar
 %{py_sitedir}/pida/services/statusbar/*.py[co]
-%{py_sitedir}/pida/services/statusbar/service.pida
 %dir %{py_sitedir}/pida/services/versioncontrol
 %{py_sitedir}/pida/services/versioncontrol/glade
 %{py_sitedir}/pida/services/versioncontrol/*.py[co]
-%{py_sitedir}/pida/services/versioncontrol/service.pida
 %{py_sitedir}/pida/services/versioncontrol/uidef
-%dir %{py_sitedir}/pida/services/webbrowser
-%{py_sitedir}/pida/services/webbrowser/*.py[co]
-%{py_sitedir}/pida/services/webbrowser/service.pida
-%{py_sitedir}/pida/services/webbrowser/uidef
 %dir %{py_sitedir}/pida/services/window
 %{py_sitedir}/pida/services/window/*.py[co]
-%{py_sitedir}/pida/services/window/service.pida
 %{py_sitedir}/pida/services/window/uidef
 %{py_sitedir}/pida/ui
 %{py_sitedir}/pida/utils
This page took 0.100213 seconds and 4 git commands to generate.