]> git.pld-linux.org Git - packages/phpMyAdmin.git/blobdiff - phpMyAdmin.spec
- release 3
[packages/phpMyAdmin.git] / phpMyAdmin.spec
index 2d587d4a1ed4c1f8cf28ab8e2fc47542c2d61f34..792674639dfaf46355e4e4df0cff5390a6b4706d 100644 (file)
@@ -1,19 +1,33 @@
 Summary:       phpMyAdmin - web-based MySQL administration
 Summary(pl):   phpMyAdmin - administracja bazami MySQL przez WWW
 Name:          phpMyAdmin
-Version:       2.3.2
-Release:       1
+%define                _pl     pl2
+%define                _rel    3
+# NOTE: bump _rel with every new patchlevel
+Version:       2.6.0
+#Release:      1
+Release:       %{_rel}.%{_pl}
+#Release:      0.%{_pl}.%{_rel}
 License:       GPL v2
 Group:         Applications/Databases/Interfaces
-Source0:       http://prdownloads.sourceforge.net/phpmyadmin/%{name}-%{version}-php.tar.bz2
-URL:           http://www.phpmyadmin.net
-Requires:      mysql
+Source0:       http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-%{_pl}.tar.bz2
+# Source0-md5: f9000262ce736ec21369e1be1522ea0d
+# Source0-size:        1278267
+#Source0:      http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}.tar.bz2
+Source1:       %{name}.conf
+Patch0:                %{name}-config.patch
+URL:           http://www.phpmyadmin.net/
+#Requires:     mysql
+Requires(postun):      perl-base
 Requires:      php-mysql
+Requires:      php-pcre
+Requires:      php
 Requires:      webserver
-Buildarch:     noarch
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _myadmindir     /home/services/httpd/html/myadmin
+%define                _myadmindir     %{_datadir}/%{name}
+%define                _sysconfdir     /etc/%{name}
 
 %description
 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
@@ -50,30 +64,95 @@ MySQL). Aktualnie phpMyAdmin potrafi:
   - tworzyƦ i czytaƦ zrzuty tabel
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}-%{_pl}
+#%setup -q
+%patch -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_myadmindir}/{lang,images,libraries,libraries/auth}
+install -d $RPM_BUILD_ROOT%{_myadmindir}/{css,lang,libraries/{auth,export,dbg,dbi,transformations}} \
+       $RPM_BUILD_ROOT{%{_sysconfdir},/etc/httpd}
 
-install *.php *.html badwords.txt $RPM_BUILD_ROOT%{_myadmindir}
-install images/*.{gif,png} $RPM_BUILD_ROOT%{_myadmindir}/images
+install *.php *.html *.css $RPM_BUILD_ROOT%{_myadmindir}
+#install images/*.{gif,png} $RPM_BUILD_ROOT%{_myadmindir}/images
 install lang/*.php $RPM_BUILD_ROOT%{_myadmindir}/lang
+cp -rf themes  $RPM_BUILD_ROOT%{_myadmindir}/
+install css/* $RPM_BUILD_ROOT%{_myadmindir}/css
 install libraries/*.{js,php} $RPM_BUILD_ROOT%{_myadmindir}/libraries
 install libraries/auth/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/auth
+install libraries/export/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/export
+install libraries/dbg/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/dbg
+install libraries/dbi/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/dbi
+install libraries/transformations/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/transformations
+
+cp -rf scripts $RPM_BUILD_ROOT%{_myadmindir}
+
+install config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}
+ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_myadmindir}/config.inc.php
+
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*%{name}.conf" /etc/httpd/httpd.conf; then
+       echo "Include /etc/httpd/%{name}.conf" >> /etc/httpd/httpd.conf
+       if [ -f /var/lock/subsys/httpd ]; then
+               /usr/sbin/apachectl restart 1>&2
+       fi
+elif [ -d /etc/httpd/httpd.conf ]; then
+       ln -sf /etc/httpd/%{name}.conf /etc/httpd/httpd.conf/99_%{name}.conf
+       if [ -f /var/lock/subsys/httpd ]; then
+               /usr/sbin/apachectl restart 1>&2
+       fi
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       umask 027
+       if [ -d /etc/httpd/httpd.conf ]; then
+           rm -f /etc/httpd/httpd.conf/99_%{name}.conf
+       else
+               grep -v "^Include.*%{name}.conf" /etc/httpd/httpd.conf > \
+                       /etc/httpd/httpd.conf.tmp
+               mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
+       fi
+       if [ -f /var/lock/subsys/httpd ]; then
+           /usr/sbin/apachectl restart 1>&2
+       fi
+fi
+
+%triggerpostun -- phpMyAdmin <= 2.5.3-2
+if [ -f /home/services/httpd/html/myadmin/config.inc.php.rpmsave ]; then
+       mv -f /home/services/httpd/html/myadmin/config.inc.php.rpmsave /etc/phpMyAdmin/config.inc.php
+else
+       if [ -f /home/httpd/html/myadmin/config.inc.php.rpmsave ]; then
+               mv -f /home/httpd/html/myadmin/config.inc.php.rpmsave /etc/phpMyAdmin/config.inc.php
+       fi
+fi
+for i in `grep -lr "/home/\(services/\)*httpd/html/myadmin" /etc/httpd/*`; do
+       cp $i $i.backup
+       %{__perl} -pi -e "s#/home/httpd/html/myadmin#%{_myadmindir}#g" $i
+       %{__perl} -pi -e "s#/home/services/httpd/html/myadmin#%{_myadmindir}#g" $i
+       echo "File changed by trigger: $i (backup: $i.backup)"
+done
+if [ -f /var/lock/subsys/httpd ]; then
+       /usr/sbin/apachectl restart 1>&2
+fi
+
 %files
 %defattr(644,root,root,755)
-%doc Documentation.txt ANNOUNCE.txt README TODO ChangeLog
+%doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts
+%dir %{_sysconfdir}
+%attr(640,root,http) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*
+%config(noreplace) %verify(not size mtime md5) /etc/httpd/%{name}.conf
 %dir %{_myadmindir}
-%attr(640,root,http) %config(noreplace) %verify(not size mtime md5) %{_myadmindir}/config.inc.php
-%{_myadmindir}/images
+%{_myadmindir}/css
+%{_myadmindir}/themes
+%{_myadmindir}/scripts
 %{_myadmindir}/lang
 %{_myadmindir}/libraries
-%{_myadmindir}/badwords.txt
+%{_myadmindir}/*.css
 %{_myadmindir}/*.html
-%{_myadmindir}/[^c]*.php
-%{_myadmindir}/c[^o]*.php
+%{_myadmindir}/*.php
This page took 0.70765 seconds and 4 git commands to generate.