]> git.pld-linux.org Git - packages/phpMyAdmin.git/blobdiff - phpMyAdmin.spec
- release 3
[packages/phpMyAdmin.git] / phpMyAdmin.spec
index 0b0a2237b1034522e07b4b833109b4bd118cabee..792674639dfaf46355e4e4df0cff5390a6b4706d 100644 (file)
@@ -1,15 +1,19 @@
-# NOTE:        currently apache configs are in /etc/httpd/httpd.conf/ directory
-#      but phpMyAdmin.conf is placed in /etc/httpd/
 Summary:       phpMyAdmin - web-based MySQL administration
 Summary(pl):   phpMyAdmin - administracja bazami MySQL przez WWW
 Name:          phpMyAdmin
-%define                _rc     rc2
-Version:       2.5.6
-Release:       0.%{_rc}.1
+%define                _pl     pl2
+%define                _rel    3
+# NOTE: bump _rel with every new patchlevel
+Version:       2.6.0
+#Release:      1
+Release:       %{_rel}.%{_pl}
+#Release:      0.%{_pl}.%{_rel}
 License:       GPL v2
 Group:         Applications/Databases/Interfaces
-Source0:       http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-%{_rc}.tar.bz2
-# Source0-md5: 51eebb1363bbef27a7cf6e3fbb95ee5c
+Source0:       http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-%{_pl}.tar.bz2
+# Source0-md5: f9000262ce736ec21369e1be1522ea0d
+# Source0-size:        1278267
+#Source0:      http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}.tar.bz2
 Source1:       %{name}.conf
 Patch0:                %{name}-config.patch
 URL:           http://www.phpmyadmin.net/
@@ -60,21 +64,28 @@ MySQL). Aktualnie phpMyAdmin potrafi:
   - tworzyƦ i czytaƦ zrzuty tabel
 
 %prep
-%setup -q -n %{name}-%{version}-%{_rc}
+%setup -q -n %{name}-%{version}-%{_pl}
+#%setup -q
 %patch -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_myadmindir}/{css,lang,images,libraries/{auth,export}} \
+install -d $RPM_BUILD_ROOT%{_myadmindir}/{css,lang,libraries/{auth,export,dbg,dbi,transformations}} \
        $RPM_BUILD_ROOT{%{_sysconfdir},/etc/httpd}
 
 install *.php *.html *.css $RPM_BUILD_ROOT%{_myadmindir}
-install images/*.{gif,png} $RPM_BUILD_ROOT%{_myadmindir}/images
+#install images/*.{gif,png} $RPM_BUILD_ROOT%{_myadmindir}/images
 install lang/*.php $RPM_BUILD_ROOT%{_myadmindir}/lang
+cp -rf themes  $RPM_BUILD_ROOT%{_myadmindir}/
 install css/* $RPM_BUILD_ROOT%{_myadmindir}/css
 install libraries/*.{js,php} $RPM_BUILD_ROOT%{_myadmindir}/libraries
 install libraries/auth/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/auth
 install libraries/export/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/export
+install libraries/dbg/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/dbg
+install libraries/dbi/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/dbi
+install libraries/transformations/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/transformations
+
+cp -rf scripts $RPM_BUILD_ROOT%{_myadmindir}
 
 install config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}
 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_myadmindir}/config.inc.php
@@ -85,13 +96,16 @@ install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*phpMyAdmin.conf" /etc/httpd/httpd.conf; then
-       echo "Include /etc/httpd/phpMyAdmin.conf" >> /etc/httpd/httpd.conf
+if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*%{name}.conf" /etc/httpd/httpd.conf; then
+       echo "Include /etc/httpd/%{name}.conf" >> /etc/httpd/httpd.conf
+       if [ -f /var/lock/subsys/httpd ]; then
+               /usr/sbin/apachectl restart 1>&2
+       fi
 elif [ -d /etc/httpd/httpd.conf ]; then
-       mv -f /etc/httpd/%{name}.conf /etc/httpd/httpd.conf/99_%{name}.conf
-fi
-if [ -f /var/lock/subsys/httpd ]; then
-       /usr/sbin/apachectl restart 1>&2
+       ln -sf /etc/httpd/%{name}.conf /etc/httpd/httpd.conf/99_%{name}.conf
+       if [ -f /var/lock/subsys/httpd ]; then
+               /usr/sbin/apachectl restart 1>&2
+       fi
 fi
 
 %preun
@@ -100,12 +114,12 @@ if [ "$1" = "0" ]; then
        if [ -d /etc/httpd/httpd.conf ]; then
            rm -f /etc/httpd/httpd.conf/99_%{name}.conf
        else
-               grep -v "^Include.*phpMyAdmin.conf" /etc/httpd/httpd.conf > \
-                       etc/httpd/httpd.conf.tmp
+               grep -v "^Include.*%{name}.conf" /etc/httpd/httpd.conf > \
+                       /etc/httpd/httpd.conf.tmp
                mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
-               if [ -f /var/lock/subsys/httpd ]; then
-                   /usr/sbin/apachectl restart 1>&2
-               fi
+       fi
+       if [ -f /var/lock/subsys/httpd ]; then
+           /usr/sbin/apachectl restart 1>&2
        fi
 fi
 
@@ -135,7 +149,8 @@ fi
 %config(noreplace) %verify(not size mtime md5) /etc/httpd/%{name}.conf
 %dir %{_myadmindir}
 %{_myadmindir}/css
-%{_myadmindir}/images
+%{_myadmindir}/themes
+%{_myadmindir}/scripts
 %{_myadmindir}/lang
 %{_myadmindir}/libraries
 %{_myadmindir}/*.css
This page took 0.030606 seconds and 4 git commands to generate.