]> git.pld-linux.org Git - packages/phpMyAdmin.git/blobdiff - phpMyAdmin.spec
- up to 2.6.4-rc1
[packages/phpMyAdmin.git] / phpMyAdmin.spec
index 9e285d1c299c9646c3679f2351acde1f095598c9..2c94cfa75a88e88c6682beae1ce0362ac431d944 100644 (file)
@@ -1,18 +1,16 @@
+# TODO
+# - http://www.gentoo.org/security/en/glsa/glsa-200504-30.xml
 Summary:       phpMyAdmin - web-based MySQL administration
 Summary(pl):   phpMyAdmin - administracja bazami MySQL przez WWW
 Name:          phpMyAdmin
-%define                _pl     pl2
-%define                _rel    3
-# NOTE: bump _rel with every new patchlevel
-Version:       2.6.0
+Version:       2.6.4
+%define                _pl     rc1
 #Release:      1
-Release:       %{_rel}.%{_pl}
-#Release:      0.%{_pl}.%{_rel}
+Release:       0.%{_pl}.1
 License:       GPL v2
 Group:         Applications/Databases/Interfaces
 Source0:       http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-%{_pl}.tar.bz2
-# Source0-md5: f9000262ce736ec21369e1be1522ea0d
-# Source0-size:        1278267
+# Source0-md5: dfa8a387ae7e69ec3888a1e58b68a8cc
 #Source0:      http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}.tar.bz2
 Source1:       %{name}.conf
 Patch0:                %{name}-config.patch
@@ -35,16 +33,16 @@ but also a single database. To accomplish the latter you'll need a
 properly set up MySQL-user who can read/write only the desired
 database. It's up to you to look up the appropiate part in the MySQL
 manual. Currently phpMyAdmin can:
-  - create and drop databases
-  - create, copy, drop and alter tables
-  - delete, edit and add fields
-  - execute any SQL-statement, even batch-queries
-  - manage keys on fields
-  - load text files into tables
-  - create (*) and read dumps of tables
-  - export (*) and import data to CSV values
-  - administer multiple servers and single databases
-  - communicate in more than 20 different languages
+- create and drop databases
+- create, copy, drop and alter tables
+- delete, edit and add fields
+- execute any SQL-statement, even batch-queries
+- manage keys on fields
+- load text files into tables
+- create (*) and read dumps of tables
+- export (*) and import data to CSV values
+- administer multiple servers and single databases
+- communicate in more than 20 different languages
 
 %description -l pl
 phpMyAdmin potrafi zarz±dzaæ ca³ymi bazami MySQL (potrzebne
@@ -52,20 +50,20 @@ uprawnienia superu
 Potrzebny jest u¿ytkownik, który ma prawa zapisu/odczytu tylko tych
 baz, którymi chcemy administrowaæ (wiêcej informacji w odpowiedniej
 podrêcznika MySQL). Aktualnie phpMyAdmin potrafi:
-  - tworzyæ i usuwaæ bazy
-  - wykonywaæ create, copy, drop oraz alter na tabelach
-  - dodawaæ, usuwaæ i modyfikowaæ pola
-  - wykonywaæ dowolne zapytania SQL
-  - zarz±dzaæ kluczami na rekordach
-  - wczytywaæ tekst z plików do tabel
-  - obs³ugiwaæ ponad 20 jêzyków
-  - zarz±dzaæ wieloma serwerami i pojedynczymi bazami danych
-  - eksportowaæ i importowaæ dane do warto¶ci CSV
-  - tworzyæ i czytaæ zrzuty tabel
+- tworzyæ i usuwaæ bazy
+- wykonywaæ create, copy, drop oraz alter na tabelach
+- dodawaæ, usuwaæ i modyfikowaæ pola
+- wykonywaæ dowolne zapytania SQL
+- zarz±dzaæ kluczami na rekordach
+- wczytywaæ tekst z plików do tabel
+- obs³ugiwaæ ponad 20 jêzyków
+- zarz±dzaæ wieloma serwerami i pojedynczymi bazami danych
+- eksportowaæ i importowaæ dane do warto¶ci CSV
+- tworzyæ i czytaæ zrzuty tabel
 
 %prep
-%setup -q -n %{name}-%{version}-%{_pl}
 #%setup -q
+%setup -q -n %{name}-%{version}-%{_pl}
 %patch -p1
 
 %install
@@ -76,7 +74,7 @@ install -d $RPM_BUILD_ROOT%{_myadmindir}/{css,lang,libraries/{auth,export,dbg,db
 install *.php *.html *.css $RPM_BUILD_ROOT%{_myadmindir}
 #install images/*.{gif,png} $RPM_BUILD_ROOT%{_myadmindir}/images
 install lang/*.php $RPM_BUILD_ROOT%{_myadmindir}/lang
-cp -rf themes  $RPM_BUILD_ROOT%{_myadmindir}/
+cp -rf themes $RPM_BUILD_ROOT%{_myadmindir}/
 install css/* $RPM_BUILD_ROOT%{_myadmindir}/css
 install libraries/*.{js,php} $RPM_BUILD_ROOT%{_myadmindir}/libraries
 install libraries/auth/*.php $RPM_BUILD_ROOT%{_myadmindir}/libraries/auth
@@ -112,14 +110,14 @@ fi
 if [ "$1" = "0" ]; then
        umask 027
        if [ -d /etc/httpd/httpd.conf ]; then
-           rm -f /etc/httpd/httpd.conf/99_%{name}.conf
+               rm -f /etc/httpd/httpd.conf/99_%{name}.conf
        else
                grep -v "^Include.*%{name}.conf" /etc/httpd/httpd.conf > \
                        /etc/httpd/httpd.conf.tmp
                mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
        fi
        if [ -f /var/lock/subsys/httpd ]; then
-           /usr/sbin/apachectl restart 1>&2
+               /usr/sbin/apachectl restart 1>&2
        fi
 fi
 
@@ -145,8 +143,8 @@ fi
 %defattr(644,root,root,755)
 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts
 %dir %{_sysconfdir}
-%attr(640,root,http) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*
-%config(noreplace) %verify(not size mtime md5) /etc/httpd/%{name}.conf
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
+%config(noreplace) %verify(not md5 mtime size) /etc/httpd/%{name}.conf
 %dir %{_myadmindir}
 %{_myadmindir}/css
 %{_myadmindir}/themes
This page took 0.028698 seconds and 4 git commands to generate.