]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- proper dom configure option - now shared dom module is built
[packages/php.git] / php.spec
index 3f3bb2758bf01ff1a1ab8c3f62179f25d7af9968..fe8249e7403ad2b65f2933993cc45fc55aa5f905 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -8,21 +8,19 @@
 #    - pfpro,
 #    - ircg,
 #   These extensions BuildRequires proprietary libraries...
-# - fix building of mono, sybase extensions
+# - fix building of sybase extensions
 # - test if php.cgi segfaults after ctrl+d when overload.so is loaded
-# - build simplexml as shared (now it's static)
 #
 # Conditional build:
 %bcond_with    db3             # use db3 packages instead of db (4.x) for Berkeley DB support
 %bcond_with    fdf             # with FDF (PDF forms) module           (BR: proprietary libs)
-%bcond_with    hyperwave       # with Hw API support                   (BR: proprietary libs)
+%bcond_with    hardened        # build with hardened patch applied (http://www.hardened-php.net/)
+%bcond_with    hwapi           # with Hw API support                   (BR: proprietary libs)
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
-%bcond_with    java            # with Java extension module            (BR: jdk)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_with    oracle          # with oracle extension module          (BR: proprietary libs)
 %bcond_without cpdf            # without cpdf extension module
 %bcond_without curl            # without CURL extension module
-%bcond_without domxslt         # without DOM XSLT/EXSLT support in DOM XML extension module
 %bcond_without fam             # without FAM (File Alteration Monitor) extension module
 %bcond_without imap            # without IMAP extension module
 %bcond_without interbase       # without InterBase extension module
@@ -39,7 +37,6 @@
 %bcond_without pgsql           # without PostgreSQL extension module
 %bcond_without pspell          # without pspell extension module
 %bcond_without recode          # without recode extension module
-%bcond_without simplexml       # without simplexml extension module
 %bcond_without snmp            # without SNMP extension module
 %bcond_without sqlite          # without SQLite extension module
 %bcond_without sybase          # without Sybase extension module
 %bcond_without tidy            # without Tidy extension module
 %bcond_without wddx            # without WDDX extension module
 %bcond_without xmlrpc          # without XML-RPC extension module
-%bcond_without xml             # without XML and DOMXML extension modules
-%bcond_without xslt            # without XSLT extension module
-# To be verified
-# Removed from sources?
-%bcond_with    mono            # without Mono extensions module
-%bcond_with    yaz             # without YAZ extension module
 #
 %define        _apache2        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
 %define        apxs            /usr/sbin/apxs
@@ -75,14 +66,13 @@ Summary(pt_BR):     A linguagem de script PHP
 Summary(ru):   PHP ÷ÅÒÓÉÉ 5 - ÑÚÙË ÐÒÅÐÒÏÃÅÓÓÉÒÏ×ÁÎÉÑ HTML-ÆÁÊÌÏ×, ×ÙÐÏÌÎÑÅÍÙÊ ÎÁ ÓÅÒ×ÅÒÅ
 Summary(uk):   PHP ÷ÅÒÓ¦§ 5 - ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
-Version:       5.0.2
-Release:       9
+Version:       5.0.3
+Release:       1%{?with_hardened:hardened}
 Epoch:         3
 Group:         Libraries
 License:       PHP
-#Source0:      http://www.php.net/distributions/%{name}-%{version}%{_pre}.tar.bz2
-Source0:       http://pl2.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: 579f82f3d6a61b669183b2ebce357a1e
+Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
+# Source0-md5: fd26455febdddee0977ce226b9108d9c
 Source1:       FAQ.%{name}
 Source2:       zend.gif
 Source4:       %{name}-module-install
@@ -90,34 +80,35 @@ Source5:    %{name}-mod_%{name}.conf
 Source6:       %{name}-cgi.ini
 Source7:       %{name}-apache.ini
 Source8:       %{name}-cli.ini
+Source9:       http://www.hardened-php.net/hardened-php-%{version}-0.2.5.patch.gz
+# Source9-md5: cc91bb34a066135f1ef7cb1d4ba00b0d
 Patch0:                %{name}-shared.patch
 Patch1:                %{name}-pldlogo.patch
-Patch2:                %{name}-xml-expat-fix.patch
-Patch3:                %{name}-mail.patch
-Patch4:                %{name}-link-libs.patch
-Patch5:                %{name}-libpq_fs_h_path.patch
-Patch6:                %{name}-wddx-fix.patch
-Patch7:                %{name}-msession-shared-lib.patch
-Patch8:                %{name}-build_modules.patch
-Patch9:                %{name}-sapi-ini-file.patch
-Patch10:       %{name}-no-metaccld.patch
-Patch11:       %{name}-session-unregister.patch
-Patch12:       %{name}-ini.patch
-Patch13:       %{name}-acam.patch
-Patch14:       %{name}-xmlrpc-fix.patch
-Patch15:       %{name}-libtool.patch
-Patch16:       %{name}-allow-db31.patch
-Patch17:       %{name}-threads-acfix.patch
-Patch18:       %{name}-tsrmlsfetchgcc2.patch
-Patch19:       %{name}-no_pear_install.patch
-Patch20:       %{name}-zlib.patch
-Patch21:       %{name}-sybase-fix.patch
-Patch22:       %{name}-mssql-fix.patch
-Patch23:       %{name}-mnogosearch-fix.patch
-Patch24:       %{name}-nohttpd.patch
-Patch25:       %{name}-lib64.patch
-Patch26:       %{name}-phpize.patch
-Patch27:       %{name}-gd_imagerotate_enable.patch
+Patch2:                %{name}-mail.patch
+Patch3:                %{name}-link-libs.patch
+Patch4:                %{name}-libpq_fs_h_path.patch
+Patch5:                %{name}-wddx-fix.patch
+Patch6:                %{name}-msession-shared-lib.patch
+Patch7:                %{name}-build_modules.patch
+Patch8:                %{name}-sapi-ini-file.patch
+Patch9:                %{name}-no-metaccld.patch
+Patch10:       %{name}-session-unregister.patch
+Patch11:       %{name}-ini.patch
+Patch12:       %{name}-acam.patch
+Patch13:       %{name}-xmlrpc-fix.patch
+Patch14:       %{name}-libtool.patch
+Patch15:       %{name}-allow-db31.patch
+Patch16:       %{name}-threads-acfix.patch
+Patch17:       %{name}-tsrmlsfetchgcc2.patch
+Patch18:       %{name}-no_pear_install.patch
+Patch19:       %{name}-zlib.patch
+Patch20:       %{name}-sybase-fix.patch
+Patch21:       %{name}-mnogosearch-fix.patch
+Patch22:       %{name}-nohttpd.patch
+Patch23:       %{name}-lib64.patch
+Patch24:       %{name}-phpize.patch
+Patch25:       %{name}-gd_imagerotate_enable.patch
+Patch26:       %{name}-uint32_t.patch
 Icon:          php.gif
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
@@ -126,15 +117,15 @@ BuildRequires:    autoconf >= 2.53
 BuildRequires: automake >= 1.4d
 BuildRequires: bison
 BuildRequires: bzip2-devel
-%{?with_curl:BuildRequires:    curl-devel >= 7.12.0 }
+%{?with_curl:BuildRequires:    curl-devel >= 7.12.0}
 BuildRequires: cyrus-sasl-devel
 %{?with_db3:BuildRequires:     db3-devel >= 3.1}
 %{!?with_db3:BuildRequires:    db-devel >= 4.0}
 BuildRequires: elfutils-devel
-%if %{with xml} || %{with xmlrpc}
+%if %{with wddx} || %{with xmlrpc}
 BuildRequires: expat-devel
-%{?with_fam:BuildRequires:     fam-devel}
 %endif
+%{?with_fam:BuildRequires:     fam-devel}
 %{?with_fdf:BuildRequires:     fdftk-devel}
 BuildRequires: fcgi-devel
 BuildRequires: flex
@@ -145,10 +136,8 @@ BuildRequires:     freetype-devel >= 2.0
 BuildRequires: gd-devel >= 2.0.28-4
 BuildRequires: gdbm-devel
 BuildRequires: gmp-devel
-%{?with_imap:BuildRequires:    imap-devel >= 1:2001-0.BETA.200107022325.2 }
-%{?with_java:BuildRequires:    jdk >= 1.1}
+%{?with_imap:BuildRequires:    imap-devel >= 1:2001-0.BETA.200107022325.2}
 %{?with_cpdf:BuildRequires:    libcpdf-devel >= 2.02r1-2}
-BuildRequires: libgcrypt-devel
 BuildRequires: libidn-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
@@ -156,13 +145,12 @@ BuildRequires:    libmcrypt-devel >= 2.4.4
 BuildRequires: libpng-devel >= 1.0.8
 BuildRequires: libtiff-devel
 BuildRequires: libtool >= 1.4.3
-%{?with_xml:BuildRequires:     libxml2-devel >= 2.5.10}
-%{?with_domxslt:BuildRequires: libxslt-devel >= 1.0.3}
+BuildRequires: libxml2-devel >= 2.5.10
+BuildRequires: libxslt-devel >= 1.0.18
 %{?with_mhash:BuildRequires:   mhash-devel}
 %{?with_ming:BuildRequires:    ming-devel >= 0.1.0}
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
 %{?with_mnogosearch:BuildRequires:     mnogosearch-devel >= 3.2.6}
-%{?with_mono:BuildRequires:    mono-devel}
 BuildRequires: mysql-devel >= 4.0.0
 BuildRequires: ncurses-ext-devel
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.0}
@@ -178,14 +166,12 @@ BuildRequires:    readline-devel
 %{?with_recode:BuildRequires:  recode-devel >= 3.5d-3}
 BuildRequires: rpm-php-pearprov >= 4.0.2-100
 BuildRequires: rpmbuild(macros) >= 1.120
-%{?with_xslt:BuildRequires:    sablotron-devel >= 0.96}
 %{?with_sqlite:BuildRequires:  sqlite-devel}
 BuildRequires: t1lib-devel
 %{?with_tidy:BuildRequires:    tidy-devel}
 %{?with_snmp:BuildRequires:    net-snmp-devel >= 5.0.7}
 %{?with_odbc:BuildRequires:    unixODBC-devel}
 %{?with_xmlrpc:BuildRequires:  xmlrpc-epi-devel}
-%{?with_yaz:BuildRequires:     yaz-devel >= 1.9}
 BuildRequires: zlib-devel >= 1.0.9
 # apache 1.3 vs apache 2.0
 %if %{_apache2}
@@ -524,6 +510,20 @@ file I/O support.
 %description dio -l pl
 Modu³ PHP dodaj±cy obs³ugê bezpo¶rednich operacji I/O na plikach.
 
+%package dom
+Summary:       DOM extension module for PHP
+Summary(pl):   Modu³ DOM dla PHP
+Group:         Libraries
+Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+
+%description dom
+This is a dynamic shared object (DSO) for PHP that will add new DOM
+support.
+
+%description dom -l pl
+Modu³ PHP dodaj±cy now± obs³ugê DOM.
+
 %package exif
 Summary:       exif extension module for PHP
 Summary(pl):   Modu³ exif dla PHP
@@ -645,18 +645,18 @@ length number support with GNU MP library.
 Modu³ PHP umo¿liwiaj±cy korzystanie z biblioteki gmp do obliczeñ na
 liczbach o dowolnej d³ugo¶ci.
 
-%package hyperwave
-Summary:       Hyperwave extension module for PHP
-Summary(pl):   Modu³ Hyperwave dla PHP
+%package hwapi
+Summary:       Hyperwave API extension module for PHP
+Summary(pl):   Modu³ API Hyperwave dla PHP
 Group:         Libraries
 Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 
-%description hyperwave
-This is a dynamic shared object (DSO) for PHP that will add Hyperwave
-support.
+%description hwapi
+This is a dynamic shared object (DSO) for PHP that will add official
+Hyperwave API support.
 
-%description hyperwave -l pl
+%description hwapi -l pl
 Modu³ PHP dodaj±cy obs³ugê Hyperwave.
 
 %package iconv
@@ -706,30 +706,6 @@ and Firebird database support.
 %description interbase -l pl
 Modu³ PHP umo¿liwiaj±cy dostêp do baz danych InterBase i Firebird.
 
-%package java
-Summary:       Java extension module for PHP
-Summary(pl):   Modu³ Javy dla PHP
-Group:         Libraries
-Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-
-%description java
-This is a dynamic shared object (DSO) for PHP that will add Java
-support to PHP. This extension provides a simple and effective means
-for creating and invoking methods on Java objects from PHP.
-
-Note: it requires setting LD_LIBRARY_PATH to JRE directories
-containing JVM libraries (e.g. libjava.so, libverify.so and libjvm.so
-for Sun's JRE) before starting Apache or PHP interpreter.
-
-%description java -l pl
-Modu³ PHP dodaj±cy wsparcie dla Javy. Umo¿liwia odwo³ywanie siê do
-obiektów Javy z poziomu PHP.
-
-Uwaga: modu³ wymaga ustawienia LD_LIBRARY_PATH na katalogi JRE
-zawieraj±ce biblioteki JVM (np. libjava.so, libverify.so i libjvm.so
-dla JRE Suna) przed uruchomieniem Apache'a lub interpretera PHP.
-
 %package ldap
 Summary:       LDAP extension module for PHP
 Summary(pl):   Modu³ LDAP dla PHP
@@ -836,21 +812,6 @@ access mnoGoSearch free search engine.
 Modu³ PHP dodaj±cy pozwalaj±cy na dostêp do wolnodostêpnego silnika
 wyszukiwarki mnoGoSearch.
 
-%package mono
-Summary:       Mono extension module for PHP
-Summary(pl):   Modu³ Mono dla PHP
-Group:         Libraries
-Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-
-%description mono
-This is a dynamic shared object (DSO) for PHP that will allow you to
-access .NET assemblies via free Mono library.
-
-%description mono -l pl
-Modu³ PHP pozwalaj±cy na dostêp do wstawek .NET za pomoc± darmowej
-biblioteki Mono.
-
 %package msession
 Summary:       msession extension module for PHP
 Summary(pl):   Modu³ msession dla PHP
@@ -1130,20 +1091,6 @@ Modu
 
 Uwaga: to jest modu³ eksperymentalny.
 
-%package simplexml
-Summary:       SimpleXML extension module for PHP
-Summary(pl):   Modu³ SimpleXML dla PHP
-Group:         Libraries
-Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-%{common} = %{epoch}:%{version}-%{release}
-
-%description simplexml
-This is a dynamic shared object (DSO) for PHP that will add SimpleXML
-support.
-
-%description simplexml -l pl
-Modu³ PHP dodaj±cy obs³ugê SimpleXML.
-
 %package snmp
 Summary:       SNMP extension module for PHP
 Summary(pl):   Modu³ SNMP dla PHP
@@ -1341,36 +1288,20 @@ Modu
 
 Uwaga: to jest modu³ eksperymentalny.
 
-%package xslt
-Summary:       xslt extension module for PHP
-Summary(pl):   Modu³ xslt dla PHP
+%package xsl
+Summary:       xsl extension module for PHP
+Summary(pl):   Modu³ xsl dla PHP
 Group:         Libraries
 Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      libxslt >= 1.0.18
 
-%description xslt
-This is a dynamic shared object (DSO) for PHP that will add xslt
-support.
+%description xsl
+This is a dynamic shared object (DSO) for PHP that will add new XSL
+support (using libxslt).
 
-%description xslt -l pl
-Modu³ PHP umo¿liwiaj±cy korzystanie z technologii xslt.
-
-%package yaz
-Summary:       yaz extension module for PHP
-Summary(pl):   Modu³ yaz dla PHP
-Group:         Libraries
-Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      yaz >= 1.9
-
-%description yaz
-This is a dynamic shared object (DSO) for PHP that will add yaz
-support. yaz toolkit implements the Z39.50 protocol for information
-retrieval.
-
-%description yaz -l pl
-Modu³ PHP umo¿liwiaj±cy korzystanie z yaz - implementacji protoko³u
-Z39.50 s³u¿±cego do pozyskiwania informacji.
+%description xsl -l pl
+Modu³ PHP dodaj±cy now± obs³ugê XSLT (przy u¿yciu libxslt).
 
 %package yp
 Summary:       NIS (yp) extension module for PHP
@@ -1429,7 +1360,7 @@ php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
 %setup -q
 %patch0 -p1
 %patch1 -p1
-#%patch2 -p1
+%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
@@ -1438,11 +1369,11 @@ php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
 cp php.ini-dist php.ini
-%patch12 -p1
+%patch11 -p1
 # for ac2.53b/am1.6b - AC_LANG_CXX has AM_CONDITIONAL, so cannot be invoked
 # conditionally...
+%patch12 -p1
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
@@ -1453,13 +1384,14 @@ cp php.ini-dist php.ini
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
+%ifarch amd64
 %patch23 -p1
+%endif
 %patch24 -p1
-%ifarch amd64
 %patch25 -p1
-%endif
 %patch26 -p1
-%patch27 -p1
+
+%{?with_hardened:zcat %{SOURCE9} | patch -p1}
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
@@ -1501,6 +1433,7 @@ for i in fcgi cgi cli apxs ; do
        --enable-dba=shared \
        --enable-dbx=shared \
        --enable-dio=shared \
+       --enable-dom=shared \
        --enable-exif=shared \
        --enable-filepro=shared \
        --enable-ftp=shared \
@@ -1514,7 +1447,6 @@ for i in fcgi cgi cli apxs ; do
        --enable-session \
        --enable-shared \
        --enable-shmop=shared \
-       %{?with_simplexml:--enable-simplexml} \
        --enable-sysvmsg=shared \
        --enable-sysvsem=shared \
        --enable-sysvshm=shared \
@@ -1524,17 +1456,14 @@ for i in fcgi cgi cli apxs ; do
        --enable-sockets=shared \
        --enable-ucd-snmp-hack \
        %{?with_wddx:--enable-wddx=shared} \
-       %{!?with_xml:--disable-xml}%{?with_xml:--enable-xml=shared} \
-       %{?with_xslt:--enable-xslt=shared} \
+       --enable-xml=shared \
        --enable-yp=shared \
        --with-bz2=shared \
        %{?with_cpdf:--with-cpdflib=shared} \
        %{!?with_curl:--without-curl}%{?with_curl:--with-curl=shared} \
        %{?with_db3:--with-db3}%{!?with_db3:--with-db4} \
        --with-dbase=shared \
-       %{?with_xml:--with-dom=shared} \
-       %{?with_domxslt:--with-dom-xslt=shared --with-dom-exslt=shared} \
-%if %{with xml} || %{with xmlrpc}
+%if %{with wddx} || %{with xmlrpc}
        --with-expat-dir=shared,/usr \
 %else
        --without-expat-dir \
@@ -1548,10 +1477,9 @@ for i in fcgi cgi cli apxs ; do
        --with-gd=shared,/usr \
        --with-gdbm \
        --with-gmp=shared \
-       %{?with_hyperwave:--with-hwapi=shared} \
+       %{?with_hwapi:--with-hwapi=shared} \
        %{?with_imap:--with-imap=shared --with-imap-ssl} \
        %{?with_interbase:--with-interbase=shared%{!?with_interbase_inst:,/usr}} \
-       %{?with_java:--with-java=/usr/lib/java} \
        --with-jpeg-dir=/usr \
        %{?with_ldap:--with-ldap=shared} \
        --with-mcrypt=shared \
@@ -1560,7 +1488,6 @@ for i in fcgi cgi cli apxs ; do
        %{?with_ming:--with-ming=shared} \
        %{?with_mm:--with-mm} \
        %{!?with_mnogosearch:--without-mnogosearch}%{?with_mnogosearch:--with-mnogosearch=shared,/usr} \
-       %{?with_mono:--with-mono} \
        %{?with_msession:--with-msession=shared}%{!?with_msession:--without-msession} \
        %{?with_mssql:--with-mssql=shared} \
        --with-mysql=shared,/usr \
@@ -1587,14 +1514,10 @@ for i in fcgi cgi cli apxs ; do
        --with-tiff-dir=/usr \
        %{?with_odbc:--with-unixODBC=shared} \
        %{!?with_xmlrpc:--without-xmlrpc}%{?with_xmlrpc:--with-xmlrpc=shared,/usr} \
-       --with-xsl \
-       %{?with_xslt:--with-xslt-sablot=shared} \
-       %{?with_yaz:--with-yaz=shared} \
+       --with-xsl=shared \
        --with-zlib=shared \
        --with-zlib-dir=shared,/usr
 
-#      %{?with_sybase:--with-sybase-ct=shared,/usr --with-sybase=shared,/usr} \
-
 cp -f Makefile Makefile.$i
 # left for debugging purposes
 cp -f main/php_config.h php_config.h.$i
@@ -1647,8 +1570,6 @@ install libs/libphp5.so $RPM_BUILD_ROOT%{_libdir}/apache
 # compatibility (/usr/bin/php used to be CGI SAPI)
 ln -sf php.cli $RPM_BUILD_ROOT%{_bindir}/php
 
-%{?with_java:install ext/java/php_java.jar $RPM_BUILD_ROOT%{extensionsdir}}
-
 install php.ini        $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
 install %{SOURCE6} %{SOURCE7} %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}
 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
@@ -1781,6 +1702,14 @@ if [ "$1" = "0" ]; then
        %{_sbindir}/php-module-install remove dio %{_sysconfdir}/php.ini
 fi
 
+%post dom
+%{_sbindir}/php-module-install install dom %{_sysconfdir}/php.ini
+
+%preun dom
+if [ "$1" = "0" ]; then
+       %{_sbindir}/php-module-install remove dom %{_sysconfdir}/php.ini
+fi
+
 %post exif
 %{_sbindir}/php-module-install install exif %{_sysconfdir}/php.ini
 
@@ -1845,12 +1774,12 @@ if [ "$1" = "0" ]; then
        %{_sbindir}/php-module-install remove gmp %{_sysconfdir}/php.ini
 fi
 
-%post hyperwave
-%{_sbindir}/php-module-install install hyperwave %{_sysconfdir}/php.ini
+%post hwapi
+%{_sbindir}/php-module-install install hwapi %{_sysconfdir}/php.ini
 
-%preun hyperwave
+%preun hwapi
 if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove hyperwave %{_sysconfdir}/php.ini
+       %{_sbindir}/php-module-install remove hwapi %{_sysconfdir}/php.ini
 fi
 
 %post iconv
@@ -1877,14 +1806,6 @@ if [ "$1" = "0" ]; then
        %{_sbindir}/php-module-install remove interbase %{_sysconfdir}/php.ini
 fi
 
-%post java
-%{_sbindir}/php-module-install install java %{_sysconfdir}/php.ini
-
-%preun java
-if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove java %{_sysconfdir}/php.ini
-fi
-
 %post ldap
 %{_sbindir}/php-module-install install ldap %{_sysconfdir}/php.ini
 
@@ -1941,14 +1862,6 @@ if [ "$1" = "0" ]; then
        %{_sbindir}/php-module-install remove mnogosearch %{_sysconfdir}/php.ini
 fi
 
-%post mono
-%{_sbindir}/php-module-install install mono %{_sysconfdir}/php.ini
-
-%preun mono
-if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove mono %{_sysconfdir}/php.ini
-fi
-
 %post msession
 %{_sbindir}/php-module-install install msession %{_sysconfdir}/php.ini
 
@@ -2115,14 +2028,6 @@ if [ "$1" = "0" ]; then
        %{_sbindir}/php-module-install remove shmop %{_sysconfdir}/php.ini
 fi
 
-%post simplexml
-%{_sbindir}/php-module-install install simplexml %{_sysconfdir}/php.ini
-
-%preun simplexml
-if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove simplexml %{_sysconfdir}/php.ini
-fi
-
 %post snmp
 %{_sbindir}/php-module-install install snmp %{_sysconfdir}/php.ini
 
@@ -2211,20 +2116,12 @@ if [ "$1" = "0" ]; then
        %{_sbindir}/php-module-install remove xmlrpc %{_sysconfdir}/php.ini
 fi
 
-%post xslt
-%{_sbindir}/php-module-install install xslt %{_sysconfdir}/php.ini
-
-%preun xslt
-if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove xslt %{_sysconfdir}/php.ini
-fi
-
-%post yaz
-%{_sbindir}/php-module-install install yaz %{_sysconfdir}/php.ini
+%post xsl
+%{_sbindir}/php-module-install install xsl %{_sysconfdir}/php.ini
 
-%preun yaz
+%preun xsl
 if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove yaz %{_sysconfdir}/php.ini
+       %{_sbindir}/php-module-install remove xsl %{_sysconfdir}/php.ini
 fi
 
 %post yp
@@ -2338,6 +2235,10 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/dio.so
 
+%files dom
+%defattr(644,root,root,755)
+%attr(755,root,root) %{extensionsdir}/dom.so
+
 %if %{with fam}
 %files fam
 %defattr(644,root,root,755)
@@ -2374,10 +2275,10 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/gmp.so
 
-%if %{with hyperwave}
-%files hyperwave
+%if %{with hwapi}
+%files hwapi
 %defattr(644,root,root,755)
-%attr(755,root,root) %{extensionsdir}/hyperwave.so
+%attr(755,root,root) %{extensionsdir}/hwapi.so
 %endif
 
 %files iconv
@@ -2396,13 +2297,6 @@ fi
 %attr(755,root,root) %{extensionsdir}/interbase.so
 %endif
 
-%if %{with java}
-%files java
-%defattr(644,root,root,755)
-%attr(755,root,root) %{extensionsdir}/java.so
-%{extensionsdir}/php_java.jar
-%endif
-
 %if %{with ldap}
 %files ldap
 %defattr(644,root,root,755)
@@ -2439,12 +2333,6 @@ fi
 %attr(755,root,root) %{extensionsdir}/mnogosearch.so
 %endif
 
-%if %{with mono}
-%files mono
-%defattr(644,root,root,755)
-%attr(755,root,root) %{extensionsdir}/mono.so
-%endif
-
 %if %{with msession}
 %files msession
 %defattr(644,root,root,755)
@@ -2586,18 +2474,9 @@ fi
 %attr(755,root,root) %{extensionsdir}/wddx.so
 %endif
 
-%if %{with xml}
 %files xml
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/xml.so
-%endif
-
-# FIXME: build as shared module
-%if 0 && %{with simplexml}
-%files simplexml
-%defattr(644,root,root,755)
-%attr(755,roor,root) %{extensionsdir}/simplexml.so
-%endif
 
 %if %{with xmlrpc}
 %files xmlrpc
@@ -2605,17 +2484,9 @@ fi
 %attr(755,root,root) %{extensionsdir}/xmlrpc.so
 %endif
 
-%if %{with xslt}
-%files xslt
+%files xsl
 %defattr(644,root,root,755)
-%attr(755,root,root) %{extensionsdir}/xslt.so
-%endif
-
-%if %{with yaz}
-%files yaz
-%defattr(644,root,root,755)
-%attr(755,root,root) %{extensionsdir}/yaz.so
-%endif
+%attr(755,root,root) %{extensionsdir}/xsl.so
 
 %files yp
 %defattr(644,root,root,755)
This page took 0.064459 seconds and 4 git commands to generate.