]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- up to 5.4.0RC7
[packages/php.git] / php.spec
index 972985a0dc738b1fb173dd169c368db31958cce8..c00b5264ce5942187c4719303d37420187bdb4a3 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -6,9 +6,10 @@
 # - update imap annotations patch (needs api porting)
 # - update imap myrights patch (needs api porting)
 # - dba: enable: --with-tcadb=DIR        DBA: Tokyo Cabinet abstract DB support
-# - --with-vpx-dir=DIR     GD: Set the path to libvpx install prefix
 # --with-libmbfl=DIR      MBSTRING: Use external libmbfl.  DIR is the libmbfl base install directory BUNDLED
-# --with-onig=DIR         MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.  
+# --with-onig=DIR         MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
+# - recheck: define PDO_MYSQL_UNIX_ADDR (ensure if's correct with mysql-libs and mysqlng)
+# - uses libvpx for webp support, should use libwebp-devel instead?
 # NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
 # UNPACKAGED EXTENSION NOTES:
 # - com_dotnet is Win32-only
@@ -77,7 +78,7 @@
 %bcond_with    zts             # Zend Thread Safety
 %bcond_without cgi             # disable CGI/FCGI SAPI
 %bcond_without fpm             # disable FPM
-%bcond_without embed           # disable Embedded API
+%bcond_with    embed           # disable Embedded API
 %bcond_with    suhosin         # with suhosin patch
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    gcov            # Enable Code coverage reporting
@@ -121,7 +122,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     0.3
+%define                rel     0.8
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -135,8 +136,8 @@ Epoch:              4
 License:       PHP
 Group:         Libraries
 #Source0:      http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-Source0:       http://downloads.php.net/stas/%{name}-%{version}alpha3.tar.bz2
-# Source0-md5: 68f277b9be92e51931ab1d705e7c6bde
+Source0:       http://downloads.php.net/stas/%{name}-%{version}RC7.tar.bz2
+# Source0-md5: 83e759b0eb87ebdf0124d64361daaf54
 Source2:       %{name}-mod_%{name}.conf
 Source3:       %{name}-cgi-fcgi.ini
 Source4:       %{name}-apache.ini
@@ -200,12 +201,12 @@ Patch50:  extension-shared-optional-dep.patch
 Patch51:       spl-shared.patch
 Patch52:       pcre-shared.patch
 Patch53:       fix-test-run.patch
-Patch54:       mysqlnd-shared.patch
+#Patch54:      mysqlnd-shared.patch # shared build supported upstream
 Patch55:       bug-52078-fileinode.patch
-Patch57:       bug-52448.patch
+#Patch57:      bug-52448.patch # outdated
 Patch59:       %{name}-systzdata.patch
 Patch60:       %{name}-oracle-instantclient.patch
-Patch61:       %{name}-krb5-ac.patch
+#Patch61:      %{name}-krb5-ac.patch # not needed on 5.4 anymore
 Patch62:       mcrypt-libs.patch
 Patch63:       %{name}-mysql-nowarning.patch
 #Patch64:      %{name}-m4.patch # not needed on 5.4 branch
@@ -247,6 +248,8 @@ BuildRequires:      libltdl-devel >= 1.4
 BuildRequires: libmcrypt-devel >= 2.4.4
 BuildRequires: libpng-devel >= 1.0.8
 #BuildRequires:        libtiff-devel
+BuildRequires: libvpx-devel
+BuildRequires: tokyocabinet-devel
 %if "%{pld_release}" != "ac"
 BuildRequires: libtool >= 2:2.2
 %else
@@ -1515,6 +1518,7 @@ Group:            Libraries
 URL:           http://www.php.net/manual/en/book.snmp.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-sockets = %{epoch}:%{version}-%{release}
+Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
 Provides:      php(snmp)
 
 %description snmp
@@ -1850,9 +1854,9 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
-%setup -q -n %{name}-%{version}alpha3
+%setup -q -n %{name}-%{version}RC7
 # prep for suhosin patch
-%{__sed} -i -e 's,\r$,,' Zend/Zend.dsp Zend/ZendTS.dsp
+%undos Zend/Zend.dsp Zend/ZendTS.dsp
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -1907,13 +1911,10 @@ cp -p php.ini-production php.ini
 %patch51 -p1
 %patch52 -p1
 %patch53 -p1
-%patch54 -p1
 %undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
 %patch55 -p1
-%patch57 -p1
 %patch59 -p1
 %patch60 -p1
-%patch61 -p1
 %patch62 -p1
 %patch63 -p1
 %{?with_system_libzip:%patch65 -p1}
@@ -1962,7 +1963,7 @@ mv sapi/cli/tests/022.phpt{,.broken}
 # probably pointless.
 %{__rm} ext/standard/tests/file/disk_free_space_basic.phpt
 
-sh -xe %{_sourcedir}/skip-tests.sh
+#sh -xe %{_sourcedir}/skip-tests.sh
 
 %build
 API=$(awk '/#define PHP_API_VERSION/{print $3}' main/php.h)
@@ -2148,6 +2149,7 @@ for sapi in $sapis; do
        %{?with_odbc:--with-pdo-odbc=shared,unixODBC,/usr} \
        %{?with_pgsql:--with-pdo-pgsql=shared} \
        %{?with_pdo_sqlite:--with-pdo-sqlite=shared,/usr} \
+       --with-vpx-dir=/usr \
        --without-libexpat-dir \
        --enable-posix=shared \
        --enable-shared \
@@ -2186,6 +2188,7 @@ for sapi in $sapis; do
        %{?with_oci8:--with-oci8=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
        %{?with_openssl:--with-openssl=shared} \
        %{?with_kerberos5:--with-kerberos} \
+       --with-tcadb=/usr \
        %{__with_without pcre pcre-regex /usr} \
        %{__enable_disable filter filter shared} \
        --with-pear=%{php_pear_dir} \
This page took 0.041655 seconds and 4 git commands to generate.