]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- rel 49; fixed icu build
[packages/php.git] / php.spec
index b9a916aba6e1ff6426593743753bad38061547f6..b33173139ad739b2f06f1dce834df2b9af26ef25 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -38,6 +38,7 @@
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    type_hints      # experimental support for strict typing/casting
 %bcond_with    zts             # Zend Thread Safety
+%bcond_with    debug           # Zend Debug Build
 # - SAPI
 %bcond_without apache1         # disable building Apache 1.3.x SAPI
 %bcond_without apache2         # disable building Apache 2.x SAPI
@@ -142,7 +143,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_alternatives
 %endif
 
-%define                rel     34
+%define                rel     49
 %define                orgname php
 %define                ver_suffix 53
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -246,6 +247,10 @@ Patch71:   php-fileinfo.patch
 # Patch71-md5:  771e4934132c5f5c968248c954d1ef6e
 Patch72:       x32-suhosin.patch
 Patch73:       php-bug-68486.patch
+Patch74:       mysqli-err.patch
+Patch75:       openssl.patch
+Patch76:       php-bug-61930.patch
+Patch77:       php-icu64.patch
 # Fixes for security bugs
 # https://repo.webtatic.com/yum/centos/5/SRPMS/repoview/php.html
 # also from RHEL6/CentOS7
@@ -266,6 +271,7 @@ Patch258:   php-5.3.29-CVE-2015-0232.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
+BuildRequires: apache-base
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1.4d
 BuildRequires: bison
@@ -277,9 +283,11 @@ BuildRequires:     elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
 BuildRequires: file
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
+BuildRequires: libatomic-devel
 %{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10-3}
 BuildRequires: mysql-devel
 BuildRequires: pkgconfig
+BuildRequires: re2c
 BuildRequires: sed >= 4.0
 %if %{with mssql} || %{with sybase_ct}
 BuildRequires: freetds-devel >= 0.82
@@ -365,7 +373,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                zipver          1.11.0
 
 %define                zend_zts                %{!?with_zts:0}%{?with_zts:1}
-%define                php_debug               %{!?debug:0}%{?debug:1}
+%define                php_debug               %{!?with_debug:0}%{?with_debug:1}
 
 %if %{with gcov}
 %undefine      with_ccache
@@ -665,6 +673,8 @@ Obsoletes:  php55-devel
 Obsoletes:     php56-devel
 Obsoletes:     php70-devel
 Obsoletes:     php71-devel
+Obsoletes:     php72-devel
+Obsoletes:     php73-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -2137,6 +2147,10 @@ gzip -dc %{SOURCE15} | tar xf - -C sapi/
 %patch70 -p1
 %patch71 -p1
 %patch73 -p1
+%patch74 -p1
+%patch75 -p1
+%patch76 -p1
+%patch77 -p1
 
 %patch220 -p1
 
@@ -2293,7 +2307,7 @@ if [ ! -f _built-conf ]; then
        touch _built-conf
 fi
 export PROG_SENDMAIL="/usr/lib/sendmail"
-export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP %{rpmcppflags} -I%{_includedir}/xmlrpc-epi"
+export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP -DOPENSSL_NO_SSL2=1 -DOPENSSL_NO_SSL3=1 %{rpmcppflags} -I%{_includedir}/xmlrpc-epi"
 %if %{with lfs}
 CPPFLAGS="$CPPFLAGS $(getconf LFS_CFLAGS)"
 %endif
@@ -2362,7 +2376,7 @@ for sapi in $sapis; do
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-exec-dir=%{_bindir} \
        --with-system-tzdata \
-       --%{!?debug:dis}%{?debug:en}able-debug \
+       --%{!?with_debug:dis}%{?with_debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-inline-optimization \
        --enable-bcmath=shared \
This page took 0.036319 seconds and 4 git commands to generate.