]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- up to 5.1.2 snap; 5.1.1 is too broken
[packages/php.git] / php.spec
index f1ab33d67f057fcee569306c498d9b156ba8eb02..9a2cc6bbe1828b36e57b8a014c81af87b3c6d084 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -8,11 +8,12 @@
 #   (existing only in php4):
 #   db, hyperwave, java, mcal, overload, qtdom
 #   and removed from php 5.1:
-#   cpdf, dio, dbx, fam, yp, oracle
+#   cpdf, fam, yp, oracle
 # - mime_magic can't handle new "string/*" entries in magic.mime
 # - make additional headers added by mail patch configurable
 # - apply -hardened patch by default ?
 # - modularize session, standard (output from pure php -m)?
+# - fix reflection module to build it statically
 #
 # Conditional build:
 %bcond_with    db3             # use db3 packages instead of db (4.x) for Berkeley DB support
@@ -78,14 +79,15 @@ Summary(pt_BR):     A linguagem de script PHP
 Summary(ru):   PHP ÷ÅÒÓÉÉ 5 - ÑÚÙË ÐÒÅÐÒÏÃÅÓÓÉÒÏ×ÁÎÉÑ HTML-ÆÁÊÌÏ×, ×ÙÐÏÌÎÑÅÍÙÊ ÎÁ ÓÅÒ×ÅÒÅ
 Summary(uk):   PHP ÷ÅÒÓ¦§ 5 - ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
-Version:       5.1.1
-%define        _rel 4
+Version:       5.1.2
+%define        _rel 0.1
 Release:       %{_rel}%{?with_hardening:hardened}
 Epoch:         4
-Group:         Libraries
 License:       PHP
-Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: 70a7c90de182d1a1901c390b844153c7
+Group:         Libraries
+# Source0:     http://www.php.net/distributions/%{name}-%{version}.tar.bz2
+Source0:       http://snaps.php.net/php5.1-200601031130.tar.bz2
+# Source0-md5: f47e4528c30fb9865bebdd2ebbf66c8f
 Source1:       FAQ.%{name}
 Source2:       zend.gif
 Source3:       %{name}-module-install
@@ -151,6 +153,7 @@ BuildRequires:      gmp-devel
 %{?with_imap:BuildRequires:    imap-devel >= 1:2001-0.BETA.200107022325.2}
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
+BuildRequires: libmbfl-devel
 BuildRequires: libmcrypt-devel >= 2.4.4
 BuildRequires: libpng-devel >= 1.0.8
 BuildRequires: libtiff-devel
@@ -282,8 +285,8 @@ Requires:   %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      apache1(EAPI) >= 1.3.33-2
 Requires:      apache1-mod_mime
 Provides:      php = %{epoch}:%{version}-%{release}
-Obsoletes:     phpfi
 Obsoletes:     apache-mod_php < 1:4.1.1
+Obsoletes:     phpfi
 
 %description -n apache1-mod_php
 PHP as DSO module for apache 1.3.x.
@@ -296,11 +299,10 @@ Summary:  PHP DSO module for apache 2.x
 Summary(pl):   Modu³ DSO (Dynamic Shared Object) php dla apache 2.x
 Group:         Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      apache(modules-api) = %{apache_modules_api}
 Requires:      apache >= 2.2.0
+Requires:      apache(modules-api) = %{apache_modules_api}
 Provides:      php = %{epoch}:%{version}-%{release}
 Obsoletes:     phpfi
-Obsoletes:     apache-mod_php < 1:4.1.1
 
 %description -n apache-mod_php
 PHP as DSO module for apache 2.x.
@@ -374,10 +376,11 @@ Provides: %{name}-simplexml = %{epoch}:%{version}-%{release}
 Provides:      %{name}-spl = %{epoch}:%{version}-%{release}
 Provides:      %{name}-standard = %{epoch}:%{version}-%{release}
 Provides:      php(modules_api) = %{php_api_version}
-Provides:      php(zend_module_api) = %{zend_module_api}
 Provides:      php(zend_extension_api) = %{zend_extension_api}
+Provides:      php(zend_module_api) = %{zend_module_api}
 Provides:      php5(debug) = %{php_debug}
 Provides:      php5(thread-safety) = %{zend_zts}
+Obsoletes:     php-pecl-domxml
 Obsoletes:     php-session < 3:4.2.1-2
 # for the posttrans scriptlet, conflicts because in vserver enviroinment rpm package is not installed.
 Conflicts:     rpm < 4.4.2-0.2
@@ -1021,6 +1024,17 @@ FreeTDS support.
 Modu³ dla PHP dodaj±cy obs³ugê baz danych FreeTDS za po¶rednictwem
 interfejsu PDO.
 
+%package pdo-firebird
+Summary:       PHP Data Objects (PDO) Firebird support
+Group:         Libraries
+Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      %{name}-pdo = %{epoch}:%{version}-%{release}
+
+%description pdo-firebird
+This is a dynamic shared object (DSO) for PHP that will add PDO
+Firebird support.
+
 %package pdo-mysql
 Summary:       PHP Data Objects (PDO) MySQL support
 Summary(pl):   Modu³ PHP Data Objects (PDO) z obs³ug± MySQL-a
@@ -1277,6 +1291,7 @@ Summary(pl):      Modu
 Group:         Libraries
 Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      %{name}-pdo = %{epoch}:%{version}-%{release}
 
 %description sqlite
 SQLite is a C library that implements an embeddable SQL database
@@ -1507,7 +1522,7 @@ compression support to PHP.
 Modu³ PHP umo¿liwiaj±cy u¿ywanie kompresji zlib.
 
 %prep
-%setup -q
+%setup -q -n php5.1-200601031130
 # this patch is broken by design, breaks --enable-versioning for example
 # update: --enable-version is broken by itself, it disables dynamic modules.
 %patch0 -p1
@@ -1550,6 +1565,21 @@ rm -f ext/recode/config9.m4
 # new apr
 sed -i -e 's#apr-config#apr-1-config#g' sapi/apache*/*.m4
 
+# remove all bundled libraries not to link with them accidentally
+#rm -rf ext/sqlite/libsqlite
+#rm -rf ext/bcmath/libbcmath
+#rm -rf ext/date/lib
+#rm -rf ext/dba/libcdb
+#rm -rf ext/dba/libflatfile
+#rm -rf ext/dba/libinifile
+#rm -rf ext/gd/libgd
+#rm -rf ext/mbstring/libmbfl
+#rm -rf ext/mbstring/oniguruma
+rm -rf ext/pcre/pcrelib
+rm -rf ext/pdo_sqlite/sqlite
+#rm -rf ext/soap/interop
+rm -rf ext/xmlrpc/libxmlrpc
+
 %build
 if API=$(awk '/#define PHP_API_VERSION/{print $3}' main/php.h) && [ $API != %{php_api_version} ]; then
        echo "Set %%define php_api_version to $API and rerun."
@@ -1625,7 +1655,6 @@ for sapi in $sapis; do
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-exec-dir=%{_bindir} \
        --%{!?debug:dis}%{?debug:en}able-debug \
-       --enable-zend-multibyte \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-memory-limit \
        --enable-bcmath=shared \
@@ -1656,8 +1685,9 @@ for sapi in $sapis; do
        %{?with_oci8:--with-pdo-oci=shared} \
        %{?with_odbc:--with-pdo-odbc=shared,unixODBC,/usr} \
        %{?with_pgsql:--with-pdo-pgsql=shared} \
-       %{?with_sqlite:--with-pdo-sqlite=shared} \
+       %{?with_sqlite:--with-pdo-sqlite=shared,/usr} \
        --enable-posix=shared \
+       --disable-reflection \
        --enable-session \
        --enable-shared \
        --enable-shmop=shared \
@@ -1674,7 +1704,7 @@ for sapi in $sapis; do
        --enable-ucd-snmp-hack \
        %{?with_wddx:--enable-wddx=shared} \
        --enable-xml=shared \
-       --with-xmlreader=shared \
+       --enable-xmlreader=shared \
        --with-bz2=shared \
        %{!?with_curl:--without-curl}%{?with_curl:--with-curl=shared} \
        %{?with_db3:--with-db3}%{!?with_db3:--with-db4} \
@@ -2214,6 +2244,12 @@ fi
 %postun pdo-dblib
 %extension_postun
 
+%post pdo-firebird
+%extension_post
+
+%postun pdo-firebird
+%extension_postun
+
 %post pdo-mysql
 %extension_post
 
@@ -2847,6 +2883,13 @@ fi
 %attr(755,root,root) %{extensionsdir}/pdo_dblib.so
 %endif
 
+%if %{with interbase} && %{without interbase_inst}
+%files pdo-firebird
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/pdo_firebird.ini
+%attr(755,root,root) %{extensionsdir}/pdo_firebird.so
+%endif
+
 %files pdo-mysql
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/pdo_mysql.ini
This page took 0.035716 seconds and 4 git commands to generate.