]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- rebuild with net-snmp 5.8
[packages/php.git] / php.spec
index d4acb838198db896439a83fce3ba4a3f2715eefa..996a1b0c6ccacb10f01f9601205fed115148681e 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -43,7 +43,7 @@
 %bcond_without alternatives    # use alternatives system to select default phar and php-fpm
 %bcond_with    default_php     # build this PHP as default PHP in system (disables alternatives)
 # - General options:
-%bcond_without embed           # disable building Embedded API
+%bcond_with    embed           # disable building Embedded API
 %bcond_with    gcov            # Enable Code coverage reporting
 %bcond_without kerberos5       # without Kerberos5 support
 %bcond_with    suhosin         # with suhosin patch, has little point in PHP>=5.3, see https://github.com/stefanesser/suhosin/issues/42#issuecomment-41728178
@@ -138,7 +138,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     14
+%define                rel     21
 %define                orgname php
 %define                ver_suffix 54
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -232,6 +232,7 @@ Patch67:    mysql-lib-ver-mismatch.patch
 Patch68:       x32.patch
 Patch70:       libvpx2.patch
 Patch71:       zend_operators_from_5.5.patch
+Patch72:       mysqli-err.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -608,6 +609,7 @@ Obsoletes:  php55-devel
 Obsoletes:     php56-devel
 Obsoletes:     php70-devel
 Obsoletes:     php71-devel
+Obsoletes:     php72-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -1973,6 +1975,7 @@ cp -p php.ini-production php.ini
 # asm part of zend_operators.h of php-5.5
 %patch71 -p1
 %endif
+%patch72 -p1
 
 %{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -2514,10 +2517,9 @@ touch $RPM_BUILD_ROOT%{_sbindir}/php-fpm
 
 # install Embedded API
 %if %{with embed}
+%{__make} -f Makefile.embed install-sapi INSTALL_ROOT=$RPM_BUILD_ROOT
 # we could use install-headers from Makefile.embed, but that would reinstall all headers
-# install-sapi installs to wrong dir, so just do it all manually
 install -d $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
-install -p libs/libphp5.so $RPM_BUILD_ROOT%{_libdir}
 cp -p sapi/embed/php_embed.h $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
 %endif
 
@@ -2586,6 +2588,10 @@ cp -a tests/* $RPM_BUILD_ROOT%{php_data_dir}/tests/php
 
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common.la
+%if %{with embed}
+# libphp5.la contains our buildroot in dependency_libs
+sed -i -e "/dependency_libs/ s,/[^ ]*/libs/libphp_common.la,%{_libdir}/libphp_common.la," $RPM_BUILD_ROOT%{_libdir}/libphp5.la
+%endif
 # better solution?
 sed -i -e 's|libphp_common.la|$(libdir)/libphp_common.la|' $RPM_BUILD_ROOT%{_libdir}/%{name}/build/acinclude.m4
 
@@ -2820,7 +2826,7 @@ fi
 %if %{with embed}
 %files embedded
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libphp5.so
+%attr(755,root,root) %{_libdir}/libphp5-%{version}.so
 %endif
 
 %files cli
@@ -2872,6 +2878,11 @@ fi
 %{_libdir}/%{name}/build
 %{_mandir}/man1/php-config.1*
 %{_mandir}/man1/phpize.1*
+%if %{with embed}
+# embedded
+%{_libdir}/libphp5.so
+%{_libdir}/libphp5.la
+%endif
 
 %files bcmath
 %defattr(644,root,root,755)
This page took 0.055373 seconds and 4 git commands to generate.