]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- fixed previous commit (pl %description for litespeed)
[packages/php.git] / php.spec
index 4310de32bb71a557bae0332c029744ef6c834e3d..9856d07265e656e267cafff900b178fc9b5578f5 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -48,6 +48,7 @@
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_with    system_gd       # with system gd (we prefer internal since it enables few more features)
+%bcond_with    litespeed       # build litespeed module
 %bcond_without curl            # without CURL extension module
 %bcond_without filter          # without filter extension module
 %bcond_without imap            # without IMAP extension module
@@ -348,6 +349,20 @@ PHP as DSO module for apache 2.x.
 %description -n apache-mod_php -l pl.UTF-8
 php jako moduĊ‚ DSO (Dynamic Shared Object) dla apache 2.x.
 
+%package litespeed
+Summary:       PHP for litespeed http server
+Summary(pl.UTF-8):     PHP dla serwera http litespeed
+Group:         Development/Languages/PHP
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      litespeed
+Provides:      webserver(php) = %{version}
+
+%description litespeed
+PHP for litespeed http server.
+
+%description litespeed -l pl.UTF-8
+PHP dla serwera http litespeed.
+
 %package cgi
 Summary:       PHP as CGI/FastCGI program
 Summary(pl.UTF-8):     PHP jako program CGI/FastCGI
@@ -1812,6 +1827,9 @@ apxs1
 %if %{with apache2}
 apxs2
 %endif
+%if %{with litespeed}
+litespeed
+%endif
 "
 for sapi in $sapis; do
        : SAPI $sapi
@@ -1837,6 +1855,9 @@ for sapi in $sapis; do
                ver=$(rpm -q --qf '%{V}' apache-devel)
                sapi_args="--disable-cli --with-apxs2=%{apxs2} --with-apache-version=$ver"
        ;;
+       litespeed)
+               sapi_args='--with-litespeed'
+       ;;
        esac
 
        %configure \
@@ -1977,6 +1998,10 @@ sed -i -e "s,@PHP_INSTALLED_SAPIS@,$sapis," "scripts/php-config.in"
 %{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache2handler/libphp5.la -f Makefile.apxs2
 %endif
 
+%if %{with litespeed}
+%{__make} -f Makefile.litespeed
+%endif
+
 # CGI/FCGI
 cp -af php_config.h.cgi-fcgi main/php_config.h
 %{__make} -f Makefile.cgi-fcgi
@@ -2022,6 +2047,11 @@ libtool --silent --mode=install install sapi/apache/libphp5.la $RPM_BUILD_ROOT%{
 libtool --silent --mode=install install sapi/apache2handler/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache
 %endif
 
+# install litespeed sapi
+%if %{with litespeed}
+libtool --silent --mode=install install sapi/litespeed/php $RPM_BUILD_ROOT%{_bindir}/php.litespeed
+%endif
+
 libtool --silent --mode=install install libphp_common.la $RPM_BUILD_ROOT%{_libdir}
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common.la
@@ -2440,6 +2470,12 @@ fi
 %attr(755,root,root) %{_libdir}/apache/libphp5.so
 %endif
 
+%if %{with litespeed}
+%files litespeed
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/php.litespeed
+%endif
+
 %files cgi
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/cgi-fcgi.d
This page took 0.100979 seconds and 4 git commands to generate.