]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- no more phpfi
[packages/php.git] / php.spec
index 381bec545e5adda59617b841788eba2df1c91b2e..903290ea91bb40382ee6558e1463d4a8d20a9738 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -9,6 +9,8 @@
 #   db, hyperwave, java, mcal, overload, qtdom
 #   and removed from php 5.1:
 #   cpdf, fam, yp, oracle
+#   and removed from php 5.1.3:
+#   msession
 #   and removed from php 5.2:
 #   filepro, hw
 # - mime_magic can't handle new "string/*" entries in magic.mime
@@ -68,7 +70,7 @@
 ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 
-%define        _rel 0.14
+%define        _rel 0.20
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr):   Le langage de script embarque-HTML PHP
 Summary(pl):   Jêzyk skryptowy PHP
@@ -98,12 +100,14 @@ Patch1:            %{name}-pldlogo.patch
 Patch2:                %{name}-mail.patch
 Patch3:                %{name}-link-libs.patch
 Patch4:                %{name}-libpq_fs_h_path.patch
+Patch5:                %{name}-filter-shared.patch
 Patch6:                %{name}-build_modules.patch
 Patch7:                %{name}-sapi-ini-file.patch
 Patch8:                %{name}-no-metaccld.patch
-
+Patch9:                %{name}-sh.patch
 Patch10:       %{name}-ini.patch
 Patch11:       %{name}-acam.patch
+Patch12:       %{name}-curl.patch
 Patch14:       %{name}-allow-db31.patch
 Patch15:       %{name}-threads-acfix.patch
 Patch16:       %{name}-tsrmlsfetchgcc2.patch
@@ -123,6 +127,7 @@ Patch35:    %{name}-versioning.patch
 Patch36:       %{name}-linkflags-clean.patch
 Patch38:       %{name}-amd64.patch
 Patch39:       %{name}-pear.patch
+Patch40:       %{name}-db4.5.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -213,11 +218,7 @@ database-enabled web page with PHP is fairly simple. The most common
 use of PHP coding is probably as a replacement for CGI scripts. The
 mod_php module enables the Apache web server to understand and process
 the embedded PHP language in web pages. This package contains php
-version %{version}. If you use applications which specifically rely on
-PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
-module contained in the phpfi package. If you're just starting with
-PHP, you should install this package. You'll also need to install the
-Apache web server.
+version %{version}.
 
 %description -l fr
 PHP est un langage de script embarque dans le HTM. PHP essaye de
@@ -229,11 +230,7 @@ des bases de donnees. L'utilisation la plus commune de PHP est
 probablement en remplacement de scripts CGI. Le module mod_php permet
 au serveur web apache de comprendre et de traiter le langage PHP
 integre dans des pages web. Ce package contient php version
-%{version}. Si vous utilisez des applications qui utilisent
-specifiquement PHP/FI, vous devrez installer le module PHP/FI inclus
-dans le package mod_php. Si vous debutez avec PHP, vous devriez
-installer ce package. Vous aurez egalement besoin dinstaller le
-serveur web Apache.
+%{version}.
 
 %description -l pl
 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w
@@ -600,6 +597,27 @@ library.
 Modu³ PHP dodaj±cy obs³ugê formularzy PDF poprzez bibliotekê Adobe
 FDFTK.
 
+%package filter
+Summary:       extension for safely dealing with input parameters
+Summary(pl):   rozszerzenie do bezpiecznej obs³ugi danych wej¶ciowych
+Group:         Libraries
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(filter)
+
+%description filter
+We all know that you should always check input variables, but PHP does
+not offer really good functionality for doing this in a safe way. The
+Input Filter extension is meant to address this issue by implementing
+a set of filters and mechanisms that users can use to safely access
+their input data.
+
+%description filter -l pl
+Wiadomo, ¿e trzeba zawsze sprawdzaæ zmienne wej¶ciowe, ale PHP nie
+oferuje naprawdê dobrej funkcjonalno¶ci do robienia tego w sposób
+bezpieczny. Rozszerzenie Input Filter ma rozwi±zaæ ten problem poprzez
+zaimplementowanie zestawu filtrów i mechanizmów, których u¿ytkownicy
+mog± bezpiecznie u¿ywaæ do dostêpu do danych.
+
 %package ftp
 Summary:       FTP extension module for PHP
 Summary(pl):   Modu³ FTP dla PHP
@@ -1531,16 +1549,18 @@ Modu
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-
+%patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 cp php.ini-dist php.ini
 %patch10 -p1
 # for ac2.53b/am1.6b - AC_LANG_CXX has AM_CONDITIONAL, so cannot be invoked
 # conditionally...
 %patch11 -p1
+%patch12 -p1
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
@@ -1565,6 +1585,7 @@ patch -p1 < %{PATCH30} || exit 1
 %patch38 -p1
 %endif
 %patch39 -p1
+%patch40 -p1
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
@@ -1741,7 +1762,7 @@ for sapi in $sapis; do
        %{?with_oci8:--with-oci8=shared} \
        %{?with_openssl:--with-openssl=shared} \
        --with-kerberos \
-       %{!?with_pcre:--without-pcre-regex --disable-filter}%{?with_pcre:--with-pcre-regex=/usr} \
+       %{!?with_pcre:--without-pcre-regex --disable-filter}%{?with_pcre:--with-pcre-regex=/usr --enable-filter=shared} \
        --with-pear=%{php_pear_dir} \
        %{!?with_pgsql:--without-pgsql}%{?with_pgsql:--with-pgsql=shared,/usr} \
        --with-png-dir=/usr \
@@ -1983,6 +2004,7 @@ fi
 %extension_scripts dom
 %extension_scripts exif
 %extension_scripts fdf
+%extension_scripts filter
 %extension_scripts ftp
 %extension_scripts gd
 %extension_scripts gettext
@@ -2330,6 +2352,11 @@ fi
 %attr(755,root,root) %{extensionsdir}/fdf.so
 %endif
 
+%files filter
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/filter.ini
+%attr(755,root,root) %{extensionsdir}/filter.so
+
 %files exif
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/exif.ini
@@ -2556,7 +2583,9 @@ fi
 %endif
 
 %if 0
-# simplexml is needed by spl, and spl can't be built shared as of now (5.1.0RC3)
+# simplexml is needed by spl, and spl can't be built shared as of now (5.2.0)
+# simplexml can be built shared, but SPL startup fails
+# we could add R: -simplexml to -common...
 %files simplexml
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/simplexml.ini
This page took 0.082634 seconds and 4 git commands to generate.