]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- release 2, rebuild against icu 64
[packages/php.git] / php.spec
index 9af3c603f6ff594ac8ed5cb0b9487fb17ff2c8cd..77a692011c7e2fffdbefad23ecc6e1151fe2fdf5 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -37,6 +37,7 @@
 %bcond_with    systemtap       # systemtap/DTrace support
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    zts             # Zend Thread Safety
+%bcond_with    debug           # Zend Debug Build
 # - SAPI
 %bcond_without apache1         # disable building Apache 1.3.x SAPI
 %bcond_without apache2         # disable building Apache 2.x SAPI
@@ -154,7 +155,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     1
+%define                rel     2
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -165,7 +166,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.32
+Version:       5.6.40
 Release:       %{rel}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -174,7 +175,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 660cd5bc0f16eaad655b7815c757aadc
+# Source0-md5: c7dde3afb16ce7b761abf2805125d372
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -196,6 +197,7 @@ Patch8:             milter.patch
 Patch9:                libtool-tag.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
+Patch12:       openssl.patch
 Patch14:       %{orgname}-no_pear_install.patch
 Patch17:       %{orgname}-readline.patch
 Patch18:       %{orgname}-nohttpd.patch
@@ -237,6 +239,7 @@ Patch69:    fpm-conf-split.patch
 Patch70:       mysqlnd-ssl.patch
 Patch72:       phar-hash-shared.patch
 Patch73:       php-pdo-ssl.patch
+Patch74:       php-icu64.patch
 URL:           http://php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -343,7 +346,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                phpdbgver       0.4.0
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
-%define                php_debug               %{!?debug:0}%{?debug:1}
+%define                php_debug               %{!?with_debug:0}%{?with_debug:1}
 
 %if %{with gcov}
 %undefine      with_ccache
@@ -669,6 +672,8 @@ Obsoletes:  php54-devel
 Obsoletes:     php55-devel
 Obsoletes:     php70-devel
 Obsoletes:     php71-devel
+Obsoletes:     php72-devel
+Obsoletes:     php73-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -2083,6 +2088,9 @@ cp -p php.ini-production php.ini
 %{?with_milter:%patch8 -p1}
 %patch9 -p1
 %patch10 -p1
+
+%patch12 -p1
+
 %patch14 -p1
 %patch17 -p1
 %patch18 -p1
@@ -2144,6 +2152,7 @@ exit 1
 %patch70 -p1
 %patch72 -p1
 %patch73 -p1
+%patch74 -p1
 
 %{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -2350,7 +2359,7 @@ if [ ! -f _built-conf ]; then
        touch _built-conf
 fi
 export PROG_SENDMAIL="/usr/lib/sendmail"
-export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP %{rpmcppflags} \
+export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP -DOPENSSL_NO_SSL2 %{rpmcppflags} \
        -I%{_includedir}/xmlrpc-epi"
 
 sapis="
@@ -2428,7 +2437,7 @@ for sapi in $sapis; do
        --with-config-file-path=%{_sysconfdir} \
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-system-tzdata \
-       --%{!?debug:dis}%{?debug:en}able-debug \
+       --%{!?with_debug:dis}%{?with_debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-inline-optimization \
        %{__enable_disable bcmath bcmath shared} \
@@ -3163,7 +3172,7 @@ fi
 
 %files common
 %defattr(644,root,root,755)
-%doc CREDITS EXTENSIONS LICENSE NEWS README.namespaces UPGRADING* Zend/{LICENSE.Zend,ZEND_CHANGES} php.ini-*
+%doc CREDITS EXTENSIONS LICENSE NEWS README.namespaces UPGRADING* Zend/{LICENSE.Zend,ZEND_CHANGES} php.ini-* .gdbinit
 %dir %{_sysconfdir}
 %dir %{_sysconfdir}/conf.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php.ini
This page took 0.04169 seconds and 4 git commands to generate.