]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- update php 5.2 backports from http://centos.alt.ru/repository/centos/5/SRPMS/php...
[packages/php.git] / php.spec
index e948b8818735fcf85c2baf8792cafce96c008954..41bb5fb7bb125ca26e61a7bd0bc60adeb3f1d49f 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -30,6 +30,7 @@
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_with    system_gd       # with system gd (we prefer internal since it enables few more features)
+%bcond_with    system_libzip   # with system libzip (reported broken: https://bugs.php.net/bug.php?id=60100)
 %bcond_with    gd_jis_conv     # causes imagettfbbox(): any2eucjp(): invalid code in input string when internal gd used
 %bcond_with    zend_multibyte          # enable zend multibyte, mbstring can't be shared then anymore
 %bcond_without curl            # without CURL extension module
@@ -59,7 +60,7 @@
 %bcond_without apache1         # disable building Apache 1.3.x module
 %bcond_without apache2         # disable building Apache 2.x module
 %bcond_without fcgi            # disable building FCGI SAPI
-%bcond_without zts             # disable Zend Thread Safety
+%bcond_with    zts             # disable Zend Thread Safety
 %bcond_without fpm             # fpm patches from http://www.php-fpm.org/
 %bcond_without suhosin         # with suhosin patch
 %bcond_with    system_xmlrpc_epi       # use system xmlrpc-epi library (broken on 64bit arches, see http://bugs.php.net/41611)
@@ -112,7 +113,7 @@ Summary(ru.UTF-8):  PHP Версии 5 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          php
 Version:       5.2.17
-Release:       7
+Release:       10
 Epoch:         4
 License:       PHP
 Group:         Libraries
@@ -191,6 +192,7 @@ Patch55:    bug-52078-fileinode.patch
 Patch56:       %{name}-krb5.patch
 Patch57:       php-php_dl.patch
 Patch58:       php-svn-281516.patch
+Patch59:       %{name}-systzdata.patch
 # http://spot.fedorapeople.org/php-5.3.6-libzip.patch
 Patch65:       system-libzip.patch
 # CENTALT patches
@@ -200,6 +202,8 @@ Patch202: php-5.2.17-CVE-2011-1938.patch
 Patch203: php-5.2.17-CVE-2011-1148.patch
 Patch204: php-5.2.17-CVE-2011-0708.patch
 Patch205: php-5.2.17-CVE-2011-1092.patch
+Patch206: php-5.2.17-CVE-2011-0421.patch
+
 # Backport from 5.3.6
 Patch301: php-5.3.6-bug-54055.patch
 Patch302: php-5.3.6-bug-53577.patch
@@ -256,6 +260,27 @@ Patch355: php-5.3.7-bug-55323.patch
 Patch356: php-5.3.7-bug-54312.patch
 Patch357: php-5.3.7-bug-51958.patch
 Patch358: php-5.3.7-bug-54946.patch
+# 5.3.9 backport
+Patch359: php-5.2.17-CVE-2011-4566.patch
+Patch360: php-5.2.17-bug-60206.patch
+Patch361: php-5.2.17-bug-60138.patch
+Patch362: php-5.2.17-bug-60120.patch
+Patch363: php-5.2.17-bug-55674.patch
+Patch364: php-5.2.17-bug-55509.patch
+Patch365: php-5.2.17-bug-55504.patch
+Patch366: php-5.2.17-bug-52461.patch
+Patch367: php-5.2.17-bug-55366.patch
+Patch368: php-5.2.17-bug-55273.patch
+Patch369: php-5.2.17-bug-52624.patch
+Patch370: php-5.2.17-bug-43200.patch
+Patch371: php-5.2.17-bug-54682.patch
+Patch372: php-5.2.17-bug-60455.patch
+Patch373: php-5.2.17-bug-60183.patch
+Patch374: php-5.2.17-bug-55478.patch
+
+#php-5.2-max-input-vars patch
+Patch400: php-5.2.17-max-input-vars.patch
+Patch401: php-5.2.17-bug-323007-2.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -275,7 +300,7 @@ BuildRequires:      elfutils-devel
 BuildRequires: flex
 %if %{with mssql} || %{with sybase} || %{with sybase_ct}
 BuildRequires: freetds-devel
-BuildRequires: libzip-devel >= 0.10-3
+%{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10-3}
 %endif
 BuildRequires: freetype-devel >= 2.0
 %if %{with system_gd}
@@ -523,6 +548,7 @@ Group:              Libraries
 Requires:      glibc >= 6:2.3.5
 Requires:      php-dirs
 Requires:      rpm-whiteout >= 1.28
+Requires:      tzdata
 Provides:      php(date)
 Provides:      php(ereg)
 Provides:      php(libxml)
@@ -1820,7 +1846,7 @@ URL:              http://www.php.net/manual/en/book.zip.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(zip)
 Obsoletes:     php-pecl-zip
-Requires:      libzip >= 0.10-3
+%{?with_system_libzip:Requires:        libzip >= 0.10-3}
 
 %description zip
 Zip is an extension to create, modify and read zip files.
@@ -1935,13 +1961,15 @@ done
 %patch56 -p1
 %patch57 -p1
 %patch58 -p4
-%patch65 -p1
+%patch59 -p1
+%{?with_system_libzip:%patch65 -p1}
 
 %patch201 -p1 -b .CVE-2011-2202
 %patch202 -p1 -b .CVE-2011-1938
 %patch203 -p1 -b .CVE-2011-1148
 %patch204 -p1 -b .CVE-2011-0708
 %patch205 -p1 -b .CVE-2011-1092
+%patch206 -p1 -b .CVE-2011-0421
 
 # Bugfix backport from 5.3.6
 %patch301 -p1 -b .bug-54055
@@ -1999,6 +2027,25 @@ done
 %patch356 -p1 -b .bug-54312
 %patch357 -p1 -b .bug-51958
 %patch358 -p1 -b .bug-54946
+%patch359 -p1 -b .CVE-2011-4566
+%patch360 -p1 -b .bug-60206
+%patch361 -p1 -b .bug-60138
+%patch362 -p1 -b .bug-60120
+%patch363 -p1 -b .bug-55674
+%patch364 -p1 -b .bug-55509
+%patch365 -p1 -b .bug-55504
+%patch366 -p1 -b .bug-52461
+%patch367 -p1 -b .bug-55366
+%patch368 -p1 -b .bug-55273
+%patch369 -p1 -b .bug-52624
+%patch370 -p1 -b .bug-43200
+%patch371 -p1 -b .bug-54682
+%patch372 -p1 -b .bug-60455
+%patch373 -p1 -b .bug-60183
+%patch374 -p1 -b .bug-55478
+
+%patch400 -p1 -b .php-5.2-max-input-vars
+%patch401 -p1 -b .bug-323007
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
@@ -2118,6 +2165,7 @@ for sapi in $sapis; do
        --with-config-file-path=%{_sysconfdir} \
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-exec-dir=%{_bindir} \
+       --with-system-tzdata \
        --%{!?debug:dis}%{?debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        %{?with_suhosin:--enable-suhosin} \
@@ -2224,7 +2272,7 @@ for sapi in $sapis; do
        --with-xsl=shared \
        --with-zlib=shared \
        --with-zlib-dir=shared,/usr \
-       --with-libzip \
+       %{?with_system_libzip:--with-libzip} \
        --enable-zip=shared,/usr \
 
        cp -f Makefile Makefile.$sapi
@@ -2307,7 +2355,10 @@ generate_inifiles
 PHP=./sapi/cli/php EXTENSION_DIR=modules CONFIG_DIR=conf.d ./dep-tests.sh > dep-tests.log
 if grep -v OK dep-tests.log; then
        echo >&2 "The results above were not expected"
+# TEMP: ac-i386 builder is broken
+%ifnarch i386
        exit 1
+%endif
 fi
 
 
@@ -3243,6 +3294,15 @@ fi
 %{php_data_dir}/tests/php/quicktester.inc
 %attr(755,root,root) %{php_data_dir}/tests/php/run-tests.php
 
+# random junk, didn't check, maybe can be just removed
+%{php_data_dir}/tests/php/bin-info.inc
+%{php_data_dir}/tests/php/foo*
+%{php_data_dir}/tests/php/odbc*.php
+%{php_data_dir}/tests/php/recurse
+%{php_data_dir}/tests/php/run.*
+%{php_data_dir}/tests/php/scan_cases
+%{php_data_dir}/tests/php/test*
+
 %if %{with tidy}
 %files tidy
 %defattr(644,root,root,755)
This page took 0.045361 seconds and 4 git commands to generate.