]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- fix release naming scheme
[packages/php.git] / php.spec
index 39e20df99214f0fcd138d672c6339a4992a994e2..02ebd3dc751001c22f51f30f97e8c646706d9c02 100644 (file)
--- a/php.spec
+++ b/php.spec
 %undefine      with_filter
 %endif
 
-%define                rel     2
-%define                subver  RC6
+%define                rel     1
+%define                subver  RC7
 %define                orgname php
 %define                ver_suffix 70
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -152,7 +152,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.0.0
-Release:       %{rel}.%{subver}
+Release:       2.%{subver}.%{rel}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -161,8 +161,8 @@ License:    PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
 Source0:       https://downloads.php.net/~ab/php-%{version}%{subver}.tar.xz
-# Source0-md5: 809731123f62a9fcc706385de9a5dc5b
-Source2:       %{orgname}-mod_%{orgname}.conf
+# Source0-md5: 5bb4e6b8bf969d2bd5ab222c60c52dad
+Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
 Source5:       %{orgname}-cli.ini
@@ -221,6 +221,7 @@ Patch67:    mysql-lib-ver-mismatch.patch
 Patch68:       php-mysql-ssl-context.patch
 Patch69:       fpm-conf-split.patch
 Patch70:       mysqlnd-ssl.patch
+Patch71:       libdb-info.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -2000,6 +2001,7 @@ exit 1
 %patch67 -p1
 #%patch68 -p1 DROP or update to 7.0 APIs
 %patch70 -p1
+%patch71 -p1
 
 sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -2065,13 +2067,31 @@ mv Zend/tests/bug39438.phpt{,.disable}
 %{__rm} -r ext/sqlite3/tests
 %endif
 
+# ----- Manage known as failed test -------
+# affected by systzdata patch
+%{__rm} ext/date/tests/timezone_location_get.phpt
+%{__rm} ext/date/tests/timezone_version_get.phpt
+%{__rm} ext/date/tests/timezone_version_get_basic1.phpt
+# Should be skipped but fails sometime
+%{__rm} ext/standard/tests/file/file_get_contents_error001.phpt
+# fails sometimes
+%{__rm} ext/sockets/tests/mcast_ipv?_recv.phpt
+# causes stack exhausion
+%{__rm} Zend/tests/bug54268.phpt
+%{__rm} Zend/tests/bug68412.phpt
+
+# avoid issues when two builds run simultaneously
+%ifarch %{x8664}
+sed -e 's/64321/64322/' -i ext/openssl/tests/*.phpt
+%endif
+
 # skip XFAILs
 # no point testing stuff that is knowingly broken
-find -name '*.phpt' | xargs grep XFAIL -l | xargs rm -v
+find -name '*.phpt' | xargs grep '^--XFAIL--' -l | xargs rm -v
 
 env \
 %ifarch %{ix86}
-ix86= x8664=:
+ix86= x8664=: \
 %endif
 %ifarch %{x8664}
 ix86=: x8664= \
@@ -2467,6 +2487,7 @@ exit 1
 cat <<'EOF' > run-tests.sh
 #!/bin/sh
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
+export SKIP_ONLINE_TESTS=1
 unset TZ LANG LC_ALL || :
 %{__make} test \
        EXTENSION_DIR=modules \
This page took 0.033331 seconds and 4 git commands to generate.