]> git.pld-linux.org Git - packages/phpunit.git/blobdiff - php-phpunit-PHPUnit.spec
- deps from proper channel, version up to 3.5.2
[packages/phpunit.git] / php-phpunit-PHPUnit.spec
index a9fa628ec917741a57714d129b25b538c9832ed1..38eb2c742eafa84473f223422cebc36b6db19abc 100644 (file)
@@ -6,29 +6,53 @@
 %define                _class          PHPUnit
 %define                _status         stable
 %define                _pearname       %{_class}
+%define                php_min_version 5.2.7
 Summary:       %{_pearname} - regression testing framework for unit tests
 Summary(pl.UTF-8):     %{_pearname} - zestaw testów regresyjnych
 Name:          php-%{_pearname}
-Version:       3.4.15
-Release:       2
+Version:       3.5.2
+Release:       0.1
 License:       BSD
 Group:         Development/Languages/PHP
 Source0:       http://pear.phpunit.de/get/PHPUnit-%{version}.tgz
-# Source0-md5: a36105b20467aca3f815704fec440a1f
+# Source0-md5: ea0e53d8bfe0ca8dadc9d22b953909b9
 URL:           http://www.phpunit.de/
+BuildRequires: php-channel(components.ez.no)
 BuildRequires: php-channel(pear.phpunit.de)
 BuildRequires: php-channel(pear.symfony-project.com)
 BuildRequires: php-pear >= 4:1.1-2
-BuildRequires: php-pear-PEAR
+BuildRequires: php-pear-PEAR >= 1:1.9.1
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.473
-Requires:      php-common >= 4:5.1.4
+Requires:      php-channel(pear.phpunit.de)
+Requires:      php-common >= 4:%{php_min_version}
+Requires:      php-dom
+Requires:      php-pcre
 Requires:      php-pear >= 4:1.1-2
+Requires:      php-phpunit-DbUnit >= 1.0.0
+Requires:      php-phpunit-File_Iterator >= 1.2.3
+Requires:      php-phpunit-PHPUnit_MockObject >= 1.0.0
+Requires:      php-phpunit-PHPUnit_Selenium >= 1.0.0
+Requires:      php-phpunit-PHP_CodeCoverage >= 1.0.0
+Requires:      php-phpunit-PHP_Timer >= 1.0.0
+Requires:      php-phpunit-Text_Template >= 1.0.0
+Requires:      php-reflection
+Requires:      php-spl
+Requires:      php-symfony-YAML >= 1.0.2
+Suggests:      php-dbus
+Suggests:      php-json
+Suggests:      php-pdo
+Suggests:      php-soap
+Suggests:      php-tokenizer
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # exclude optional dependencies
-%define                _noautoreq      pear(Image/GraphViz.*) pear(Log.*) pear(SymfonyComponents/.*) pear(XML/RPC2/Client.php)
+%define                dep_optional    pear(Image/GraphViz.*) pear(Log.*) pear(SymfonyComponents/.*) pear(XML/RPC2/Client.php)
+%define                dep_missing1            pear(File/Iterator/Factory.php) pear(PHP/CodeCoverage.*) pear(PHP/Timer.php) pear(Text/Template.php)
+
+# put it together for rpmbuild
+%define                _noautoreq      %{?dep_optional} %{?dep_missing}
 
 %description
 PHPUnit is a regression testing framework used by the developer who
@@ -65,7 +89,7 @@ Testy dla PEAR::%{_pearname}.
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{php_pear_dir}
 install -d $RPM_BUILD_ROOT%{_bindir}
-install usr/bin/phpunit $RPM_BUILD_ROOT%{_bindir}
+install -p usr/bin/phpunit $RPM_BUILD_ROOT%{_bindir}
 %pear_package_install
 
 %clean
This page took 0.035414 seconds and 4 git commands to generate.