]> git.pld-linux.org Git - packages/php-pecl-zip.git/blobdiff - php-pecl-zip.spec
- release 2 (by relup.sh)
[packages/php-pecl-zip.git] / php-pecl-zip.spec
index 64a1b277a7c19d6099cc4f7227b437b81c45239f..1bce30d29edb5af3932a94cb6c1a505166ede461 100644 (file)
@@ -1,72 +1,69 @@
-%define                _modname        zip
-%define                _status         alpha
-%define                _sysconfdir     /etc/php
-%define                extensionsdir   %(php-config --extension-dir 2>/dev/null)
-
-Summary:       %{_modname} - a zip management extension
-Summary(pl):   %{_modname} - zarz±dzanie archiwami zip
-Name:          php-pecl-%{_modname}
-Version:       1.5.0
-Release:       1
+%define                php_name        php%{?php_suffix}
+%define                modname zip
+%define                status          stable
+Summary:       %{modname} - a zip management extension
+Summary(pl.UTF-8):     %{modname} - zarządzanie archiwami zip
+Name:          %{php_name}-pecl-%{modname}
+Version:       1.10.2
+Release:       2
 License:       PHP 2.02
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
-# Source0-md5: cea41efb3a3c5642d119081801bd0d1c
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
+# Source0-md5: 0a779255388fa7c9ea4b3fcead55cc69
 URL:           http://pecl.php.net/package/zip/
-BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.254
+BuildRequires: %{php_name}-devel >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.650
 BuildRequires: zziplib-devel
 %{?requires_php_extension}
-Requires:      %{_sysconfdir}/conf.d
-Obsoletes:     php-pear-%{_modname}
+Requires:      php-common >= 4:5.0.4
+Provides:      php(zip)
+Obsoletes:     php-pear-%{modname}
 Obsoletes:     php-zip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Zip is an extension to create, modify and read zip files.
 
-In PECL status of this package is: %{_status}.
+In PECL status of this package is: %{status}.
 
-%description -l pl
-Zip jest rozszerzeniem umo¿liwiaj±cym tworzenie, modyfikacjê oraz
-odczyt archiwów zip.
+%description -l pl.UTF-8
+Zip jest rozszerzeniem umożliwiającym tworzenie, modyfikację oraz
+odczyt archiwów zip.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
+install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-[ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
-[ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
+%php_webserver_restart
 
 %postun
 if [ "$1" = 0 ]; then
-       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
-       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
+       %php_webserver_restart
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/CREDITS
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{extensionsdir}/%{_modname}.so
+%doc CREDITS
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.056707 seconds and 4 git commands to generate.