]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blobdiff - php-pecl-memcache.spec
fix self-test on php 7.4; always do module load test
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
index 1e8f01c121d2d2076a4c8956a349f327dc34c5f3..eae669074cade4e482f74d591e555b7672c16ab2 100644 (file)
 Summary:       %{modname} - a memcached extension
 Summary(pl.UTF-8):     %{modname} - rozszerzenie memcached
 Name:          %{php_name}-pecl-%{modname}
-Version:       3.0.9
-Release:       2
+Version:       4.0.4
+Release:       1
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-#Source0:      http://pecl.php.net/get/%{modname}-%{version}.tgz
-# https://github.com/websupport-sk/pecl-memcache/commits/NON_BLOCKING_IO_php7
-Source0:       https://github.com/websupport-sk/pecl-memcache/archive/%{commit}/%{modname}-%{version}-%{commit}.tar.gz
-# Source0-md5: 945e6a30b3cac160abf9b6d103c5676b
+Source0:       https://github.com/websupport-sk/pecl-memcache/archive/%{version}/%{modname}-%{version}.tar.gz
+# Source0-md5: 612c575eccc18d98484b72c0cff6907a
 Source1:       %{modname}.ini
 Source2:       %{modname}-apache.conf
 Source3:       %{modname}-lighttpd.conf
 Source4:       config.php
 Patch0:                %{modname}-webapp.patch
-URL:           http://pecl.php.net/package/memcache/
-BuildRequires: %{php_name}-devel >= 3:5.0.0
+URL:           https://github.com/websupport-sk/pecl-memcache/
+BuildRequires: %{php_name}-devel >= 3:7.0.0
+BuildRequires: %{php_name}-pcre
+BuildRequires: %{php_name}-session
+BuildRequires: %{php_name}-simplexml
+BuildRequires: %{php_name}-spl
 BuildRequires: %{php_name}-xml
 BuildRequires: php-packagexml2cl
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.650
 %if %{with tests}
 BuildRequires: %{php_name}-cli
-BuildRequires: %{php_name}-pcre
-BuildRequires: %{php_name}-session
-BuildRequires: %{php_name}-spl
 BuildRequires: memcached
 %endif
 %{?requires_php_extension}
@@ -93,10 +92,19 @@ memcache.
 mv pecl-%{modname}-*/{.??*,*} .
 %patch0 -p1
 
-# locks up on carme, likely due udp very long timeout
-rm tests/039.phpt
-rm tests/041.phpt
-rm tests/042.phpt
+cat <<'EOF' > run-tests.sh
+#!/bin/sh
+export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
+exec %{__make} test \
+       PHP_EXECUTABLE=%{__php} \
+%if "%php_major_version.%php_minor_version" >= "7.4"
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="simplexml session" \
+%else
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl simplexml session" \
+%endif
+       RUN_TESTS_SETTINGS="-q $*"
+EOF
+chmod +x run-tests.sh
 
 # skip failed tests
 xfail() {
@@ -125,18 +133,18 @@ memcache->delete() with load balancing [tests/026.phpt]
 memcache->addServer() adding server in failed mode [tests/031.phpt]
 memcache->getServerStatus(), memcache->setServerParams() [tests/032.phpt]
 memcache::connect() with unix domain socket [tests/035.phpt]
-memcache->get() over UDP [tests/038.phpt]
+ini_set('session.save_handler') [tests/036.phpt]
+ini_set('session.save_path') [tests/036b.phpt]
 memcache->increment()/decrement() with multiple keys [tests/040.phpt]
+memcache->delete() with multiple keys [tests/041.phpt]
+memcache->set() with multiple values [tests/042.phpt]
 ini_set('memcache.redundancy') [tests/043.phpt]
 ini_set('memcache.session_redundancy') [tests/044.phpt]
+ini_set('memcache.session_redundancy') [tests/044b.phpt]
 hash strategies and functions [tests/046.phpt]
 ini_set('session.save_handler') with unix domain socket [tests/053.phpt]
-FLAKY: memcache->addServer() with microsecond timeout [tests/056.phpt]
-ini_set('session.save_handler') [tests/036.phpt]
-ini_set("memcache.allow_failover") [tests/029.phpt]
-%if "%{php_major_version}.%{php_minor_version}" >= "7.1"
-strange keys [tests/005.phpt]
-%endif
+memcache multi host save path function [tests/bug73539.phpt]
+session_regenerate_id() should not cause fatal error [tests/githubbug13.phpt]
 EOF
 
 %build
@@ -146,32 +154,28 @@ phpize
        --with-zlib-dir=/usr
 %{__make}
 
-%if %{with tests}
 # simple module load test
 %{__php} -n -q \
        -d extension_dir=modules \
+%if "%php_major_version.%php_minor_version" >= "7.4"
+       -d extension=%{php_extensiondir}/simplexml.so \
+       -d extension=%{php_extensiondir}/session.so \
+%else
        -d extension=%{php_extensiondir}/pcre.so \
        -d extension=%{php_extensiondir}/spl.so \
+       -d extension=%{php_extensiondir}/simplexml.so \
        -d extension=%{php_extensiondir}/session.so \
+%endif
        -d extension=%{modname}.so \
        -m > modules.log
 grep %{modname} modules.log
 
-cat <<'EOF' > run-tests.sh
-#!/bin/sh
-export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
-exec %{__make} test \
-       PHP_EXECUTABLE=%{__php} \
-       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl session" \
-       RUN_TESTS_SETTINGS="-q $*"
-EOF
-chmod +x run-tests.sh
-
+%if %{with tests}
 # Launch the Memcached service and stop it on exit
 %{_sbindir}/memcached -p 11211 -U 11211 -d -P $PWD/memcached.pid
 trap 'kill $(cat memcached.pid)' EXIT INT
 
-./run-tests.sh
+./run-tests.sh --show-diff
 %endif
 
 %install
This page took 0.318592 seconds and 4 git commands to generate.