]> git.pld-linux.org Git - packages/php-pecl-intl.git/blobdiff - php-pecl-intl.spec
- release 4
[packages/php-pecl-intl.git] / php-pecl-intl.spec
index 143a63024b690e6e068fe0088dacb344801b77f2..748ab360040aca1dfa31bfbd0131eb53d0ce7b29 100644 (file)
@@ -1,38 +1,48 @@
-%define                _modname        intl
-%define                _status         stable
-Summary:       %{_modname} - Internationalization extension
-Summary(pl.UTF-8):     %{_modname} - rozszerzenie internacjonalizacji
-Name:          php-pecl-%{_modname}
-Version:       1.0.2
-Release:       2
+%define                modname         intl
+%define                status          stable
+Summary:       %{modname} - Internationalization extension
+Summary(pl.UTF-8):     %{modname} - rozszerzenie internacjonalizacji
+Name:          php-pecl-%{modname}
+Version:       1.1.1
+Release:       4
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
-# Source0-md5: c68272f7dfacde9de8b44c57bae31be6
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
+# Source0-md5: f69e662ff0125eb991597be9b5116d96
+Patch0:                zend_arg_info_static.patch
+Patch1:                z_refcount.patch
 URL:           http://pecl.php.net/package/intl/
 BuildRequires: libicu-devel >= 3.4.0-1
+BuildRequires: libstdc++-devel
 BuildRequires: php-devel >= 3:5.0.0
+BuildRequires: pkgconfig
+BuildRequires: re2c
 BuildRequires: rpmbuild(macros) >= 1.344
 %{?requires_php_extension}
-Requires:      php-common >= 4:5.0.4
+Provides:      php(intl)
+Obsoletes:     php-pecl-idn
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Internationalization extension implements ICU library functionality in
 PHP.
 
-In PECL status of this extension is: %{_status}.
+Since 1.0.2 it also integrates IDN functions.
+
+In PECL status of this extension is: %{status}.
 
 %description -l pl.UTF-8
 Rozszerzenie to posiada zaimplementowaną obsługę biblioteki ICU.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
+%patch0 -p1
+%patch1 -p1
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
@@ -42,12 +52,11 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
 
 %{__make} install \
-       -C %{_modname}-%{version} \
-       INSTALL_ROOT=$RPM_BUILD_ROOT \
-       EXTENSION_DIR=%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+       EXTENSION_DIR=%{php_extensiondir} \
+       INSTALL_ROOT=$RPM_BUILD_ROOT
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -63,6 +72,6 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{doc/,CREDITS}
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%doc doc/* CREDITS
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.201043 seconds and 4 git commands to generate.