]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blobdiff - php-pecl-imagick.spec
- release 3 (by relup.sh)
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
index 9d8b45073402e76dde3ec71105b805d2eee07142..fbd801dbd39a2ef2f3873b515ddddfbd425e19c3 100644 (file)
@@ -5,26 +5,27 @@
 %define                php_name        php%{?php_suffix}
 %define                modname         imagick
 %define                status          stable
+%define                libversion      %(pkg-config --modversion MagickCore 2>/dev/null || echo ERROR)
 Summary:       %{modname} - PHP wrapper to the Image Magick Library
 Summary(pl.UTF-8):     %{modname} - PHP-owy wrapper do biblioteki Image Magick
 Name:          %{php_name}-pecl-%{modname}
-Version:       3.4.2
+Version:       3.4.4
 Release:       3
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
-# Source0-md5: 3f80e35c2434636cdb5df01b221b3ffa
+Source0:       https://pecl.php.net/get/%{modname}-%{version}.tgz
+# Source0-md5: 6d3a7048ab73b0fab931f28c484dbf76
 Patch0:                skip_version_check.patch
-URL:           http://pecl.php.net/package/imagick/
+URL:           https://pecl.php.net/package/imagick
+BuildRequires: %{php_name}-cli
 BuildRequires: %{php_name}-devel >= 4:5.3
+BuildRequires: %{php_name}-pcre
+BuildRequires: %{php_name}-spl
 BuildRequires: ImageMagick-devel >= 1:6.2.4.0
 BuildRequires: pkgconfig
 BuildRequires: re2c
 BuildRequires: rpmbuild(macros) >= 1.650
 %if %{with tests}
-BuildRequires: %{php_name}-cli
-BuildRequires: %{php_name}-pcre
-BuildRequires: %{php_name}-spl
 BuildRequires: ImageMagick-coder-jpeg
 BuildRequires: ImageMagick-coder-png
 BuildRequires: ImageMagick-coder-tiff
@@ -36,6 +37,7 @@ Suggests:     ImageMagick-coder-jpeg
 Suggests:      ImageMagick-coder-png
 Suggests:      ImageMagick-coder-tiff
 Provides:      php(imagick) = %{version}
+Provides:      php(lib-imagick) = %{libversion}
 Obsoletes:     php-pecl-imagick < 3.1.2-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -80,6 +82,7 @@ Test() {
 }
 # skip failing tests
 Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
+Test Imagick, setRegistry and getRegistry [tests/150_Imagick_setregistry.phpt]
 Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
 Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
 Test ImagickDraw, setFontFamily [tests/207_ImagickDraw_setFontFamily_basic.phpt]
@@ -94,6 +97,9 @@ Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_bas
 Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
 Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
 Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
+Test Imagick, Imagick::exportImagePixels [tests/256_Imagick_exportImagePixels_basic.phpt]
+Test ImagickDraw, getTextDirection [tests/264_ImagickDraw_getTextDirection_basic.phpt]
+Test ImagickDraw, getFontResolution [tests/266_ImagickDraw_getFontResolution_basic.phpt]
 %ifarch x32
 # Fail on 7.0
 Test Imagick, quantizeImage [tests/101_Imagick_quantizeImage_basic.phpt]
@@ -101,6 +107,8 @@ Test Imagick, uniqueImageColors [tests/163_Imagick_uniqueImageColors_basic.phpt]
 Test Tutorial, deconstructGif [tests/237_Tutorial_deconstructGif_basic.phpt]
 Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIteratorRow_basic.phpt]
 %endif
+# Fail on 5.3, 5.5, 5.6, 7.0, 7.1, 7.2
+Test Tutorial, fxAnalyzeImage [tests/229_Tutorial_fxAnalyzeImage_case1.phpt]
 
 %build
 phpize
@@ -110,20 +118,24 @@ phpize
 %{__make} \
        CFLAGS_CLEAN="%{rpmcflags}"
 
-%if %{with tests}
 %{__php} -n -q \
        -d extension_dir=modules \
+%if "%php_major_version.%php_minor_version" < "7.4"
        -d extension=%{php_extensiondir}/pcre.so \
        -d extension=%{php_extensiondir}/spl.so \
+%endif
        -d extension=%{modname}.so \
        -m > modules.log
 grep %{modname} modules.log
 
+%if %{with tests}
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
 %{__make} test \
        PHP_EXECUTABLE=%{__php} \
+%if "%php_major_version.%php_minor_version" < "7.4"
        PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl" \
 %endif
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.153728 seconds and 4 git commands to generate.