]> git.pld-linux.org Git - packages/php-pecl-big_int.git/blobdiff - php-pecl-big_int.spec
- use new php extension related macros
[packages/php-pecl-big_int.git] / php-pecl-big_int.spec
index 301bc8b34c522585b88239857e7d5e786f337f1b..95591b653e738f15dcad94d7cb654baf0e58388d 100644 (file)
@@ -1,22 +1,19 @@
 %define                _modname        big_int
 %define                _status         stable
-%define                _sysconfdir     /etc/php
-%define                extensionsdir   %(php-config --extension-dir 2>/dev/null)
-
 Summary:       %{_modname} - set of functions for calculations with arbitrary length integers
 Summary(pl):   %{_modname} - zestaw funkcji do obliczeñ z u¿yciem liczb o dowolnej wielko¶ci
 Name:          php-pecl-%{_modname}
-Version:       1.0.6
-Release:       2
+Version:       1.0.7
+Release:       1
 License:       PHP 2.02
 Group:         Development/Languages/PHP
 Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
-# Source0-md5: 844332ab0a40ea12aa8339d7d2c20770
+# Source0-md5: d858d5bcfd3f789cb1ae8cb8ff09d3e9
 URL:           http://pecl.php.net/package/big_int/
 BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.238
-%requires_php_extension
-Requires:      %{_sysconfdir}/conf.d
+BuildRequires: rpmbuild(macros) >= 1.344
+%{?requires_php_extension}
+Requires:      php-common >= 4:5.0.4
 Obsoletes:     php-pear-%{_modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -60,10 +57,10 @@ phpize
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
+install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
+install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
 ; Enable %{_modname} extension module
 extension=%{_modname}.so
 EOF
@@ -72,17 +69,15 @@ EOF
 rm -rf $RPM_BUILD_ROOT
 
 %post
-[ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
-[ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
+%php_webserver_restart
 
 %postun
 if [ "$1" = 0 ]; then
-       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
-       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
+       %php_webserver_restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc %{_modname}-%{version}/{docs,tests,CREDITS,README}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{extensionsdir}/%{_modname}.so
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.031251 seconds and 4 git commands to generate.